summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-20 22:08:09 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-20 22:08:09 +0000
commit7a54cbc5b7dfe9e7429166b38bfdbca0e7befc45 (patch)
treeb3a6314d2e7ccd18a52565e8dc554ec3fa72c68f /net-misc/vino
parentAdd net-misc/vino to gnome 2.32 mask (diff)
downloadgentoo-2-7a54cbc5b7dfe9e7429166b38bfdbca0e7befc45.tar.gz
gentoo-2-7a54cbc5b7dfe9e7429166b38bfdbca0e7befc45.tar.bz2
gentoo-2-7a54cbc5b7dfe9e7429166b38bfdbca0e7befc45.zip
Version bump. Enhance telepathy tubes, internals clean up and translation updates.
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/vino')
-rw-r--r--net-misc/vino/ChangeLog8
-rw-r--r--net-misc/vino/vino-2.32.0.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/net-misc/vino/ChangeLog b/net-misc/vino/ChangeLog
index a60b14fa6399..57c7a6381e6a 100644
--- a/net-misc/vino/ChangeLog
+++ b/net-misc/vino/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vino
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/ChangeLog,v 1.152 2010/10/09 15:23:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/ChangeLog,v 1.153 2010/10/20 22:08:09 eva Exp $
+
+*vino-2.32.0 (20 Oct 2010)
+
+ 20 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> +vino-2.32.0.ebuild:
+ Version bump. Enhance telepathy tubes, internals clean up and translation
+ updates.
09 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> vino-2.28.2.ebuild:
ppc64 stable wrt #324077
diff --git a/net-misc/vino/vino-2.32.0.ebuild b/net-misc/vino/vino-2.32.0.ebuild
new file mode 100644
index 000000000000..bba7d2f923c3
--- /dev/null
+++ b/net-misc/vino/vino-2.32.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/vino-2.32.0.ebuild,v 1.1 2010/10/20 22:08:09 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="An integrated VNC server for GNOME"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi crypt ipv6 jpeg gnome-keyring libnotify networkmanager ssl +telepathy zlib"
+
+RDEPEND=">=dev-libs/glib-2.17:2
+ >=x11-libs/gtk+-2.20:2
+ >=gnome-base/gconf-2
+ >=sys-apps/dbus-1.2.3
+ >=net-libs/libsoup-2.24:2.4
+ >=dev-libs/libunique-1
+ dev-libs/dbus-glib
+ x11-libs/libXext
+ x11-libs/libXtst
+ avahi? ( >=net-dns/avahi-0.6[dbus] )
+ crypt? ( >=dev-libs/libgcrypt-1.1.90 )
+ gnome-keyring? ( || ( gnome-base/libgnome-keyring <gnome-base/gnome-keyring-2.29.4 ) )
+ jpeg? ( media-libs/jpeg )
+ libnotify? ( >=x11-libs/libnotify-0.4.4 )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ ssl? ( >=net-libs/gnutls-1 )
+ telepathy? ( >=net-libs/telepathy-glib-0.11.6 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ || (
+ gnome-base/libgnome-keyring
+ <gnome-base/gnome-keyring-2.29.4 )"
+# keyring is always required at build time per bug 322763
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable avahi)
+ $(use_enable crypt gcrypt)
+ $(use_enable ipv6)
+ $(use_with jpeg)
+ $(use_enable gnome-keyring)
+ $(use_enable libnotify)
+ $(use_enable networkmanager network-manager)
+ $(use_enable ssl gnutls)
+ $(use_enable telepathy)
+ $(use_with zlib)
+ $(use_with zlib libz)
+ --enable-libunique"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix autorestart loop, bug #277989
+ epatch "${FILESDIR}/${PN}-2.26.2-autorestart-loop.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "If you are getting refresh problems when using special 3D effects,"
+ elog "try disabling XDamage extension. For that, you can run the following:"
+ elog " gconftool-2 --type boolean --set /desktop/gnome/remote_access/disable_xdamage true"
+ elog "This is due http://bugs.freedesktop.org/12255"
+}