summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 18:01:53 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 18:01:53 +0000
commit19702211a5c7ff56582c9174934e7761fab70426 (patch)
treec7e9184d7b0511368fea8a369067a201999578aa /net-misc/vinagre
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-19702211a5c7ff56582c9174934e7761fab70426.tar.gz
gentoo-2-19702211a5c7ff56582c9174934e7761fab70426.tar.bz2
gentoo-2-19702211a5c7ff56582c9174934e7761fab70426.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-misc/vinagre')
-rw-r--r--net-misc/vinagre/ChangeLog7
-rw-r--r--net-misc/vinagre/vinagre-3.12.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-misc/vinagre/ChangeLog b/net-misc/vinagre/ChangeLog
index 36bd02c461e7..602c9bd1857d 100644
--- a/net-misc/vinagre/ChangeLog
+++ b/net-misc/vinagre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vinagre
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.102 2014/04/27 09:02:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.103 2014/04/27 18:01:53 eva Exp $
+
+*vinagre-3.12.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +vinagre-3.12.1.ebuild:
+ Version bump for Gnome 3.12.
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -vinagre-3.8.3.ebuild:
drop old
diff --git a/net-misc/vinagre/vinagre-3.12.1.ebuild b/net-misc/vinagre/vinagre-3.12.1.ebuild
new file mode 100644
index 000000000000..1c6590f8fc28
--- /dev/null
+++ b/net-misc/vinagre/vinagre-3.12.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/vinagre-3.12.1.ebuild,v 1.1 2014/04/27 18:01:53 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION=0.18
+
+inherit gnome2 vala
+
+DESCRIPTION="VNC client for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Vinagre"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avahi rdp +ssh spice +telepathy"
+
+# cairo used in vinagre-tab
+# gdk-pixbuf used all over the place
+# FIXME: uses xfreerdp ???
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.9.6:3
+ app-crypt/libsecret
+ >=dev-libs/libxml2-2.6.31:2
+ >=net-libs/gtk-vnc-0.4.3[gtk3]
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-themes/gnome-icon-theme
+
+ avahi? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
+ rdp? ( net-misc/freerdp )
+ ssh? ( >=x11-libs/vte-0.20:2.90 )
+ spice? ( >=net-misc/spice-gtk-0.5[gtk3] )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.11.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
+ gnome2_src_configure \
+ $(use_with avahi) \
+ $(use_enable rdp) \
+ $(use_enable ssh) \
+ $(use_enable spice) \
+ $(use_with telepathy) \
+ ITSTOOL=$(type -P true)
+}