summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-12-23 23:08:46 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-12-23 23:08:46 +0000
commit07c2d710a6a6151a3eca3ad25094b001dd13ea4d (patch)
treef56e459b75b08cb512af5ec7457f20bc0536a381 /net-misc/vinagre
parentVersion bump for Gnome 3.14. Clean up old revision. (diff)
downloadgentoo-2-07c2d710a6a6151a3eca3ad25094b001dd13ea4d.tar.gz
gentoo-2-07c2d710a6a6151a3eca3ad25094b001dd13ea4d.tar.bz2
gentoo-2-07c2d710a6a6151a3eca3ad25094b001dd13ea4d.zip
Version bump for Gnome 3.14. Dropped keywords due to bug #523924.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-misc/vinagre')
-rw-r--r--net-misc/vinagre/ChangeLog7
-rw-r--r--net-misc/vinagre/vinagre-3.14.3.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-misc/vinagre/ChangeLog b/net-misc/vinagre/ChangeLog
index d769c3fc2149..c2be4a1a170f 100644
--- a/net-misc/vinagre/ChangeLog
+++ b/net-misc/vinagre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vinagre
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.109 2014/11/13 12:31:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.110 2014/12/23 23:08:46 eva Exp $
+
+*vinagre-3.14.3 (23 Dec 2014)
+
+ 23 Dec 2014; Gilles Dartiguelongue <eva@gentoo.org> +vinagre-3.14.3.ebuild:
+ Version bump for Gnome 3.14. Dropped keywords due to bug #523924.
13 Nov 2014; Pacho Ramos <pacho@gentoo.org>
-files/vinagre-2.30.3-gmodule.patch, -vinagre-2.30.3.ebuild, metadata.xml:
diff --git a/net-misc/vinagre/vinagre-3.14.3.ebuild b/net-misc/vinagre/vinagre-3.14.3.ebuild
new file mode 100644
index 000000000000..502d376002a7
--- /dev/null
+++ b/net-misc/vinagre/vinagre-3.14.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/vinagre-3.14.3.ebuild,v 1.1 2014/12/23 23:08:46 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION=0.18
+
+inherit gnome2 vala
+
+DESCRIPTION="VNC client for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Vinagre"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="avahi rdp +ssh spice +telepathy"
+
+# cairo used in vinagre-tab
+# gdk-pixbuf used all over the place
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.9.6:3
+ app-crypt/libsecret
+ >=dev-libs/libxml2-2.6.31:2
+ >=net-libs/gtk-vnc-0.4.3[gtk3]
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-themes/hicolor-icon-theme
+
+ avahi? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
+ rdp? ( net-misc/freerdp )
+ ssh? ( >=x11-libs/vte-0.20:2.91 )
+ spice? (
+ app-emulation/spice-protocol
+ >=net-misc/spice-gtk-0.5[gtk3] )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.11.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
+ gnome2_src_configure \
+ $(use_with avahi) \
+ $(use_enable rdp) \
+ $(use_enable ssh) \
+ $(use_enable spice) \
+ $(use_with telepathy) \
+ ITSTOOL=$(type -P true)
+}