summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-02-12 13:53:11 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-02-12 13:53:11 +0000
commit9f8b06667953ae8d63767115ee5740e13100dea9 (patch)
treee354a4c95f3269d19cbb3536ef770feadf397737 /net-misc/vidalia
parentFreeImage License (diff)
downloadgentoo-2-9f8b06667953ae8d63767115ee5740e13100dea9.tar.gz
gentoo-2-9f8b06667953ae8d63767115ee5740e13100dea9.tar.bz2
gentoo-2-9f8b06667953ae8d63767115ee5740e13100dea9.zip
Two version bumps
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/vidalia')
-rw-r--r--net-misc/vidalia/ChangeLog9
-rw-r--r--net-misc/vidalia/vidalia-0.2.16.ebuild37
-rw-r--r--net-misc/vidalia/vidalia-0.2.17.ebuild37
3 files changed, 82 insertions, 1 deletions
diff --git a/net-misc/vidalia/ChangeLog b/net-misc/vidalia/ChangeLog
index fa303f6cc973..baa0961e5af3 100644
--- a/net-misc/vidalia/ChangeLog
+++ b/net-misc/vidalia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/vidalia
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.27 2012/02/01 17:05:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.28 2012/02/12 13:53:11 blueness Exp $
+
+*vidalia-0.2.17 (12 Feb 2012)
+*vidalia-0.2.16 (12 Feb 2012)
+
+ 12 Feb 2012; Anthony G. Basile <blueness@gentoo.org> +vidalia-0.2.16.ebuild,
+ +vidalia-0.2.17.ebuild:
+ Two version bumps
01 Feb 2012; Brent Baude <ranger@gentoo.org> vidalia-0.2.12.ebuild:
Marking vidalia-0.2.12 ppc for bug 381243
diff --git a/net-misc/vidalia/vidalia-0.2.16.ebuild b/net-misc/vidalia/vidalia-0.2.16.ebuild
new file mode 100644
index 000000000000..b0a94c4d1f1f
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.2.16.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.2.16.ebuild,v 1.1 2012/02/12 13:53:11 blueness Exp $
+
+EAPI="4"
+
+inherit eutils qt4-r2 cmake-utils
+# cmake-utils needs to be last, so we get its src_compile()
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="https://www.torproject.org/projects/vidalia.html.en"
+SRC_URI="https://www.torproject.org/dist/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 ) openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug +tor"
+
+DEPEND="x11-libs/qt-gui:4[debug?]"
+RDEPEND="${DEPEND}
+ tor? ( net-misc/tor )"
+
+DOCS="CHANGELOG CREDITS README"
+
+pkg_postinst() {
+ ewarn
+ if use tor; then
+ ewarn "To have vidalia starting tor, you probably have to copy"
+ ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
+ ewarn "the settings there and change the socks. Also, in vidalia"
+ ewarn "change the default user under which tor will run."
+ else
+ ewarn "You have disabled tor USE flag, which means you need to "
+ ewarn "configure tor on a different host."
+ fi
+ ewarn
+}
diff --git a/net-misc/vidalia/vidalia-0.2.17.ebuild b/net-misc/vidalia/vidalia-0.2.17.ebuild
new file mode 100644
index 000000000000..626ed27002cb
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.2.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.2.17.ebuild,v 1.1 2012/02/12 13:53:11 blueness Exp $
+
+EAPI="4"
+
+inherit eutils qt4-r2 cmake-utils
+# cmake-utils needs to be last, so we get its src_compile()
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="https://www.torproject.org/projects/vidalia.html.en"
+SRC_URI="https://www.torproject.org/dist/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 ) openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug +tor"
+
+DEPEND="x11-libs/qt-gui:4[debug?]"
+RDEPEND="${DEPEND}
+ tor? ( net-misc/tor )"
+
+DOCS="CHANGELOG CREDITS README"
+
+pkg_postinst() {
+ ewarn
+ if use tor; then
+ ewarn "To have vidalia starting tor, you probably have to copy"
+ ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
+ ewarn "the settings there and change the socks. Also, in vidalia"
+ ewarn "change the default user under which tor will run."
+ else
+ ewarn "You have disabled tor USE flag, which means you need to "
+ ewarn "configure tor on a different host."
+ fi
+ ewarn
+}