summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-10-11 14:03:45 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-10-11 14:03:45 +0000
commit0a8f51b6d48abf2c846b09db6e76f51eb23d04dd (patch)
tree76a8a4a2860ed76a74dfccd87129750a320bfe58 /net-misc/vidalia
parentVersion bump, remove release candidate. (diff)
downloadgentoo-2-0a8f51b6d48abf2c846b09db6e76f51eb23d04dd.tar.gz
gentoo-2-0a8f51b6d48abf2c846b09db6e76f51eb23d04dd.tar.bz2
gentoo-2-0a8f51b6d48abf2c846b09db6e76f51eb23d04dd.zip
bump
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-misc/vidalia')
-rw-r--r--net-misc/vidalia/ChangeLog9
-rw-r--r--net-misc/vidalia/files/digest-vidalia-0.0.83
-rw-r--r--net-misc/vidalia/vidalia-0.0.7.ebuild4
-rw-r--r--net-misc/vidalia/vidalia-0.0.8.ebuild42
4 files changed, 55 insertions, 3 deletions
diff --git a/net-misc/vidalia/ChangeLog b/net-misc/vidalia/ChangeLog
index 52d130a886cc..a75aa12483a9 100644
--- a/net-misc/vidalia/ChangeLog
+++ b/net-misc/vidalia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/vidalia
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.2 2006/08/19 14:29:51 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.3 2006/10/11 14:03:45 humpback Exp $
+
+*vidalia-0.0.8 (11 Oct 2006)
+
+ 11 Oct 2006; Gustavo Felisberto <humpback@gentoo.org>;
+ vidalia-0.0.7.ebuild, +vidalia-0.0.8.ebuild:
+ Bumped to 0.0.8 . This will probably be updated do to diferent ways that it
+ can start Tor
19 Aug 2006; Tobias Scherbaum <dertobi123@gentoo.org>
vidalia-0.0.7.ebuild:
diff --git a/net-misc/vidalia/files/digest-vidalia-0.0.8 b/net-misc/vidalia/files/digest-vidalia-0.0.8
new file mode 100644
index 000000000000..744eff5f4ee2
--- /dev/null
+++ b/net-misc/vidalia/files/digest-vidalia-0.0.8
@@ -0,0 +1,3 @@
+MD5 13c449b7784dd1c185839c4d9e2f27a1 vidalia-0.0.8.tar.gz 1528205
+RMD160 879910dccc308840c3fc3594f0b326970f544f3e vidalia-0.0.8.tar.gz 1528205
+SHA256 b5f975471bf479a400669dfa4b8d8bb5d9c1b92f93d49e86ddaadc0fa252f700 vidalia-0.0.8.tar.gz 1528205
diff --git a/net-misc/vidalia/vidalia-0.0.7.ebuild b/net-misc/vidalia/vidalia-0.0.7.ebuild
index 12a9f4f77adb..812a65aaed41 100644
--- a/net-misc/vidalia/vidalia-0.0.7.ebuild
+++ b/net-misc/vidalia/vidalia-0.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.0.7.ebuild,v 1.2 2006/08/19 14:29:51 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.0.7.ebuild,v 1.3 2006/10/11 14:03:45 humpback Exp $
inherit eutils
@@ -36,7 +36,7 @@ src_install() {
pkg_postinst() {
ewarn "To have vidalia starting tor you probably have to copy
- /etc/torr/torrc.sample to the users HOME/.tor/torrc and comment the settings
+ /etc/tor/torrc.sample to the users HOME/.tor/torrc and comment the settings
there and change the socks. Also in vidalia change the default user under
wich tor will run"
}
diff --git a/net-misc/vidalia/vidalia-0.0.8.ebuild b/net-misc/vidalia/vidalia-0.0.8.ebuild
new file mode 100644
index 000000000000..97e15f4e2e0a
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.0.8.ebuild,v 1.1 2006/10/11 14:03:45 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="http://www.vidalia-project.net/"
+SRC_URI="http://www.vidalia-project.net/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=x11-libs/qt-4.1.1"
+RDEPEND="${DEPEND}
+ >=net-misc/tor-0.1.1.20"
+
+pkg_setup() {
+ if use debug && ! built_with_use ">=x11-libs/qt-4.1.1" debug; then
+ eerror "In order to have debug support for Vidalia"
+ eerror "you need to compile Qt 4 with debug support too."
+ die "Qt 4 built without debug support"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ewarn "To have vidalia starting tor you probably have to copy
+ /etc/tor/torrc.sample to the users $HOME/.tor/torrc and comment the settings
+ there and change the socks. Also in vidalia change the default user under
+ wich tor will run"
+}