summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-07 21:35:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-07 21:35:31 +0000
commitab50d9405d8b6faa5476285a453dafaf2b78725d (patch)
tree08748032f337a432f5bad120b640830f3d889f53 /net-misc/unison
parentStable on alpha, bug #216757 (diff)
downloadgentoo-2-ab50d9405d8b6faa5476285a453dafaf2b78725d.tar.gz
gentoo-2-ab50d9405d8b6faa5476285a453dafaf2b78725d.tar.bz2
gentoo-2-ab50d9405d8b6faa5476285a453dafaf2b78725d.zip
Revision bump for slotted version, mainly by Martin von Gagern <Martin.vGagern@gmx.net> in bug #207746 and bug #183019
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/ChangeLog9
-rw-r--r--net-misc/unison/unison-2.27.57-r1.ebuild84
2 files changed, 92 insertions, 1 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index 82e84c73c774..8df0e305c8d3 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/unison
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.45 2008/01/27 15:06:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.46 2008/04/07 21:35:31 aballier Exp $
+
+*unison-2.27.57-r1 (07 Apr 2008)
+
+ 07 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +unison-2.27.57-r1.ebuild:
+ Revision bump for slotted version, mainly by Martin von Gagern
+ <Martin.vGagern@gmx.net> in bug #207746 and bug #183019
*unison-2.27.57 (27 Jan 2008)
diff --git a/net-misc/unison/unison-2.27.57-r1.ebuild b/net-misc/unison/unison-2.27.57-r1.ebuild
new file mode 100644
index 000000000000..133391839b8e
--- /dev/null
+++ b/net-misc/unison/unison-2.27.57-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.27.57-r1.ebuild,v 1.1 2008/04/07 21:35:31 aballier Exp $
+
+EAPI=1
+
+inherit eutils versionator
+
+IUSE="gtk doc static debug threads"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/ocaml-3.04
+ gtk? ( >=dev-ml/lablgtk-2.2 )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2
+|| ( net-misc/x11-ssh-askpass net-misc/gtk2-ssh-askpass ) )
+ !net-misc/unison:0
+ app-admin/eselect-unison"
+
+PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake -j1 $myconf CFLAGS="" || die "error making unsion"
+}
+
+src_test() {
+ emake selftest || die "selftest failed"
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ newbin unison unison-${SLOT} || die
+ dodoc BUGS.txt CONTRIB INSTALL NEWS \
+ README ROADMAP.txt TODO.txt || die
+
+ if use doc; then
+ dohtml "${DISTDIR}/${P}-manual.html" || die
+ dodoc "${DISTDIR}/${P}-manual.pdf" || die
+ fi
+}
+
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+}