summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-23 20:08:15 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-23 20:08:15 +0000
commit33e95a730b4428af655909b66615d146d9535888 (patch)
tree3f6425271559fdcde567dfc3d9153571db23e210 /net-misc/unison
parentStable on amd64 and x86, remove older stable. (diff)
downloadgentoo-2-33e95a730b4428af655909b66615d146d9535888.tar.gz
gentoo-2-33e95a730b4428af655909b66615d146d9535888.tar.bz2
gentoo-2-33e95a730b4428af655909b66615d146d9535888.zip
Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/48 by damex.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/ChangeLog8
-rw-r--r--net-misc/unison/unison-2.48.3.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index ce0c2306d91f..ebfd25b579e9 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/unison
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.71 2015/01/17 05:19:33 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.72 2015/02/23 20:08:15 mgorny Exp $
+
+*unison-2.48.3 (23 Feb 2015)
+
+ 23 Feb 2015; Michał Górny <mgorny@gentoo.org> +unison-2.48.3.ebuild:
+ Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/48 by
+ damex.
17 Jan 2015; Benda Xu <heroxbd@gentoo.org> -unison-2.27.57-r1.ebuild,
-unison-2.40.65.ebuild:
diff --git a/net-misc/unison/unison-2.48.3.ebuild b/net-misc/unison/unison-2.48.3.ebuild
new file mode 100644
index 000000000000..231c60b90202
--- /dev/null
+++ b/net-misc/unison/unison-2.48.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.48.3.ebuild,v 1.1 2015/02/23 20:08:15 mgorny Exp $
+
+EAPI="5"
+
+inherit eutils versionator
+
+IUSE="gtk doc static debug threads +ocamlopt test"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+# ocaml version so we are sure it has ocamlopt use flag
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.2 )
+ test? ( || ( dev-util/ctags virtual/emacs ) )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ !net-misc/unison:0
+ app-admin/eselect-unison"
+
+#PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+ doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" buildexecutable
+}
+
+src_test() {
+ emake selftest
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ newbin unison unison-${SLOT}
+ dodoc BUGS.txt CONTRIB INSTALL NEWS \
+ README ROADMAP.txt TODO.txt
+
+ if use doc; then
+ dohtml "${DISTDIR}/${P}-manual.html"
+ dodoc "${DISTDIR}/${P}-manual.pdf"
+ fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+}