summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2012-06-06 16:36:31 +0000
committerBenda XU <heroxbd@gentoo.org>2012-06-06 16:36:31 +0000
commit29dac1ea3cd1a0c496e4e8ae0113d335c0b88b5a (patch)
treea1d5a3cd6bf241ed76b47f5e5abcd5623af4119b /net-misc/unison
parentVersion bump wrt #416271 by "df" (diff)
downloadgentoo-2-29dac1ea3cd1a0c496e4e8ae0113d335c0b88b5a.tar.gz
gentoo-2-29dac1ea3cd1a0c496e4e8ae0113d335c0b88b5a.tar.bz2
gentoo-2-29dac1ea3cd1a0c496e4e8ae0113d335c0b88b5a.zip
bump closing bug 353282. Thanks to Thomas and all the people who commented and pushed
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/ChangeLog8
-rw-r--r--net-misc/unison/unison-2.40.65.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index 83afc02e2c02..39159318a891 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/unison
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.65 2012/02/05 18:44:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.66 2012/06/06 16:36:31 heroxbd Exp $
+
+*unison-2.40.65 (06 Jun 2012)
+
+ 06 Jun 2012; Benda Xu <heroxbd@gentoo.org> +unison-2.40.65.ebuild:
+ bump closing bug 353282. Thanks to Thomas and all the people who commented and
+ pushed
05 Feb 2012; Raúl Porcel <armin76@gentoo.org> unison-2.13.16-r1.ebuild,
unison-2.27.57-r1.ebuild, unison-2.32.52.ebuild:
diff --git a/net-misc/unison/unison-2.40.65.ebuild b/net-misc/unison/unison-2.40.65.ebuild
new file mode 100644
index 000000000000..e2fc16d5736a
--- /dev/null
+++ b/net-misc/unison/unison-2.40.65.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.40.65.ebuild,v 1.1 2012/06/06 16:36:31 heroxbd Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+IUSE="gtk doc static debug threads +ocamlopt test"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+# ocaml version so we are sure it has ocamlopt use flag
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.2 )
+ test? ( || ( dev-util/ctags virtual/emacs ) )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ !net-misc/unison:0
+ app-admin/eselect-unison"
+
+#PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+ doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" buildexecutable || die "error making unsion"
+}
+
+src_test() {
+ emake selftest || die "selftest failed"
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ newbin unison unison-${SLOT} || die
+ dodoc BUGS.txt CONTRIB INSTALL NEWS \
+ README ROADMAP.txt TODO.txt || die
+
+ if use doc; then
+ dohtml "${DISTDIR}/${P}-manual.html" || die
+ dodoc "${DISTDIR}/${P}-manual.pdf" || die
+ fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+}