summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-09-23 21:08:40 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-09-23 21:08:40 +0000
commitcab9813f4172280fb2e7ca0ce21660a2a2c4a1e8 (patch)
tree7b44b223324265aa215d2354bb71b32e30d9c15b /net-misc/tor
parentSet CC when building gznbd #435932 by Agostino Sarubbo. Add USE=debug support. (diff)
downloadgentoo-2-cab9813f4172280fb2e7ca0ce21660a2a2c4a1e8.tar.gz
gentoo-2-cab9813f4172280fb2e7ca0ce21660a2a2c4a1e8.tar.bz2
gentoo-2-cab9813f4172280fb2e7ca0ce21660a2a2c4a1e8.zip
Version bump alpha to 0.2.4.3
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog8
-rw-r--r--net-misc/tor/metadata.xml5
-rw-r--r--net-misc/tor/tor-0.2.4.3_alpha.ebuild87
3 files changed, 97 insertions, 3 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index d56393b5c683..118cdef89e15 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.356 2012/09/15 18:02:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.357 2012/09/23 21:08:40 blueness Exp $
+
+*tor-0.2.4.3_alpha (23 Sep 2012)
+
+ 23 Sep 2012; Anthony G. Basile <blueness@gentoo.org>
+ +tor-0.2.4.3_alpha.ebuild, metadata.xml:
+ Version bump alpha to 0.2.4.3
15 Sep 2012; Raúl Porcel <armin76@gentoo.org> tor-0.2.2.39.ebuild:
sparc stable wrt #434882
diff --git a/net-misc/tor/metadata.xml b/net-misc/tor/metadata.xml
index a464bcfe15aa..d3ace33ac5c9 100644
--- a/net-misc/tor/metadata.xml
+++ b/net-misc/tor/metadata.xml
@@ -6,10 +6,11 @@
<name>Anthony G. Basile</name>
</maintainer>
<use>
- <flag name='tor-hardening'>Compile tor with hardening on vanilla compilers/linkers</flag>
- <flag name='transparent-proxy'>Enable transparent proxying</flag>
<flag name='bufferevents'>Use Libevent's buffered IO</flag>
+ <flag name='stats'>Enable to keep track of how much of each kind of resource we download</flag>
<flag name='nat-pmp'>Enable NAT Port Mapping Protocol</flag>
+ <flag name='tor-hardening'>Compile tor with hardening on vanilla compilers/linkers</flag>
+ <flag name='transparent-proxy'>Enable transparent proxying</flag>
<flag name='upnp'>Enable Universal Plug and Play</flag>
<flag name='web'>Enable tor2web support</flag>
</use>
diff --git a/net-misc/tor/tor-0.2.4.3_alpha.ebuild b/net-misc/tor/tor-0.2.4.3_alpha.ebuild
new file mode 100644
index 000000000000..e4adcc272500
--- /dev/null
+++ b/net-misc/tor/tor-0.2.4.3_alpha.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.4.3_alpha.ebuild,v 1.1 2012/09/23 21:08:40 blueness Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic versionator
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+bufferevents nat-pmp selinux stats tor-hardening transparent-proxy threads upnp web"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ dev-libs/libevent
+ nat-pmp? ( net-libs/libnatpmp )
+ upnp? ( net-libs/miniupnpc )
+ selinux? ( sec-policy/selinux-tor )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.3.14_alpha-torrc.sample.patch
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+ econf \
+ --disable-buf-freelists \
+ --enable-asciidoc \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable stats instrument-downloads) \
+ $(use_enable bufferevents) \
+ $(use_enable nat-pmp) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable threads) \
+ $(use_enable upnp) \
+ $(use_enable web tor2web-mode)
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r6 tor
+
+ emake DESTDIR="${D}" install
+
+ keepdir /var/lib/tor
+
+ dodoc README ChangeLog ReleaseNotes \
+ doc/{HACKING,spec/README}
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}
+
+pkg_postinst() {
+ elog
+ elog "We created a configuration file for tor, /etc/tor/torrc, but you can"
+ elog "change it according to your needs. Use the torrc.sample that is in"
+ elog "that directory as a guide. Also, to have privoxy work with tor"
+ elog "just add the following line"
+ elog
+ elog "forward-socks4a / localhost:9050 ."
+ elog
+ elog "to /etc/privoxy/config. Notice the . at the end!"
+ elog
+}