summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-08-13 10:49:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-08-13 10:49:15 +0000
commitee797e90a58afc549f4d9541f90af7182212b1c9 (patch)
tree74c3e0900b595452408a358ce7b961d0cc7d1db4 /net-misc/tokyotyrant
parentVersion bump: XEmacs compatibility fixes. (diff)
downloadgentoo-2-ee797e90a58afc549f4d9541f90af7182212b1c9.tar.gz
gentoo-2-ee797e90a58afc549f4d9541f90af7182212b1c9.tar.bz2
gentoo-2-ee797e90a58afc549f4d9541f90af7182212b1c9.zip
Bump, fixes thanks to Johan Bergstroem. Fixes #331559
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tokyotyrant')
-rw-r--r--net-misc/tokyotyrant/ChangeLog8
-rw-r--r--net-misc/tokyotyrant/files/fix_makefiles-1.4.41.patch85
-rw-r--r--net-misc/tokyotyrant/tokyotyrant-1.1.41.ebuild65
3 files changed, 157 insertions, 1 deletions
diff --git a/net-misc/tokyotyrant/ChangeLog b/net-misc/tokyotyrant/ChangeLog
index 788e703b7af3..2026ef032e3e 100644
--- a/net-misc/tokyotyrant/ChangeLog
+++ b/net-misc/tokyotyrant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tokyotyrant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tokyotyrant/ChangeLog,v 1.8 2010/06/18 07:44:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tokyotyrant/ChangeLog,v 1.9 2010/08/13 10:49:15 patrick Exp $
+
+*tokyotyrant-1.1.41 (13 Aug 2010)
+
+ 13 Aug 2010; Patrick Lauer <patrick@gentoo.org>
+ +tokyotyrant-1.1.41.ebuild, +files/fix_makefiles-1.4.41.patch:
+ Bump, fixes thanks to Johan Bergstroem. Fixes #331559
18 Jun 2010; Patrick Lauer <patrick@gentoo.org>
-tokyotyrant-1.1.37.ebuild, -tokyotyrant-1.1.39.ebuild:
diff --git a/net-misc/tokyotyrant/files/fix_makefiles-1.4.41.patch b/net-misc/tokyotyrant/files/fix_makefiles-1.4.41.patch
new file mode 100644
index 000000000000..40d26cc5f93a
--- /dev/null
+++ b/net-misc/tokyotyrant/files/fix_makefiles-1.4.41.patch
@@ -0,0 +1,85 @@
+diff --git a/Makefile.in b/Makefile.in
+index b388455..52d3bc3 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -58,8 +58,8 @@ CFLAGS = @MYCFLAGS@
+ LDFLAGS = @MYLDFLAGS@
+ CMDLDFLAGS = @MYCMDLDFLAGS@
+ LIBS = @LIBS@
+-LDENV = LD_RUN_PATH=/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@:.
+-RUNENV = @MYLDLIBPATHENV@=.:/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
++LDENV =
++RUNENV = @MYLDLIBPATHENV@=.:$(LIBDIR)
+ POSTCMD = @MYPOSTCMD@
+
+
+@@ -120,10 +120,6 @@ install :
+ cp -Rf $(LIBRARYFILES) $(DESTDIR)$(LIBDIR)
+ mkdir -p $(DESTDIR)$(BINDIR)
+ cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
+- mkdir -p $(DESTDIR)$(SBINDIR)
+- cp -Rf $(INITFILES) $(DESTDIR)$(SBINDIR)
+- mkdir -p $(DESTDIR)$(DATADIR)
+- cp -Rf $(SCREXTFILES) $(DOCUMENTFILES) $(DESTDIR)$(DATADIR)
+ mkdir -p $(DESTDIR)$(MAN1DIR)
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+ mkdir -p $(DESTDIR)$(MAN3DIR)
+@@ -132,7 +128,6 @@ install :
+ cd man && cp -Rf $(MAN8FILES) $(DESTDIR)$(MAN8DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+- [ "$$UID" == 0 ] && ldconfig || true
+ @printf '\n'
+ @printf '#================================================================\n'
+ @printf '# Thanks for using Tokyo Tyrant.\n'
+diff --git a/configure.in b/configure.in
+index fbe0c71..809a839 100644
+--- a/configure.in
++++ b/configure.in
+@@ -28,33 +28,15 @@ MYDOCUMENTFILES="COPYING ChangeLog THANKS doc tokyotyrant.idl"
+ MYPCFILES="tokyotyrant.pc"
+
+ # Building flags
+-MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char -O2"
++MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char"
+ MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I$HOME/include -I/usr/local/include"
+ MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1 -D_REENTRANT -D__EXTENSIONS__"
+-MYLDFLAGS="-L. -L\$(LIBDIR) -L$HOME/lib -L/usr/local/lib"
++MYLDFLAGS="-L. -L\$(LIBDIR)"
+ MYCMDLDFLAGS=""
+ MYRUNPATH="\$(LIBDIR)"
+ MYLDLIBPATHENV="LD_LIBRARY_PATH"
+ MYPOSTCMD="true"
+
+-# Building paths
+-PATH="$PATH:$HOME/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin"
+-PATH="$PATH:/opt/SUNWspro/bin:/usr/ccs/bin:/usr/xpg4/bin:/usr/xpg6/bin:/usr/ucb"
+-CPATH="$HOME/include:/usr/local/include:$CPATH"
+-LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LIBRARY_PATH"
+-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
+-PKG_CONFIG_PATH="$HOME/lib/pkgconfig:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
+-export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
+-if type pkg-config > /dev/null 2>&1
+-then
+- PATH="$PATH:`pkg-config --variable=bindir tokyocabinet`"
+- CPATH="$CPATH:`pkg-config --variable=includedir tokyocabinet`"
+- LIBRARY_PATH="$LIBRARY_PATH:`pkg-config --variable=libdir tokyocabinet`"
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:`pkg-config --variable=libdir tokyocabinet`"
+-fi
+-
+-
+-
+ #================================================================
+ # Options
+ #================================================================
+diff --git a/tokyotyrant.pc.in b/tokyotyrant.pc.in
+index efb3749..efec1f6 100644
+--- a/tokyotyrant.pc.in
++++ b/tokyotyrant.pc.in
+@@ -10,5 +10,5 @@ datadir=@datadir@
+ Name: Tokyo Tyrant
+ Description: network interface of Tokyo Cabinet
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -ltokyotyrant @LIBS@
++Libs: -L${libdir} -ltokyotyrant
+ Cflags: -I${includedir}
diff --git a/net-misc/tokyotyrant/tokyotyrant-1.1.41.ebuild b/net-misc/tokyotyrant/tokyotyrant-1.1.41.ebuild
new file mode 100644
index 000000000000..279139642098
--- /dev/null
+++ b/net-misc/tokyotyrant/tokyotyrant-1.1.41.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tokyotyrant/tokyotyrant-1.1.41.ebuild,v 1.1 2010/08/13 10:49:15 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A network interface to Tokyo Cabinet"
+HOMEPAGE="http://fallabs.com/tokyotyrant/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-macos"
+IUSE="debug examples lua"
+
+DEPEND="dev-db/tokyocabinet
+ sys-libs/zlib
+ app-arch/bzip2
+ lua? ( dev-lang/lua )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use !prefix ; then
+ enewgroup tyrant
+ enewuser tyrant -1 -1 /var/lib/${PN} tyrant
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix_makefiles-1.4.41.patch
+ epatch "${FILESDIR}"/fix_testsuite.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable lua)
+}
+
+src_install() {
+ rm ttservctl || die "Install failed"
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ for x in /var/{lib,run,log}/${PN}; do
+ dodir "${x}" || die "Install failed"
+ use prefix || fowners tyrant:tyrant "${x}"
+ done
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ dohtml doc/* || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die "Install failed"
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die "Install failed"
+
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}