summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-26 01:44:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-26 01:44:08 +0000
commitf67af77d46db4b001ed9822891f0e05b7b9a273e (patch)
treefdc42aac3c7b6892b73df4515ae62c3be02c6c9f /net-misc/tinc
parentVersion bump. (diff)
downloadgentoo-2-f67af77d46db4b001ed9822891f0e05b7b9a273e.tar.gz
gentoo-2-f67af77d46db4b001ed9822891f0e05b7b9a273e.tar.bz2
gentoo-2-f67af77d46db4b001ed9822891f0e05b7b9a273e.zip
Version bump with patch to fix AC_ARG_ENABLE
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tinc')
-rw-r--r--net-misc/tinc/ChangeLog8
-rw-r--r--net-misc/tinc/files/fix-ac-arg-enable.patch69
-rw-r--r--net-misc/tinc/tinc-1.0.18.ebuild55
3 files changed, 131 insertions, 1 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index 8a37f46fd790..cf594b30e807 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tinc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.31 2012/03/11 14:08:26 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.32 2012/03/26 01:44:07 blueness Exp $
+
+*tinc-1.0.18 (26 Mar 2012)
+
+ 26 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +tinc-1.0.18.ebuild,
+ +files/fix-ac-arg-enable.patch:
+ Version bump with patch to fix AC_ARG_ENABLE
*tinc-1.0.17 (11 Mar 2012)
diff --git a/net-misc/tinc/files/fix-ac-arg-enable.patch b/net-misc/tinc/files/fix-ac-arg-enable.patch
new file mode 100644
index 000000000000..fef695211551
--- /dev/null
+++ b/net-misc/tinc/files/fix-ac-arg-enable.patch
@@ -0,0 +1,69 @@
+diff -Naur tinc-1.0.18.orig//configure.in tinc-1.0.18/configure.in
+--- tinc-1.0.18.orig//configure.in 2012-03-25 09:46:02.000000000 -0400
++++ tinc-1.0.18/configure.in 2012-03-25 21:24:55.000000000 -0400
+@@ -74,29 +74,43 @@
+
+ AC_ARG_ENABLE(uml,
+ AS_HELP_STRING([--enable-uml], [enable support for User Mode Linux]),
+- [ AC_DEFINE(ENABLE_UML, 1, [Support for UML])
+- uml=true
+- ]
++ [ AS_IF([test "x$enable_uml" = "xyes"],
++ [ AC_DEFINE(ENABLE_UML, 1, [Support for UML])
++ uml=true
++ ],
++ [uml=false])
++ ],
++ [uml=true]
+ )
+
+ AC_ARG_ENABLE(vde,
+ AS_HELP_STRING([--enable-vde], [enable support for Virtual Distributed Ethernet]),
+- [ AC_CHECK_HEADERS(libvdeplug_dyn.h, [], [AC_MSG_ERROR([VDE plug header files not found.]); break])
+- AC_DEFINE(ENABLE_VDE, 1, [Support for VDE])
+- vde=true
+- ]
++ [ AS_IF([test "x$enable_vde" = "xyes"],
++ [ AC_CHECK_HEADERS(libvdeplug_dyn.h, [], [AC_MSG_ERROR([VDE plug header files not found.]); break])
++ AC_DEFINE(ENABLE_VDE, 1, [Support for VDE])
++ vde=true
++ ],
++ [vde=false])
++ ],
++ [vde=true]
+ )
+
+ AC_ARG_ENABLE(tunemu,
+ AS_HELP_STRING([--enable-tunemu], [enable support for the tunemu driver]),
+- [ AC_DEFINE(ENABLE_TUNEMU, 1, [Support for tunemu])
+- tunemu=true
+- ]
++ [ AS_IF([test "x$enable_tunemu" = "xyes"],
++ [ AC_DEFINE(ENABLE_TUNEMU, 1, [Support for tunemu])
++ tunemu=true
++ ],
++ [tunemu=false])
++ ],
++ [tunemu=true]
+ )
+
+ AC_ARG_WITH(windows2000,
+ AS_HELP_STRING([--with-windows2000], [compile with support for Windows 2000. This disables support for tunneling over existing IPv6 networks.]),
+- [AC_DEFINE(WITH_WINDOWS2000, 1, [Compile with support for Windows 2000])]
++ [ AS_IF([test "x$with_windows2000" = "xyes"],
++ [AC_DEFINE(WITH_WINDOWS2000, 1, [Compile with support for Windows 2000])])
++ ]
+ )
+
+ AM_CONDITIONAL(UML, test "$uml" = true)
+@@ -177,7 +191,9 @@
+ dnl Check if support for jumbograms is requested
+ AC_ARG_ENABLE(jumbograms,
+ AS_HELP_STRING([--enable-jumbograms], [enable support for jumbograms (packets up to 9000 bytes)]),
+- [ AC_DEFINE(ENABLE_JUMBOGRAMS, 1, [Support for jumbograms (packets up to 9000 bytes)]) ]
++ [ AS_IF([test "x$enable_jumbograms" = "xyes"],
++ [ AC_DEFINE(ENABLE_JUMBOGRAMS, 1, [Support for jumbograms (packets up to 9000 bytes)]) ])
++ ]
+ )
+
+ AC_SUBST(INCLUDES)
diff --git a/net-misc/tinc/tinc-1.0.18.ebuild b/net-misc/tinc/tinc-1.0.18.ebuild
new file mode 100644
index 000000000000..19c9d5947403
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.18.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.18.ebuild,v 1.1 2012/03/26 01:44:07 blueness Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo vde +zlib"
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-ac-arg-enable.patch
+ eautoreconf
+}
+
+src_configure() {
+ # The new DeviceType option can now be used to select UML or VDE
+ # devices without having to recompile. So we'll set UML by default
+ # since it doesn't pull in any deps, but VDE needs net-misc/vde,
+ # so we'll keep that contingent on a USE flag.
+ econf \
+ --enable-jumbograms \
+ --enable-uml \
+ $(use_enable vde) \
+ $(use_enable lzo) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ newinitd "${FILESDIR}"/tincd.1 tincd
+ newinitd "${FILESDIR}"/tincd.lo.1 tincd.lo
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf.1 tincd
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}