summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2010-07-18 10:04:56 +0000
committerDaniel Black <dragonheart@gentoo.org>2010-07-18 10:04:56 +0000
commit4a07295638ff976a0449ce8a7f5a0ad756ab364b (patch)
tree3436af9ab8d6bce371713d6a370615cab14f57b3 /net-misc/tinc
parentversion bump (diff)
downloadgentoo-2-4a07295638ff976a0449ce8a7f5a0ad756ab364b.tar.gz
gentoo-2-4a07295638ff976a0449ce8a7f5a0ad756ab364b.tar.bz2
gentoo-2-4a07295638ff976a0449ce8a7f5a0ad756ab364b.zip
version bump thanks to Jan in bugs #314739 and #307477
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tinc')
-rw-r--r--net-misc/tinc/ChangeLog8
-rw-r--r--net-misc/tinc/files/tincd.conf1
-rw-r--r--net-misc/tinc/files/tincd.lo46
-rw-r--r--net-misc/tinc/tinc-1.0.13.ebuild37
4 files changed, 91 insertions, 1 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index aca365a860ed..a1f66269cf73 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tinc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.19 2010/01/16 05:59:07 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.20 2010/07/18 10:04:56 dragonheart Exp $
+
+*tinc-1.0.13 (18 Jul 2010)
+
+ 18 Jul 2010; Daniel Black <dragonheart@gentoo.org> +tinc-1.0.13.ebuild,
+ +files/tincd.conf, +files/tincd.lo:
+ version bump thanks to Jan in bugs #314739 and #307477
16 Jan 2010; Jonathan Callen <abcd@gentoo.org> tinc-1.0.11.ebuild:
Add prefix keywords, only depend on linux-sources on linux
diff --git a/net-misc/tinc/files/tincd.conf b/net-misc/tinc/files/tincd.conf
new file mode 100644
index 000000000000..c19b8365b6d3
--- /dev/null
+++ b/net-misc/tinc/files/tincd.conf
@@ -0,0 +1 @@
+#rc_need="net.net"
diff --git a/net-misc/tinc/files/tincd.lo b/net-misc/tinc/files/tincd.lo
new file mode 100644
index 000000000000..79c185b3810f
--- /dev/null
+++ b/net-misc/tinc/files/tincd.lo
@@ -0,0 +1,46 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/files/tincd.lo,v 1.1 2010/07/18 10:04:56 dragonheart Exp $
+
+opts="reload"
+
+depend()
+{
+ use logger dns
+ need net
+}
+
+start()
+{
+ TINCNET=${RC_SVCNAME#*.}
+ if [ -f /etc/tinc/"$TINCNET"/tinc.conf ] ; then
+ ebegin "Starting tinc network $TINCNET"
+ /usr/sbin/tincd --debug=1 --net="$TINCNET" --logfile=/var/log/tinc.$TINCNET.log --pidfile=/var/run/tinc.$TINCNET.pid
+ eend $?
+ else
+ eerror "Cannot start network $TINCNET, /etc/tinc/$TINCNET/tinc.conf does not exist !"
+ fi
+}
+
+stop()
+{
+ TINCNET=${RC_SVCNAME#*.}
+ if [ -f /var/run/tinc."$TINCNET".pid ] ; then
+ ebegin "Stopping tinc network $TINCNET"
+ /usr/sbin/tincd --kill --pidfile=/var/run/tinc."$TINCNET".pid
+ eend $?
+ else
+ eerror "Cannot start network $TINCNET, /etc/tinc/$TINCNET/tinc.conf does not exist !"
+ fi
+}
+
+reload()
+{
+ TINCNET=${RC_SVCNAME#*.}
+ if [ -f /var/run/tinc."$TINCNET".pid ] ; then
+ ebegin "Reloading configuration for tinc network $TINCNET"
+ /usr/sbin/tincd --kill HUP --pidfile=/var/run/tinc."$TINCNET".pid
+ eend $?
+ fi
+}
diff --git a/net-misc/tinc/tinc-1.0.13.ebuild b/net-misc/tinc/tinc-1.0.13.ebuild
new file mode 100644
index 000000000000..5d5b652a5c72
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.13.ebuild,v 1.1 2010/07/18 10:04:56 dragonheart Exp $
+
+EAPI=2
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo +zlib"
+
+DEPEND=">=dev-libs/openssl-0.9.7c
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( >=sys-libs/zlib-1.1.4-r2 )
+ kernel_linux? ( virtual/linux-sources )"
+
+src_configure() {
+ econf --enable-jumbograms $(use_enable lzo) $(use_enable zlib) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doinitd "${FILESDIR}"/tincd{,.lo}
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}