summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-09-27 15:02:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-09-27 15:02:09 +0000
commit35c8b1b0a104deebbf52d482653902d2af59693a (patch)
treef4160927590c8b4976ca80ba05dbbe432759c2f6 /net-misc/tinc/tinc-1.1_pre10-r1.ebuild
parentre-add 2.71 with fixed Manifest wrt #523328 and unbundle minilzo wrt #515266 (diff)
downloadgentoo-2-35c8b1b0a104deebbf52d482653902d2af59693a.tar.gz
gentoo-2-35c8b1b0a104deebbf52d482653902d2af59693a.tar.bz2
gentoo-2-35c8b1b0a104deebbf52d482653902d2af59693a.zip
Fix bashism, bug #523862
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/tinc/tinc-1.1_pre10-r1.ebuild')
-rw-r--r--net-misc/tinc/tinc-1.1_pre10-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/tinc/tinc-1.1_pre10-r1.ebuild b/net-misc/tinc/tinc-1.1_pre10-r1.ebuild
new file mode 100644
index 000000000000..c20433d890f3
--- /dev/null
+++ b/net-misc/tinc/tinc-1.1_pre10-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.1_pre10-r1.ebuild,v 1.1 2014/09/27 15:02:09 blueness Exp $
+
+EAPI="5"
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils systemd python-any-r1
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo +ncurses +openssl gcrypt gui +readline uml vde +zlib"
+
+DEPEND="dev-libs/openssl
+ lzo? ( dev-libs/lzo:2 )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )
+ ${PYTHON_DEPS}
+ gui? ( $(python_gen_any_dep '
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ ') )"
+
+REQUIRED_USE="^^ ( openssl gcrypt )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ --with-windows2000 \
+ --disable-silent-rules \
+ $(use_enable lzo) \
+ $(use_enable ncurses curses) \
+ $(use_enable readline) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib) \
+ $(use_with openssl) \
+# $(use_with gcrypt libgcrypt), upstream not ready
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r1 tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+
+ if use gui; then
+ python_fix_shebang "${ED}"/usr/bin/tinc-gui
+ else
+ rm -f "${ED}"/usr/bin/tinc-gui || die
+ fi
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}