summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-01-09 22:36:07 +0000
committerAlin Năstac <mrness@gentoo.org>2006-01-09 22:36:07 +0000
commitb097d1f2ced79fc3a9769161a91c2a263f2a93a5 (patch)
treee943fbc9042394fcd6577e0562a7eeb9c8a95db3 /net-misc/taylor-uucp/taylor-uucp-1.07-r1.ebuild
parentStable on x86, alpha and ia64, bug 117835. (diff)
downloadgentoo-2-b097d1f2ced79fc3a9769161a91c2a263f2a93a5.tar.gz
gentoo-2-b097d1f2ced79fc3a9769161a91c2a263f2a93a5.tar.bz2
gentoo-2-b097d1f2ced79fc3a9769161a91c2a263f2a93a5.zip
Take maintainership of this package. Remove old version. Change lock directory to /var/lock (#96339). Install executables SUIDed and SGIDed, with uucp:uucp as owner:group (#115689).
(Portage version: 2.0.53)
Diffstat (limited to 'net-misc/taylor-uucp/taylor-uucp-1.07-r1.ebuild')
-rw-r--r--net-misc/taylor-uucp/taylor-uucp-1.07-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/taylor-uucp/taylor-uucp-1.07-r1.ebuild b/net-misc/taylor-uucp/taylor-uucp-1.07-r1.ebuild
new file mode 100644
index 000000000000..03eab418a865
--- /dev/null
+++ b/net-misc/taylor-uucp/taylor-uucp-1.07-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/taylor-uucp/taylor-uucp-1.07-r1.ebuild,v 1.1 2006/01/09 22:36:07 mrness Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Taylor UUCP"
+HOMEPAGE="http://www.airs.com/ian/uucp.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/uucp/uucp-${PV}.tar.gz"
+
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+S="${WORKDIR}/uucp-1.07"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ #disable lazy bindings
+ sed -i -e "s:^LDFLAGS *=.*\$:& ${LDFLAGS} $(bindnow-flags):" "${S}/Makefile.in"
+}
+
+src_compile() {
+ econf --with-newconfigdir=/etc/uucp || die "configure failed"
+ make || die "make failed"
+}
+
+src_install() {
+ dodir /usr/share/man/man{1,8}
+ dodir /usr/share/info
+ dodir /etc/uucp
+ dodir /usr/bin /usr/sbin
+ diropts -o uucp -g uucp -m 0750
+ keepdir /var/log/uucp /var/spool/uucp
+ diropts -o uucp -g uucp -m 0775
+ keepdir /var/spool/uucppublic
+
+ make \
+ "prefix=${D}/usr" \
+ "sbindir=${D}/usr/sbin" \
+ "bindir=${D}/usr/bin" \
+ "man1dir=${D}/usr/share/man/man1" \
+ "man8dir=${D}/usr/share/man/man8" \
+ "newconfigdir=${D}/etc/uucp" \
+ "infodir=${D}/usr/share/info" \
+ install install-info || die "make install failed"
+ sed -i -e 's:/usr/spool:/var/spool:g' sample/config
+ cp sample/* "${D}/etc/uucp"
+ dodoc ChangeLog NEWS README TODO
+}
+
+pkg_preinst() {
+ usermod -s /bin/bash uucp
+}