summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-25 02:59:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-25 02:59:21 +0000
commita9febabb6b8623b0a4339af8aca74a37cbd7d76e (patch)
tree0a90cd105db41942f367fe2daa48efb6eef2c28c /net-misc/suite3270
parentStable on amd64 per bug #227979. Tested on Gentoo infrastructure. (diff)
downloadgentoo-2-a9febabb6b8623b0a4339af8aca74a37cbd7d76e.tar.gz
gentoo-2-a9febabb6b8623b0a4339af8aca74a37cbd7d76e.tar.bz2
gentoo-2-a9febabb6b8623b0a4339af8aca74a37cbd7d76e.zip
Version bump, resolves bug #205417. Thanks to Jesse Farinacci <jieryn@gmail.com> as usual.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'net-misc/suite3270')
-rw-r--r--net-misc/suite3270/ChangeLog9
-rw-r--r--net-misc/suite3270/suite3270-3.3.7_p5.ebuild82
2 files changed, 90 insertions, 1 deletions
diff --git a/net-misc/suite3270/ChangeLog b/net-misc/suite3270/ChangeLog
index 575d81d65919..d3f4423dc2cf 100644
--- a/net-misc/suite3270/ChangeLog
+++ b/net-misc/suite3270/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/suite3270
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.21 2008/06/07 02:29:51 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.22 2008/06/25 02:59:21 robbat2 Exp $
+
+*suite3270-3.3.7_p5 (25 Jun 2008)
+
+ 25 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +suite3270-3.3.7_p5.ebuild:
+ Version bump, resolves bug #205417. Thanks to Jesse Farinacci
+ <jieryn@gmail.com> as usual.
*suite3270-3.3.7 (07 Jun 2008)
diff --git a/net-misc/suite3270/suite3270-3.3.7_p5.ebuild b/net-misc/suite3270/suite3270-3.3.7_p5.ebuild
new file mode 100644
index 000000000000..d14d9b6350b2
--- /dev/null
+++ b/net-misc/suite3270/suite3270-3.3.7_p5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.7_p5.ebuild,v 1.1 2008/06/25 02:59:21 robbat2 Exp $
+
+inherit eutils
+
+IUSE="cjk doc ncurses ssl tcl X"
+
+S="${WORKDIR}"
+DESCRIPTION="Complete 3270 access package"
+SRC_URI="http://x3270.bgp.nu/download/${PN}-${PV/_/}.tgz"
+HOMEPAGE="http://www.geocities.com/SiliconValley/Peaks/7814/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt )
+ cjk? ( dev-libs/icu )
+ ncurses? ( sys-libs/ncurses
+ sys-libs/readline )
+ ssl? ( dev-libs/openssl )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-misc/imake
+ x11-proto/xproto
+ app-text/rman
+ x11-apps/mkfontdir
+ x11-apps/bdftopcf )"
+
+SUB_PV="3.3"
+MY_FONTDIR="/usr/share/fonts/x3270"
+
+suite3270_makelist() {
+ MY_PLIST="pr3287 s3270"
+ use ncurses && MY_PLIST="${MY_PLIST} c3270"
+ use tcl && MY_PLIST="${MY_PLIST} tcl3270"
+ use X && MY_PLIST="${MY_PLIST} x3270"
+}
+
+src_compile() {
+ local myconf
+
+ myconf="--without-pr3287"
+ myconf="${myconf} --cache-file=${S}/config.cache"
+ myconf="${myconf} $(use_enable cjk dbcs)"
+ myconf="${myconf} $(use_enable ssl)"
+ myconf="${myconf} $(use_with X x)"
+ myconf="${myconf} $(use_with X fontdir ${MY_FONTDIR})"
+
+ suite3270_makelist
+ for p in ${MY_PLIST} ; do
+ cd "${S}/${p}-${SUB_PV}"
+ econf ${myconf} || die "econf failed on ${p}"
+ emake || die "emake faild on ${p}"
+ done
+}
+
+src_install () {
+ suite3270_makelist
+ use X && dodir ${MY_FONTDIR}
+ for p in ${MY_PLIST} ; do
+ cd "${S}/${p}-${SUB_PV}"
+ emake DESTDIR="${D}" install install.man \
+ || die "emake failed on ${p}"
+ use doc && docinto ${p} && dohtml html/*
+ done
+
+ use X && rm -f "${D}/${MY_FONTDIR}/fonts.dir"
+ return 0
+}
+
+pkg_postinst() {
+ if use X ; then
+ einfo "Running mkfontdir on ${MY_FONTDIR}"
+ mkfontdir ${MY_FONTDIR}
+ fi
+}