summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-02-18 19:11:58 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-02-18 19:11:58 +0000
commitaffeaedf8b45dc420e6fe203fb7c5c22b34300b8 (patch)
tree07789f51355046f842c59300a33be07f7ab299f8 /net-misc/stuntman
parentadded blocker for >=virtual/awk-1 (diff)
downloadgentoo-2-affeaedf8b45dc420e6fe203fb7c5c22b34300b8.tar.gz
gentoo-2-affeaedf8b45dc420e6fe203fb7c5c22b34300b8.tar.bz2
gentoo-2-affeaedf8b45dc420e6fe203fb7c5c22b34300b8.zip
Revbump to add rewritten init script along with a confd file (bug #500980)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-misc/stuntman')
-rw-r--r--net-misc/stuntman/ChangeLog9
-rw-r--r--net-misc/stuntman/files/stuntman.confd7
-rw-r--r--net-misc/stuntman/files/stuntman.initd13
-rw-r--r--net-misc/stuntman/stuntman-1.2.6-r1.ebuild36
4 files changed, 64 insertions, 1 deletions
diff --git a/net-misc/stuntman/ChangeLog b/net-misc/stuntman/ChangeLog
index 73131db9f456..660210b12f8b 100644
--- a/net-misc/stuntman/ChangeLog
+++ b/net-misc/stuntman/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/stuntman
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stuntman/ChangeLog,v 1.2 2014/01/24 15:41:25 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stuntman/ChangeLog,v 1.3 2014/02/18 19:11:58 polynomial-c Exp $
+
+*stuntman-1.2.6-r1 (18 Feb 2014)
+
+ 18 Feb 2014; Lars Wendler <polynomial-c@gentoo.org>
+ +stuntman-1.2.6-r1.ebuild, +files/stuntman.confd, +files/stuntman.initd:
+ Revbump to add rewritten init script along with a confd file. Thanks to Jaco
+ Kroon (bug #500980). Permission kindly granted by Chainsaw.
24 Jan 2014; Tony Vroon <chainsaw@gentoo.org> stuntman-1.2.6.ebuild:
Add ~x86 keyword as requested by Maciej Szmigiero in bug #497732. Based on
diff --git a/net-misc/stuntman/files/stuntman.confd b/net-misc/stuntman/files/stuntman.confd
new file mode 100644
index 000000000000..a49d512843e8
--- /dev/null
+++ b/net-misc/stuntman/files/stuntman.confd
@@ -0,0 +1,7 @@
+# Stuntman's stunserver normally starts in simple mode.
+# It's recommended to run stunserver in full mode, there are
+# basically two options, bind it to two separate interfaces,
+# or more conveniently, to IP addresses. There are numerous
+# other options for stunserver, just run stunserver --help
+# for more information.
+#STUNTMAN_PARAMS="--mode full --primaryinterface 1.2.3.4 --altinterface 1.2.3.5"
diff --git a/net-misc/stuntman/files/stuntman.initd b/net-misc/stuntman/files/stuntman.initd
new file mode 100644
index 000000000000..b9a704ddc3a8
--- /dev/null
+++ b/net-misc/stuntman/files/stuntman.initd
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stuntman/files/stuntman.initd,v 1.1 2014/02/18 19:11:58 polynomial-c Exp $
+
+pidfile="/run/stunserver.pid"
+command="/usr/sbin/stunserver"
+command_args="${STUNTMAN_PARAMS}"
+command_background="true"
+
+depend() {
+ need net
+}
diff --git a/net-misc/stuntman/stuntman-1.2.6-r1.ebuild b/net-misc/stuntman/stuntman-1.2.6-r1.ebuild
new file mode 100644
index 000000000000..7d58217e3e7e
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stuntman/stuntman-1.2.6-r1.ebuild,v 1.1 2014/02/18 19:11:58 polynomial-c Exp $
+
+EAPI=5
+
+DESCRIPTION="STUNTMAN is an open source implementation of the STUN protocol."
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/boost
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/stunserver"
+
+src_compile() {
+ emake T=""
+}
+
+src_install() {
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+src_test() {
+ ./stuntestcode
+}