summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-03-05 14:56:41 +0000
committerAnant Narayanan <anant@gentoo.org>2007-03-05 14:56:41 +0000
commitc0d237471b6eeb376aaad777585e8f419585bb0d (patch)
treeaba81d25abb0ca65decc34fb11648fbd61ccb9a3 /net-misc/sslwrap/sslwrap-2.0.6-r1.ebuild
parentvBump to 1.0.2, ebuild thanks to Dean Baender. Closes #124197 (diff)
downloadgentoo-2-c0d237471b6eeb376aaad777585e8f419585bb0d.tar.gz
gentoo-2-c0d237471b6eeb376aaad777585e8f419585bb0d.tar.bz2
gentoo-2-c0d237471b6eeb376aaad777585e8f419585bb0d.zip
Replace deprectaed constant with newer one, closes bug #146828
(Portage version: 2.1.2.1)
Diffstat (limited to 'net-misc/sslwrap/sslwrap-2.0.6-r1.ebuild')
-rw-r--r--net-misc/sslwrap/sslwrap-2.0.6-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/sslwrap/sslwrap-2.0.6-r1.ebuild b/net-misc/sslwrap/sslwrap-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..e4df0f62ca9b
--- /dev/null
+++ b/net-misc/sslwrap/sslwrap-2.0.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sslwrap/sslwrap-2.0.6-r1.ebuild,v 1.1 2007/03/05 14:56:41 anant Exp $
+
+inherit eutils
+
+DESCRIPTION="TSL/SSL - Port Wrapper"
+HOMEPAGE="http://quiltaholic.com/rickk/sslwrap/"
+SRC_URI="http://quiltaholic.com/rickk/sslwrap/${PN}${PV/.0./0}.tar.gz
+ mirror://gentoo/${PN}-gentoo.tar.bz2"
+
+LICENSE="sslwrap"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.6"
+
+S=${WORKDIR}/${PN}${PV//.}
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:/usr/local/ssl/include:/usr/include/openssl:" \
+ Makefile
+ cp ${WORKDIR}/${PN}-gentoo/*.c ${S}
+ has_version '=dev-libs/openssl-0.9.7*' \
+ && epatch ${FILESDIR}/${PV}-openssl-0.9.7.patch
+ sed -i \
+ -e "s:OPENSSL\":\"openssl\/:g" \
+ -e "s:SSL_OP_NON_EXPORT_FIRST:SSL_OP_CIPHER_SERVER_PREFERENCE:g" \
+ *.h *.c
+}
+
+src_install() {
+ dosbin sslwrap
+ dodoc README
+ dohtml -r ./
+}