summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-12-26 19:47:27 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-12-26 19:47:27 +0000
commit59fe31609c62f23a6fd33d3ce564ef335e124c97 (patch)
treea2c29154e3278cd013a3d1726deb31dbe39609b0 /net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r4.ebuild
parentvirtual/ghostscript->app-text/ghostscript-gpl: ghostscript-gpl is the only im... (diff)
downloadgentoo-2-59fe31609c62f23a6fd33d3ce564ef335e124c97.tar.gz
gentoo-2-59fe31609c62f23a6fd33d3ce564ef335e124c97.tar.bz2
gentoo-2-59fe31609c62f23a6fd33d3ce564ef335e124c97.zip
Attempt to let Gentoo's sudo package work with the -A flag. app-admin/sudo still needs to depend on this package, otherwise it automagically works for some Gentoo users. See bug 240620 for discussion.
(Portage version: 2.1.7.15/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r4.ebuild')
-rw-r--r--net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r4.ebuild b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r4.ebuild
new file mode 100644
index 000000000000..91bee4c46476
--- /dev/null
+++ b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r4.ebuild,v 1.1 2009/12/26 19:47:24 darkside Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A small SSH Askpass replacement written with GTK2."
+HOMEPAGE="https://www.cgabriel.org/software/wiki/SshAskpassFullscreen"
+SRC_URI="http://www.cgabriel.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0
+ !net-misc/gtk2-ssh-askpass"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e '2 s/$/$\(LDFLAGS\)/' Makefile || die "sed failed"
+ sed -i -e "s:gcc:$(tc-getCC) ${CFLAGS}:g" Makefile || die "sed failed"
+ epatch "${FILESDIR}/${P}-fix-grab.patch"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" || die "compile failed"
+}
+
+src_install() {
+ dobin ssh-askpass-fullscreen || die "dobin failed"
+ echo "SSH_ASKPASS=/usr/bin/ssh-askpass-fullscreen" >> "${T}/99ssh_askpass" \
+ || die "envd file creation failed"
+ doenvd "${T}"/99ssh_askpass || die "doenvd failed"
+ dodoc README AUTHORS ChangeLog || die "missing docs"
+ doman "${FILESDIR}"/ssh-askpass-fullscreen.1 || die "man page failed"
+}