summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-01-09 15:33:10 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-01-09 15:33:10 +0000
commit722ea5c38d978a4472fefed019294fb775676716 (patch)
tree78066d749c74c53a9e4f421bdbe409d8f5e4b3ea /net-misc/spice-gtk
parentNew snapshot (diff)
downloadgentoo-2-722ea5c38d978a4472fefed019294fb775676716.tar.gz
gentoo-2-722ea5c38d978a4472fefed019294fb775676716.tar.bz2
gentoo-2-722ea5c38d978a4472fefed019294fb775676716.zip
Add usbredir support, remove USE=cairo, + other minor ebuild changes. Update vala use-description. Add myself to metadata.xml with dev-zero's permission.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/ChangeLog7
-rw-r--r--net-misc/spice-gtk/metadata.xml17
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.7.159.ebuild41
3 files changed, 47 insertions, 18 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index 76bfc0365a2b..7c6d062e0bac 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.7 2012/01/07 20:38:03 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.8 2012/01/09 15:33:10 nirbheek Exp $
+
+ 09 Jan 2012; Nirbheek Chauhan <nirbheek@gentoo.org> spice-gtk-0.7.159.ebuild,
+ metadata.xml:
+ Add usbredir support, remove USE=cairo, + other minor ebuild changes. Update
+ vala use-description. Add myself to metadata.xml with dev-zero's permission.
*spice-gtk-0.7.159 (07 Jan 2012)
diff --git a/net-misc/spice-gtk/metadata.xml b/net-misc/spice-gtk/metadata.xml
index 666c5bddaafa..f0ce32770521 100644
--- a/net-misc/spice-gtk/metadata.xml
+++ b/net-misc/spice-gtk/metadata.xml
@@ -5,9 +5,20 @@
<email>dev-zero@gentoo.org</email>
<name>Tiziano Müller</name>
</maintainer>
+ <maintainer>
+ <email>nirbheek@gentoo.org</email>
+ <name>Nirbheek Chauhan</name>
+ </maintainer>
<use>
- <flag name="gtk3">Link against <pkg>x11-libs/gtk+:3</pkg> instead of <pkg>x11-libs/gtk+:2</pkg></flag>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
- <flag name="vala">Regenerate pre-generated vala code using <pkg>dev-lang/vala:0.12</pkg></flag>
+ <flag name="gtk3">Link against <pkg>x11-libs/gtk+:3</pkg> instead of
+ <pkg>x11-libs/gtk+:2</pkg></flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ <flag name="policykit">Enable <pkg>sys-auth/polkit</pkg> support for the
+ usbredir acl helper</flag>
+ <flag name="usbredir">Use <pkg>sys-apps/usbredir</pkg> to redirect USB
+ devices to another machine over TCP</flag>
+ <flag name="vala">Generate <pkg>dev-lang/vala</pkg> bindings using
+ vapigen and regenerate .vala files using valac</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/spice-gtk/spice-gtk-0.7.159.ebuild b/net-misc/spice-gtk/spice-gtk-0.7.159.ebuild
index 0913cb161635..9d44ba7216e2 100644
--- a/net-misc/spice-gtk/spice-gtk-0.7.159.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.7.159.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.7.159.ebuild,v 1.1 2012/01/07 20:38:03 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.7.159.ebuild,v 1.2 2012/01/09 15:33:10 nirbheek Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -16,8 +16,10 @@ LICENSE="LGPL-2.1"
SLOT="0"
SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
-IUSE="+cairo doc gnome gstreamer gtk3 +introspection kde +pulseaudio python sasl static-libs vala"
+IUSE="doc gnome gstreamer gtk3 +introspection kde policykit +pulseaudio
+python sasl static-libs usbredir vala"
+# TODO: check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
gstreamer? (
media-libs/gstreamer:0.10
@@ -35,14 +37,26 @@ RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
introspection? ( dev-libs/gobject-introspection )
python? ( dev-python/pygtk:2 )
sasl? ( dev-libs/cyrus-sasl )
- gnome? ( gnome-base/gconf )"
+ gnome? ( gnome-base/gconf )
+ usbredir? (
+ policykit? (
+ sys-auth/polkit
+ sys-apps/acl )
+ >=dev-libs/libusb-1.0.9_rc1
+ >=sys-apps/usbredir-0.3.1
+ sys-fs/udev[gudev] )"
DEPEND="${RDEPEND}
vala? ( dev-lang/vala:0.14 )
dev-lang/python
- dev-lang/perl
- dev-perl/Text-CSV
dev-python/pyparsing
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17"
+
+# Hard-deps while building from git:
+# dev-lang/vala:0.14
+# dev-lang/perl
+# dev-perl/Text-CSV
pkg_setup() {
if use gstreamer && use pulseaudio ; then
@@ -59,35 +73,34 @@ src_configure() {
# TODO: do a double build like gtk-vnc does to install both gtk2 & gtk3 libs
use gtk3 && gtk="3.0"
if use vala ; then
- rm -vf gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c # force vala regen
+ # force vala regen for MinGW, etc
+ rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
fi
- # TODO: usbredirection support
- # needs libusbredirhost, newer libusb, policykit, libacl
- econf \
+ econf --disable-maintainer-mode \
VALAC=$(type -P valac-0.14) \
VAPIGEN=$(type -P vapigen-0.14) \
$(use_enable static-libs static) \
$(use_enable introspection) \
--with-audio="${audio}" \
- $(use_with !cairo x11) \
$(use_with python) \
$(use_with sasl) \
+ $(use_enable usbredir) \
+ $(use_enable policykit polkit) \
$(use_enable vala) \
--with-gtk="${gtk}" \
--disable-smartcard \
- --disable-usbredir \
--disable-werror
}
src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ emake -j1 DESTDIR="${D}" install
use static-libs || rm -rf "${D}"/usr/lib*/*.la
use python && rm -rf "${D}"/usr/lib*/python*/site-packages/*.la
use doc || rm -rf "${D}/usr/share/gtk-doc"
- dodoc AUTHORS NEWS README TODO
+ dodoc AUTHORS NEWS README THANKS TODO
make_desktop_entry spicy Spicy "" net