summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-02-24 13:46:09 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-02-24 13:46:09 +0000
commit2b11164c23d065783b7dc4f4c9742a4137a98dd6 (patch)
tree243b708bb61be0bb6c66b6f67cda9c828fa6f910 /net-misc/spice-gtk
parentDrop problematic sse4 & sse5 USE-flags, in GCC 4.5 no such options exist. Clo... (diff)
downloadgentoo-2-2b11164c23d065783b7dc4f4c9742a4137a98dd6.tar.gz
gentoo-2-2b11164c23d065783b7dc4f4c9742a4137a98dd6.tar.bz2
gentoo-2-2b11164c23d065783b7dc4f4c9742a4137a98dd6.zip
Initial commit, ebuild written by me (bug #353780).
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/ChangeLog10
-rw-r--r--net-misc/spice-gtk/files/spice.protocol12
-rw-r--r--net-misc/spice-gtk/files/spice.schemas41
-rw-r--r--net-misc/spice-gtk/metadata.xml12
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.5.ebuild91
5 files changed, 166 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
new file mode 100644
index 000000000000..d96471b0d81f
--- /dev/null
+++ b/net-misc/spice-gtk/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/spice-gtk
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.1 2011/02/24 13:46:09 dev-zero Exp $
+
+*spice-gtk-0.5 (24 Feb 2011)
+
+ 24 Feb 2011; Tiziano Müller <dev-zero@gentoo.org> +spice-gtk-0.5.ebuild,
+ +files/spice.protocol, +files/spice.schemas, +metadata.xml:
+ Initial commit, ebuild written by me (bug #353780).
+
diff --git a/net-misc/spice-gtk/files/spice.protocol b/net-misc/spice-gtk/files/spice.protocol
new file mode 100644
index 000000000000..348247f8ca12
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice.protocol
@@ -0,0 +1,12 @@
+[Protocol]
+exec=/usr/bin/spicy --uri="%u"
+protocol=spice
+input=none
+output=none
+helper=true
+listing=
+reading=false
+writing=false
+makedir=false
+deleting=false
+
diff --git a/net-misc/spice-gtk/files/spice.schemas b/net-misc/spice-gtk/files/spice.schemas
new file mode 100644
index 000000000000..43b12171c847
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice.schemas
@@ -0,0 +1,41 @@
+<?xml version="1.0"?>
+<gconfschemafile>
+<schemalist>
+<schema>
+ <key>/schemas/desktop/gnome/url-handlers/spice/enabled</key>
+ <applyto>/desktop/gnome/url-handlers/spice/enabled</applyto>
+ <owner>spice</owner>
+ <type>bool</type>
+ <default>true</default>
+ <locale name="C">
+ <short>How to handle spice URLs</short>
+ <long>Set to true to have a program specified in command handle spice URLs</long>
+ </locale>
+</schema>
+
+ <schema>
+ <key>/schemas/desktop/gnome/url-handlers/spice/command</key>
+ <applyto>/desktop/gnome/url-handlers/spice/command</applyto>
+ <owner>spice</owner>
+ <type>string</type>
+ <default>/usr/bin/spicy --uri="%s"</default>
+ <locale name="C">
+ <short>URL handler for spice URIs</short>
+ <long>URL handler for spice URIs</long>
+ </locale>
+ </schema>
+
+ <schema>
+ <key>/schemas/desktop/gnome/url-handlers/spice/need-terminal</key>
+ <applyto>/desktop/gnome/url-handlers/spice/need-terminal</applyto>
+ <owner>spice</owner>
+ <type>bool</type>
+ <default>false</default>
+ <locale name="C">
+ <short>Run program in terminal</short>
+ <long>True if the program to handle this URL should be run in a terminal</long>
+ </locale>
+ </schema>
+</schemalist>
+</gconfschemafile>
+
diff --git a/net-misc/spice-gtk/metadata.xml b/net-misc/spice-gtk/metadata.xml
new file mode 100644
index 000000000000..b9f3a7c9e365
--- /dev/null
+++ b/net-misc/spice-gtk/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/spice-gtk/spice-gtk-0.5.ebuild b/net-misc/spice-gtk/spice-gtk-0.5.ebuild
new file mode 100644
index 000000000000..792040a98b25
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.5.ebuild,v 1.1 2011/02/24 13:46:09 dev-zero Exp $
+
+EAPI=3
+
+inherit python gnome2-utils
+
+PYTHON_DEPEND="python? 2"
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI."
+HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
+SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+cairo doc gnome gstreamer introspection kde +pulseaudio python static-libs"
+
+RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
+ gstreamer? ( media-libs/gstreamer )
+ >=app-emulation/spice-protocol-0.6.3
+ >=x11-libs/pixman-0.17.7
+ >=media-libs/celt-0.5.1.1:0.5.1
+ dev-libs/openssl
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.2
+ virtual/jpeg
+ sys-libs/zlib
+ introspection? ( dev-libs/gobject-introspection )
+ python? ( dev-python/pygtk:2 )
+ gnome? ( gnome-base/gconf )"
+DEPEND="${RDEPEND}
+ dev-lang/python
+ dev-lang/perl
+ dev-perl/Text-CSV
+ dev-python/pyparsing
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use gstreamer && use pulseaudio ; then
+ ewarn "spice-gtk can use only one audio backend: gstreamer will be used since you enabled both."
+ fi
+}
+
+src_configure() {
+ local audio="no"
+ use pulseaudio && audio="pulse"
+ use gstreamer && audio="gstreamer"
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable introspection) \
+ --with-audio="${audio}" \
+ $(use_with !cairo x11) \
+ $(use_with python)
+
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
+ use python && rm -rf "${D}"/usr/lib*/python*/site-packages/*.la
+ use doc || rm -rf "${D}/usr/share/gtk-doc"
+
+ dodoc AUTHORS NEWS README TODO
+
+ if use gnome ; then
+ insinto /etc/gconf/schemas
+ doins "${FILESDIR}/spice.schemas"
+ fi
+ if use kde ; then
+ insinto /usr/share/kde4/services
+ doins "${FILESDIR}/spice.protocol"
+ fi
+
+}
+
+pkg_preinst() {
+ use gnome && gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}