summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-29 05:07:19 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-29 05:07:19 +0000
commit06611d006d45a8c33e3ee768c4503b99af503501 (patch)
treee1e674ced565546fb77fe4e3a833ba2e74aecd29 /net-misc/spice-gtk
parentCreate perllocal.pod for modules in site in INSTALLSITEARCH (diff)
downloadgentoo-2-06611d006d45a8c33e3ee768c4503b99af503501.tar.gz
gentoo-2-06611d006d45a8c33e3ee768c4503b99af503501.tar.bz2
gentoo-2-06611d006d45a8c33e3ee768c4503b99af503501.zip
Fix building with python-3 as default interpreter (bug #418017, thanks to Alon Bar-Lev).
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/ChangeLog6
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.12.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index 9eafb99c5c28..2717029e6ae1 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.20 2012/05/26 18:21:46 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.21 2012/05/29 05:07:19 dev-zero Exp $
+
+ 29 May 2012; Tiziano Müller <dev-zero@gentoo.org> spice-gtk-0.12.ebuild:
+ Fix building with python-3 as default interpreter (bug #418017, thanks to
+ Alon Bar-Lev).
*spice-gtk-0.12 (26 May 2012)
diff --git a/net-misc/spice-gtk/spice-gtk-0.12.ebuild b/net-misc/spice-gtk/spice-gtk-0.12.ebuild
index 5002905afee9..2b8c540c714e 100644
--- a/net-misc/spice-gtk/spice-gtk-0.12.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.12.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.12.ebuild,v 1.1 2012/05/26 18:21:46 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.12.ebuild,v 1.2 2012/05/29 05:07:19 dev-zero Exp $
EAPI="4"
GCONF_DEBUG="no"
inherit eutils python
-PYTHON_DEPEND="python? 2"
+PYTHON_DEPEND="2"
DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI."
HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
@@ -62,6 +62,8 @@ DEPEND="${RDEPEND}
# dev-perl/Text-CSV
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
if use gstreamer && use pulseaudio ; then
ewarn "spice-gtk can use only one audio backend: pulseaudio will be used since you enabled both."
fi
@@ -104,6 +106,7 @@ src_install() {
use static-libs || rm -rf "${D}"/usr/lib*/*.la
use python && rm -rf "${D}"/usr/lib*/python*/site-packages/*.la
use doc || rm -rf "${D}/usr/share/gtk-doc"
+ use python && python_convert_shebangs -r 2 "${D}"
make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
}