summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-05-14 19:02:53 +0000
committerJeroen Roovers <jer@gentoo.org>2012-05-14 19:02:53 +0000
commit3820d1c38c508b0b7cd418a73f9720df6b9c4125 (patch)
treee8bbee17d631f035661f609385dbaa180d25ae8a /net-misc/socat
parentDrop maintainer as he will not take care of this stuff in the near future as ... (diff)
downloadgentoo-2-3820d1c38c508b0b7cd418a73f9720df6b9c4125.tar.gz
gentoo-2-3820d1c38c508b0b7cd418a73f9720df6b9c4125.tar.bz2
gentoo-2-3820d1c38c508b0b7cd418a73f9720df6b9c4125.zip
Version bump (bug #415977).
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/ChangeLog9
-rw-r--r--net-misc/socat/socat-1.7.2.1.ebuild53
-rw-r--r--net-misc/socat/socat-2.0.0_beta5.ebuild (renamed from net-misc/socat/socat-2.0.0_beta4.ebuild)4
3 files changed, 63 insertions, 3 deletions
diff --git a/net-misc/socat/ChangeLog b/net-misc/socat/ChangeLog
index 407ac3e62898..68baca97e898 100644
--- a/net-misc/socat/ChangeLog
+++ b/net-misc/socat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/socat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.94 2012/03/07 04:09:45 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.95 2012/05/14 19:02:53 jer Exp $
+
+*socat-2.0.0_beta5 (14 May 2012)
+*socat-1.7.2.1 (14 May 2012)
+
+ 14 May 2012; Jeroen Roovers <jer@gentoo.org> +socat-1.7.2.1.ebuild,
+ -socat-2.0.0_beta4.ebuild, +socat-2.0.0_beta5.ebuild:
+ Version bump (bug #415977).
07 Mar 2012; Jeremy Olexa <darkside@gentoo.org> socat-1.7.2.0.ebuild:
add ~x64-macos, bug 395011
diff --git a/net-misc/socat/socat-1.7.2.1.ebuild b/net-misc/socat/socat-1.7.2.1.ebuild
new file mode 100644
index 000000000000..44a1dc00851a
--- /dev/null
+++ b/net-misc/socat/socat-1.7.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.2.1.ebuild,v 1.1 2012/05/14 19:02:53 jer Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~ppc-macos ~x64-macos"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.2.0-cross-compile.patch
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -Wno-error*
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_test() {
+ TMPDIR="${T}" emake test
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ dodoc BUGREPORTS CHANGES DEVELOPMENT \
+ FAQ FILES PORTING README SECURITY VERSION
+ docinto examples
+ dodoc EXAMPLES *.sh
+ dohtml doc/*.html doc/*.css
+}
diff --git a/net-misc/socat/socat-2.0.0_beta4.ebuild b/net-misc/socat/socat-2.0.0_beta5.ebuild
index 05769fa1ebc1..4f99bdfd0469 100644
--- a/net-misc/socat/socat-2.0.0_beta4.ebuild
+++ b/net-misc/socat/socat-2.0.0_beta5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-2.0.0_beta4.ebuild,v 1.1 2010/08/02 02:37:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-2.0.0_beta5.ebuild,v 1.1 2012/05/14 19:02:53 jer Exp $
EAPI="2"