summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-07-09 10:38:43 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-07-09 10:38:43 +0000
commit133fcf8523ae044197359047092391c7635c9633 (patch)
tree6424a3034ae8ad6b4717a97a9749645ba761dc12 /net-misc/shigofumi
parentppc64 stable wrt #298200 (diff)
downloadgentoo-2-133fcf8523ae044197359047092391c7635c9633.tar.gz
gentoo-2-133fcf8523ae044197359047092391c7635c9633.tar.bz2
gentoo-2-133fcf8523ae044197359047092391c7635c9633.zip
Initial commit of shigofumi, ISDS client. Thx to Petr Pisar for the initial ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/shigofumi')
-rw-r--r--net-misc/shigofumi/ChangeLog12
-rw-r--r--net-misc/shigofumi/metadata.xml13
-rw-r--r--net-misc/shigofumi/shigofumi-0.1.ebuild48
-rw-r--r--net-misc/shigofumi/shigofumi-9999.ebuild48
4 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/shigofumi/ChangeLog b/net-misc/shigofumi/ChangeLog
new file mode 100644
index 000000000000..761bfed9cec8
--- /dev/null
+++ b/net-misc/shigofumi/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-misc/shigofumi
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/shigofumi/ChangeLog,v 1.1 2010/07/09 10:38:43 scarabeus Exp $
+
+*shigofumi-9999 (09 Jul 2010)
+*shigofumi-0.1 (09 Jul 2010)
+
+ 09 Jul 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +shigofumi-0.1.ebuild, +shigofumi-9999.ebuild, +metadata.xml:
+ Initial commit of shigofumi, ISDS client. Thx to Petr Pisar for the
+ initial ebuild.
+
diff --git a/net-misc/shigofumi/metadata.xml b/net-misc/shigofumi/metadata.xml
new file mode 100644
index 000000000000..de5f8192285e
--- /dev/null
+++ b/net-misc/shigofumi/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription>
+ This is command line oriented client for ISDS (Informační systém datových
+ schránek / Data Box Information System) based on libisds library.
+</longdescription>
+<maintainer>
+ <email>scarabeus@gentoo.org</email>
+ <name>Tomáš Chvátal</name>
+</maintainer>
+<herd>no-herd</herd>
+</pkgmetadata>
diff --git a/net-misc/shigofumi/shigofumi-0.1.ebuild b/net-misc/shigofumi/shigofumi-0.1.ebuild
new file mode 100644
index 000000000000..879923c6abb0
--- /dev/null
+++ b/net-misc/shigofumi/shigofumi-0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/shigofumi/shigofumi-0.1.ebuild,v 1.1 2010/07/09 10:38:43 scarabeus Exp $
+
+EAPI=3
+
+[[ ${PV} = 9999* ]] && GIT="git autotools"
+EGIT_REPO_URI='git://repo.or.cz/shigofumi.git'
+WANT_AUTOMAKE="1.11"
+inherit base ${GIT}
+
+DESCRIPTION="Command line client for ISDS"
+HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug nls xattr"
+
+RDEPEND=">=net-libs/libisds-0.3
+ sys-libs/readline
+ dev-libs/confuse
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets"
+
+DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
+
+src_prepare() {
+ base_src_prepare
+ [[ ${PV} = 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable xattr)
+}
diff --git a/net-misc/shigofumi/shigofumi-9999.ebuild b/net-misc/shigofumi/shigofumi-9999.ebuild
new file mode 100644
index 000000000000..532be752c510
--- /dev/null
+++ b/net-misc/shigofumi/shigofumi-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/shigofumi/shigofumi-9999.ebuild,v 1.1 2010/07/09 10:38:43 scarabeus Exp $
+
+EAPI=3
+
+[[ ${PV} = 9999* ]] && GIT="git autotools"
+EGIT_REPO_URI='git://repo.or.cz/shigofumi.git'
+WANT_AUTOMAKE="1.11"
+inherit base ${GIT}
+
+DESCRIPTION="Command line client for ISDS"
+HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug nls xattr"
+
+RDEPEND=">=net-libs/libisds-0.3
+ sys-libs/readline
+ dev-libs/confuse
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets"
+
+DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
+
+src_prepare() {
+ base_src_prepare
+ [[ ${PV} = 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable xattr)
+}