summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-09-02 18:02:28 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-09-02 18:02:28 +0000
commit9d42855a75a69eb01206187ae08084a83ef15370 (patch)
tree66e3335ad7891dbfe6262079d91d824774db616f /net-misc/ser2net
parentremoved obsolete patch (diff)
downloadgentoo-2-9d42855a75a69eb01206187ae08084a83ef15370.tar.gz
gentoo-2-9d42855a75a69eb01206187ae08084a83ef15370.tar.bz2
gentoo-2-9d42855a75a69eb01206187ae08084a83ef15370.zip
version bump, adding init-script + config. Solves bug #160268.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'net-misc/ser2net')
-rw-r--r--net-misc/ser2net/ChangeLog8
-rw-r--r--net-misc/ser2net/files/ser2net.confd23
-rw-r--r--net-misc/ser2net/files/ser2net.initd41
-rw-r--r--net-misc/ser2net/ser2net-2.5.ebuild42
4 files changed, 113 insertions, 1 deletions
diff --git a/net-misc/ser2net/ChangeLog b/net-misc/ser2net/ChangeLog
index e090c090b994..19bbc96222dc 100644
--- a/net-misc/ser2net/ChangeLog
+++ b/net-misc/ser2net/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/ser2net
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ser2net/ChangeLog,v 1.17 2008/09/02 17:58:30 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ser2net/ChangeLog,v 1.18 2008/09/02 18:02:27 sbriesen Exp $
+
+*ser2net-2.5 (02 Sep 2008)
+
+ 02 Sep 2008; Stefan Briesenick <sbriesen@gentoo.org> +files/ser2net.confd,
+ +files/ser2net.initd, +ser2net-2.5.ebuild:
+ version bump, adding init-script + config. Solves bug #160268.
02 Sep 2008; Stefan Briesenick <sbriesen@gentoo.org>
-files/ser2net-2.2-tcpwrappers-configure.in.patch:
diff --git a/net-misc/ser2net/files/ser2net.confd b/net-misc/ser2net/files/ser2net.confd
new file mode 100644
index 000000000000..7d9c536f4376
--- /dev/null
+++ b/net-misc/ser2net/files/ser2net.confd
@@ -0,0 +1,23 @@
+# Config file for /etc/init.d/ser2net
+
+# Set the configuration file to one other than the default of /etc/ser2net.conf
+#
+#CONFIG_FILE="/etc/ser2net.conf"
+
+# Enables the control port and sets the TCP port to listen to for the control port.
+# A port number may be of the form [host,]port, such as 127.0.0.1,2000 or localhost,2000.
+# If this is specified, it will only bind to the IP address specified for the port.
+# Otherwise, it will bind to all the addresses on the machine.
+#
+#CONTROL_PORT=""
+
+# Cisco IOS uses a different mechanism for specifying the baud rates than the mechanism
+# described in RFC2217. This option sets the IOS version of setting the baud rates.
+# The default is RFC2217s.
+#
+#CISCO_IOS="yes"
+
+# Enable or disable UUCP locking (default=yes)
+#
+#UUCP_LOCKS="no"
+
diff --git a/net-misc/ser2net/files/ser2net.initd b/net-misc/ser2net/files/ser2net.initd
new file mode 100644
index 000000000000..7ba1b0a85830
--- /dev/null
+++ b/net-misc/ser2net/files/ser2net.initd
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ser2net/files/ser2net.initd,v 1.1 2008/09/02 18:02:28 sbriesen Exp $
+
+depend() {
+ need net
+ after bootmisc
+}
+
+config_check() {
+ SER2NET_OPTS=""
+ CONFIG_FILE_DEFAULT="/etc/ser2net.conf"
+
+ yesno "${CISCO_IOS:-no}" && SER2NET_OPTS="${SER2NET_OPTS} -b"
+ yesno "${UUCP_LOCKS:-yes}" || SER2NET_OPTS="${SER2NET_OPTS} -u"
+ [ -z "${CONFIG_FILE}" ] && CONFIG_FILE="${CONFIG_FILE_DEFAULT}"
+ [ -n "${CONTROL_PORT}" ] && SER2NET_OPTS="${SER2NET_OPTS} -p ${CONTROL_PORT}"
+ [ "${CONFIG_FILE}" != "${CONFIG_FILE_DEFAULT}" ] && SER2NET_OPTS="${SER2NET_OPTS} -c ${CONFIG_FILE}"
+
+ if [ ! -f "${CONFIG_FILE}" ]; then
+ eerror "Please create ${CONFIG_FILE}"
+ eerror "Sample conf: ${CONFIG_FILE_DEFAULT}.dist"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ config_check || return ${?}
+ ebegin "Starting Serial to network proxy (${SVCNAME})"
+ start-stop-daemon --start --quiet --pidfile /var/run/${SVCNAME}.pid \
+ --exec /usr/sbin/ser2net -- ${SER2NET_OPTS} -P /var/run/${SVCNAME}.pid
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Serial to network proxy (${SVCNAME})"
+ start-stop-daemon --stop --quiet --pidfile /var/run/${SVCNAME}.pid
+ eend ${?}
+}
diff --git a/net-misc/ser2net/ser2net-2.5.ebuild b/net-misc/ser2net/ser2net-2.5.ebuild
new file mode 100644
index 000000000000..5e7f1352c7d0
--- /dev/null
+++ b/net-misc/ser2net/ser2net-2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ser2net/ser2net-2.5.ebuild,v 1.1 2008/09/02 18:02:27 sbriesen Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+DESCRIPTION="Serial To Network Proxy"
+SRC_URI="mirror://sourceforge/ser2net/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/ser2net"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+
+IUSE="tcpd"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ local myopts="$(use_with tcpd tcp-wrappers) --with-uucp-locking"
+ econf ${myopts} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ einstall
+ insinto /etc
+ newins ${PN}.conf ${PN}.conf.dist
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ dodoc AUTHORS NEWS README ChangeLog
+}