summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Doty <kingtaco@gentoo.org>2009-10-16 20:16:37 +0000
committerMike Doty <kingtaco@gentoo.org>2009-10-16 20:16:37 +0000
commitc82d79070828c8562b08a9ad41a4e990d01c8393 (patch)
tree1451f3fd4f8d1bd0220a8f44c0a71d69f5b39ea6 /net-misc/rwhoisd
parentfix bashism in init script (bug #195939) (diff)
downloadgentoo-2-c82d79070828c8562b08a9ad41a4e990d01c8393.tar.gz
gentoo-2-c82d79070828c8562b08a9ad41a4e990d01c8393.tar.bz2
gentoo-2-c82d79070828c8562b08a9ad41a4e990d01c8393.zip
initial import
(Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/rwhoisd')
-rw-r--r--net-misc/rwhoisd/ChangeLog10
-rw-r--r--net-misc/rwhoisd/files/rwhoisd18
-rw-r--r--net-misc/rwhoisd/files/rwhoisd-destdir.patch27
-rw-r--r--net-misc/rwhoisd/files/rwhoisd.conf8
-rw-r--r--net-misc/rwhoisd/metadata.xml9
-rw-r--r--net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild39
6 files changed, 111 insertions, 0 deletions
diff --git a/net-misc/rwhoisd/ChangeLog b/net-misc/rwhoisd/ChangeLog
new file mode 100644
index 000000000000..1e27cb9db7dd
--- /dev/null
+++ b/net-misc/rwhoisd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/rwhoisd
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/ChangeLog,v 1.1 2009/10/16 20:16:36 kingtaco Exp $
+
+*rwhoisd-1.5.9.5 (16 Oct 2009)
+
+ 16 Oct 2009; Mike Doty <kingtaco@gentoo.org> +rwhoisd-1.5.9.5.ebuild,
+ +files/rwhoisd, +files/rwhoisd.conf, +files/rwhoisd-destdir.patch,
+ +metadata.xml:
+ Initial version
diff --git a/net-misc/rwhoisd/files/rwhoisd b/net-misc/rwhoisd/files/rwhoisd
new file mode 100644
index 000000000000..9c3b6bd05222
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+depend() {
+ use logger
+ need net
+}
+
+start() {
+ ebegin "Starting rwhoisd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/rwhoisd ${RWHOISD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tftpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rwhoisd
+ eend $?
+}
diff --git a/net-misc/rwhoisd/files/rwhoisd-destdir.patch b/net-misc/rwhoisd/files/rwhoisd-destdir.patch
new file mode 100644
index 000000000000..54369048de35
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd-destdir.patch
@@ -0,0 +1,27 @@
+--- tools/rwhois_repack/Makefile.in.orig 2009-10-16 11:30:40.000000000 -0700
++++ tools/rwhois_repack/Makefile.in 2009-10-16 11:31:20.000000000 -0700
+@@ -52,9 +52,9 @@
+ # procedural
+
+ install:
+- if [ ! -d $(exec_prefix) ]; then mkdir $(exec_prefix); fi
+- if [ ! -d $(bindir) ]; then mkdir $(bindir); fi
+- $(INSTALL) rwhois_repack $(bindir)
++ if [ ! -d $(DESTDIR)$(exec_prefix) ]; then mkdir $(DESTDIR)$(exec_prefix); fi
++ if [ ! -d $(DESTDIR)$(bindir) ]; then mkdir $(DESTDIR)$(bindir); fi
++ $(INSTALL) rwhois_repack $(DESTDIR)$(bindir)
+
+ uninstall:
+ $(RM) $(bindir)/rwhois_repack
+
+--- sample.data/Makefile.in.orig 2009-10-16 11:37:54.000000000 -0700
++++ sample.data/Makefile.in 2009-10-16 11:38:22.000000000 -0700
+@@ -10,7 +10,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = $(exec_prefix)/bin
+-etcdir = $(exec_prefix)/etc
++etcdir = /etc
+
+ srcdir = @srcdir@
+ VPATH = @srcdir@
diff --git a/net-misc/rwhoisd/files/rwhoisd.conf b/net-misc/rwhoisd/files/rwhoisd.conf
new file mode 100644
index 000000000000..4715be3d632f
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd.conf
@@ -0,0 +1,8 @@
+#$Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/files/rwhoisd.conf,v 1.1 2009/10/16 20:16:37 kingtaco Exp $
+OPTS="-c /etc/rwhoisd/rwhoisd.conf"
+
+#Pass any additional options to rwhoisd here.
+
+RWHOISD_OPTS="${OPTS}"
+
+
diff --git a/net-misc/rwhoisd/metadata.xml b/net-misc/rwhoisd/metadata.xml
new file mode 100644
index 000000000000..9786e28c7db3
--- /dev/null
+++ b/net-misc/rwhoisd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>kingtaco@gentoo.org</email>
+</maintainer>
+<longdescription>rwhois server from ARIN</longdescription>
+</pkgmetadata>
diff --git a/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild b/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild
new file mode 100644
index 000000000000..9d2e0cc740f5
--- /dev/null
+++ b/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild,v 1.1 2009/10/16 20:16:36 kingtaco Exp $
+
+EAPI=0
+inherit eutils
+
+DESCRIPTION="ARIN rwhois daemon"
+HOMEPAGE="http://projects.arin.net/rwhois/"
+SRC_URI="http://projects.arin.net/rwhois/ftp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ epatch "${FILESDIR}"/rwhoisd-destdir.patch || die "epatch failed"
+ econf
+ emake -j1
+}
+
+src_install () {
+ emake -j1 install DESTDIR="${D}"
+ doinitd "${FILESDIR}"/rwhoisd || die "doinitd failed"
+ newconfd "${FILESDIR}"/rwhoisd.conf rwhoisd || die "newconfd failed"
+}
+
+pkg_setup() {
+ enewgroup rwhoisd
+ enewuser rwhoisd -1 -1 /var/empty rwhoisd
+}
+
+pkg_postinst () {
+ einfo "Please make sure to set the userid in rwhoisd.conf to rwhoisd."
+ einfo "It is highly inadvisable to run rwhoisd as root."
+}