summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-01 07:11:53 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-01 07:11:53 +0000
commit408917bc6750adaa8c67b5c32a744eac8a28b91b (patch)
treee0889d76fc12ef4787e1b8dba655e5dc05bfe9f4 /net-misc/rsync
parentDoS fix redux (diff)
downloadgentoo-2-408917bc6750adaa8c67b5c32a744eac8a28b91b.tar.gz
gentoo-2-408917bc6750adaa8c67b5c32a744eac8a28b91b.tar.bz2
gentoo-2-408917bc6750adaa8c67b5c32a744eac8a28b91b.zip
DoS redux
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/rsync-2.5.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/rsync/rsync-2.5.2-r1.ebuild b/net-misc/rsync/rsync-2.5.2-r1.ebuild
new file mode 100644
index 000000000000..7a2060d08124
--- /dev/null
+++ b/net-misc/rsync/rsync-2.5.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.5.2-r1.ebuild,v 1.1 2002/03/01 07:11:53 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="File transfer program to keep remote files into sync"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz"
+HOMEPAGE="http://rsync.samba.org"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #This next patch fixes a remote DoS:
+ #http://bugs.debian.org/128632
+ cat ${FILESDIR}/rsync-gentoo-${PV}.patch | patch -p1 -l || die
+#change confdir to /etc/rsync rather than just /etc (the --sysconfdir configure option doesn't work
+ cp rsync.h rsync.h.orig
+ sed -e 's:RSYNCD_CONF "/etc/rsyncd.conf":RSYNCD_CONF "/etc/rsync/rsyncd.conf":g' rsync.h.orig > rsync.h
+#yes, updating the man page is very important.
+ cp rsyncd.conf.5 rsyncd.conf.5.orig
+ sed -e 's:/etc/rsyncd:/etc/rsync/rsyncd:g' rsyncd.conf.5.orig > rsyncd.conf.5
+}
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ if [ "`use static`" ] ; then
+ emake LDFLAGS="-static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+ if [ -z "`use build`" ]
+ then
+ dodir /etc/rsync
+ dodoc COPYING NEWS OLDNEWS README TODO tech_report.tex
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ if [ ! -d /etc/rsync ]
+ then
+ mkdir /etc/rsync
+ fi
+}