summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-12 21:19:07 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-12 21:19:07 +0000
commit2755e9a613824ded0996d054c2ef549a849e6cc9 (patch)
tree8bf504d27373353f33606bc9f84cd5d87f25f376 /net-misc/rsync
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-2755e9a613824ded0996d054c2ef549a849e6cc9.tar.gz
gentoo-2-2755e9a613824ded0996d054c2ef549a849e6cc9.tar.bz2
gentoo-2-2755e9a613824ded0996d054c2ef549a849e6cc9.zip
Version bump rsync-3.0.0_pre7 rsync-3.0.0_pre8.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/ChangeLog9
-rw-r--r--net-misc/rsync/files/digest-rsync-3.0.0_pre83
-rw-r--r--net-misc/rsync/rsync-3.0.0_pre8.ebuild68
3 files changed, 78 insertions, 2 deletions
diff --git a/net-misc/rsync/ChangeLog b/net-misc/rsync/ChangeLog
index 4fc1a4d864a3..a14f6551700a 100644
--- a/net-misc/rsync/ChangeLog
+++ b/net-misc/rsync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/rsync
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.143 2007/12/17 00:27:51 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.144 2008/01/12 21:19:06 vapier Exp $
+
+*rsync-3.0.0_pre8 (12 Jan 2008)
+
+ 12 Jan 2008; Mike Frysinger <vapier@gentoo.org> +rsync-3.0.0_pre8.ebuild:
+ Version bump rsync-3.0.0_pre7 rsync-3.0.0_pre8.
*rsync-3.0.0_pre7 (17 Dec 2007)
diff --git a/net-misc/rsync/files/digest-rsync-3.0.0_pre8 b/net-misc/rsync/files/digest-rsync-3.0.0_pre8
new file mode 100644
index 000000000000..876125dc3f00
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-3.0.0_pre8
@@ -0,0 +1,3 @@
+MD5 cb6a0042202c1ece2232e1cbb02b8052 rsync-3.0.0pre8.tar.gz 750791
+RMD160 cf9f6d4879ee132f214c3a6c161957b9d5ad085d rsync-3.0.0pre8.tar.gz 750791
+SHA256 9e4a23ca5e4a8be61bc6c7f3691df45590cc5725d919728b710c3d639662cd69 rsync-3.0.0pre8.tar.gz 750791
diff --git a/net-misc/rsync/rsync-3.0.0_pre8.ebuild b/net-misc/rsync/rsync-3.0.0_pre8.ebuild
new file mode 100644
index 000000000000..8a5cd3636589
--- /dev/null
+++ b/net-misc/rsync/rsync-3.0.0_pre8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-3.0.0_pre8.ebuild,v 1.1 2008/01/12 21:19:06 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs autotools
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="acl ipv6 static xattr xinetd"
+
+DEPEND=">=dev-libs/popt-1.5
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ xattr? ( sys-apps/attr )
+ xinetd? ( sys-apps/xinetd )"
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${P/_/}.tar.gz
+ cd "${S}"
+ rm -f configure.sh
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf \
+ --without-included-popt \
+ $(use_enable acl acl-support) \
+ $(use_enable xattr xattr-support) \
+ $(use_enable ipv6) \
+ --with-rsyncd-conf=/etc/rsyncd.conf \
+ || die
+ emake || die "emake failed"
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/rsync/rsyncd.conf ]] && [[ ! -e ${ROOT}/etc/rsyncd.conf ]] ; then
+ mv "${ROOT}"/etc/rsync/rsyncd.conf "${ROOT}"/etc/rsyncd.conf
+ rm -f "${ROOT}"/etc/rsync/.keep
+ rmdir "${ROOT}"/etc/rsync >& /dev/null
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d rsyncd
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ insinto /etc
+ doins "${FILESDIR}"/rsyncd.conf
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd rsyncd
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The rsyncd.conf file has been moved for you to /etc/rsyncd.conf"
+ echo
+ ewarn "Please make sure you do NOT disable the rsync server running"
+ ewarn "in a chroot. Please check /etc/rsyncd.conf and make sure"
+ ewarn "it says: use chroot = yes"
+}