summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-05-12 20:07:18 +0000
committerRoy Marples <uberlord@gentoo.org>2006-05-12 20:07:18 +0000
commit73445a46b4f587c7a79f58b20bee466c13947ad3 (patch)
treebdb5da8abd23bd5f58a758d8c9ae92eb1926df94 /net-misc/resolvconf-gentoo
parentChanged maintainer back to games since warpzero is being retired. (diff)
downloadgentoo-2-73445a46b4f587c7a79f58b20bee466c13947ad3.tar.gz
gentoo-2-73445a46b4f587c7a79f58b20bee466c13947ad3.tar.bz2
gentoo-2-73445a46b4f587c7a79f58b20bee466c13947ad3.zip
NEWNEW should be NEWNS for resolvconf -v
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'net-misc/resolvconf-gentoo')
-rw-r--r--net-misc/resolvconf-gentoo/ChangeLog8
-rw-r--r--net-misc/resolvconf-gentoo/files/digest-resolvconf-gentoo-0.53
-rw-r--r--net-misc/resolvconf-gentoo/resolvconf-gentoo-0.5.ebuild61
3 files changed, 71 insertions, 1 deletions
diff --git a/net-misc/resolvconf-gentoo/ChangeLog b/net-misc/resolvconf-gentoo/ChangeLog
index b258295254be..d6ef9c347f8f 100644
--- a/net-misc/resolvconf-gentoo/ChangeLog
+++ b/net-misc/resolvconf-gentoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/resolvconf-gentoo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/resolvconf-gentoo/ChangeLog,v 1.4 2006/05/10 11:45:12 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/resolvconf-gentoo/ChangeLog,v 1.5 2006/05/12 20:07:18 uberlord Exp $
+
+*resolvconf-gentoo-0.5 (12 May 2006)
+
+ 12 May 2006; Roy Marples <uberlord@gentoo.org>
+ +resolvconf-gentoo-0.5.ebuild:
+ NEWNEW should be NEWNS for resolvconf -v
*resolvconf-gentoo-0.4 (10 May 2006)
diff --git a/net-misc/resolvconf-gentoo/files/digest-resolvconf-gentoo-0.5 b/net-misc/resolvconf-gentoo/files/digest-resolvconf-gentoo-0.5
new file mode 100644
index 000000000000..ac1f737b04da
--- /dev/null
+++ b/net-misc/resolvconf-gentoo/files/digest-resolvconf-gentoo-0.5
@@ -0,0 +1,3 @@
+MD5 f8f72f508d877f33c467f0bc9bde588c resolvconf-gentoo-0.5.tar.bz2 5351
+RMD160 63054a6af09c858150ebd1d50923e9a630c92972 resolvconf-gentoo-0.5.tar.bz2 5351
+SHA256 38dc2d73a616710f320a1918475904a5ad48fe8f180f23ff229a3c9a4448ee03 resolvconf-gentoo-0.5.tar.bz2 5351
diff --git a/net-misc/resolvconf-gentoo/resolvconf-gentoo-0.5.ebuild b/net-misc/resolvconf-gentoo/resolvconf-gentoo-0.5.ebuild
new file mode 100644
index 000000000000..194fd133d7fc
--- /dev/null
+++ b/net-misc/resolvconf-gentoo/resolvconf-gentoo-0.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/resolvconf-gentoo/resolvconf-gentoo-0.5.ebuild,v 1.1 2006/05/12 20:07:18 uberlord Exp $
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="http://dev.gentoo.org/~uberlord/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+pkg_setup() {
+ if ! grep -q "^uniqify()" "${ROOT}"/etc/init.d/functions.sh ; then
+ eerror "/etc/init.d/functions.sh does not supply the uniqify function"
+ eerror "Please upgrade to a baselayout that support it"
+ eerror "(baselayout-1.12.0_pre17 and later versions do)"
+ die "function uniqify does not exist"
+ fi
+}
+
+src_install() {
+ make ROOT="${D}" install || die "Failed to install"
+}
+
+pkg_postinst() {
+ if [[ ! -"L ${ROOT}/etc/resolv.conf" ]] \
+ || [[ $(readlink "${ROOT}/etc/resolv.conf") != \
+ "resolvconf/run/resolv.conf" ]] ; then
+ ewarn "resolvconf requires ${ROOT}/etc/resolv.conf to be a symbolic"
+ ewarn "to resolvconf/run/resolv.conf"
+ einfo "To set this up automatically type"
+ einfo " emerge --config =${PF}"
+ fi
+}
+
+pkg_config() {
+ cd "${ROOT}/etc"
+ if [[ -L resolv.conf && $(readlink resolv.conf) == \
+ "resolvconf/run/resolv.conf" ]] ; then
+ einfo "${ROOT}/etc/resolv.conf is already configured for ${PN}"
+ else
+ if [[ -e resolv.conf ]] ; then
+ einfo "Your existing resolv.conf is will be mapped to an"
+ einfo "interface called \"dummy\" in resolvconf. This will"
+ einfo "disappear when you reboot."
+ cp resolv.conf resolvconf/run/resolv.conf
+ [[ ! -d resolvconf/run/interfaces ]] \
+ && mkdir resolvconf/run/interfaces
+ cp resolv.conf resolvconf/run/interfaces/dummy
+ echo "dummy" > resolvconf/run/add_order
+ fi
+ rm -f resolv.conf
+ ln -snf resolvconf/run/resolv.conf .
+ einfo "${ROOT}/etc/resolv.conf is now correctly configured for ${PN}"
+ fi
+}