summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-07-19 13:02:36 +0000
committerRoy Marples <uberlord@gentoo.org>2006-07-19 13:02:36 +0000
commita81d02483bca7dadaa8b91dcc2de9c3ce33cf615 (patch)
treed974a0dd93b70be03e0950bf7d9246e904a96c33 /net-misc/radvd
parentStable on hppa. (diff)
downloadgentoo-2-a81d02483bca7dadaa8b91dcc2de9c3ce33cf615.tar.gz
gentoo-2-a81d02483bca7dadaa8b91dcc2de9c3ce33cf615.tar.bz2
gentoo-2-a81d02483bca7dadaa8b91dcc2de9c3ce33cf615.zip
Fix some potential quoting issues.
Add information to help setup radvd for grsec users. (Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'net-misc/radvd')
-rw-r--r--net-misc/radvd/ChangeLog7
-rw-r--r--net-misc/radvd/files/radvd.conf11
-rw-r--r--net-misc/radvd/files/radvd.init47
-rw-r--r--net-misc/radvd/metadata.xml4
-rw-r--r--net-misc/radvd/radvd-0.9.1.ebuild9
5 files changed, 72 insertions, 6 deletions
diff --git a/net-misc/radvd/ChangeLog b/net-misc/radvd/ChangeLog
index 0e22bd682a87..87c9e3999f61 100644
--- a/net-misc/radvd/ChangeLog
+++ b/net-misc/radvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/radvd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.30 2006/07/06 20:54:07 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.31 2006/07/19 13:02:36 uberlord Exp $
+
+ 19 Jul 2006; Roy Marples <uberlord@gentoo.org> +files/radvd.conf,
+ +files/radvd.init, metadata.xml, radvd-0.9.1.ebuild:
+ Fix some potential quoting issues.
+ Add information to help setup radvd for grsec users.
06 Jul 2006; Henrik Brix Andersen <brix@gentoo.org> radvd-0.9.1.ebuild:
Updated RDEPEND, bug #138203.
diff --git a/net-misc/radvd/files/radvd.conf b/net-misc/radvd/files/radvd.conf
new file mode 100644
index 000000000000..e025c6862f67
--- /dev/null
+++ b/net-misc/radvd/files/radvd.conf
@@ -0,0 +1,11 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/files/radvd.conf,v 1.1 2006/07/19 13:02:36 uberlord Exp $
+
+# Extra options to pass to radvd
+OPTIONS=""
+
+# Set this to "no" to tell the init script NOT to set up IPv6 forwarding
+# using /proc/sys/net/ipv6/conf/all/forwarding
+# Only change this if you know what you're doing!
+FORWARD="yes"
diff --git a/net-misc/radvd/files/radvd.init b/net-misc/radvd/files/radvd.init
new file mode 100644
index 000000000000..af2659926cb2
--- /dev/null
+++ b/net-misc/radvd/files/radvd.init
@@ -0,0 +1,47 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/files/radvd.init,v 1.1 2006/07/19 13:02:36 uberlord Exp $
+
+CONFIGFILE=/etc/radvd.conf
+PIDFILE=/var/run/radvd/radvd.pid
+SYSCTL_FORWARD=net.ipv6.conf.all.forwarding
+
+depend () {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f ${CONFIGFILE} ]; then
+ eerror "Configuration file ${CONFIGFILE} not found"
+ return 1
+ fi
+}
+
+start () {
+ checkconfig || return 1
+
+ if [[ ${FORWARD} != "no" ]]; then
+ ebegin "Enabling IPv6 forwarding"
+ sysctl "${SYSCTL_FORWARD}=1" >/dev/null
+ eend $?
+ fi
+
+ ebegin "Starting IPv6 Router Advertisement Daemon"
+ start-stop-daemon --start --exec /usr/sbin/radvd \
+ --pidfile "${PIDFILE}" \
+ -- -C "${CONFIGFILE}" -p "${PIDFILE}" -u radvd ${OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping IPv6 Router Advertisement Daemon"
+ start-stop-daemon --stop --exec /usr/sbin/radvd --pidfile "${PIDFILE}"
+ eend $?
+
+ if [[ ${FORWARD} != "no" ]]; then
+ ebegin "Disabling IPv6 forwarding"
+ sysctl "${SYSCTL_FORWARD}=0" > /dev/null
+ eend $?
+ fi
+}
diff --git a/net-misc/radvd/metadata.xml b/net-misc/radvd/metadata.xml
index 2cb6e0657f99..68a9b0db8ed6 100644
--- a/net-misc/radvd/metadata.xml
+++ b/net-misc/radvd/metadata.xml
@@ -6,7 +6,7 @@
<email>ipv6@gentoo.org</email>
</maintainer>
<maintainer>
- <email>brix@gentoo.org</email>
- <name>Henrik Brix Andersen</name>
+ <email>uberlord@gentoo.org</email>
+ <name>Roy Marples</name>
</maintainer>
</pkgmetadata>
diff --git a/net-misc/radvd/radvd-0.9.1.ebuild b/net-misc/radvd/radvd-0.9.1.ebuild
index 0f5addf1bf5e..d710936fde66 100644
--- a/net-misc/radvd/radvd-0.9.1.ebuild
+++ b/net-misc/radvd/radvd-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.9.1.ebuild,v 1.5 2006/07/06 20:54:07 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.9.1.ebuild,v 1.6 2006/07/19 13:02:36 uberlord Exp $
inherit eutils
@@ -40,8 +40,8 @@ src_install() {
dodoc CHANGES README TODO radvd.conf.example
dohtml INTRO.html
- newinitd "${FILESDIR}"/${P}-init.d ${PN}
- newconfd "${FILESDIR}"/${P}-conf.d ${PN}
+ newinitd "${FILESDIR}/${PN}".init "${PN}"
+ newconfd "${FILESDIR}/${PN}".conf "${PN}"
# location of radvd.pid needs to be writeable by the radvd user
keepdir /var/run/radvd
@@ -57,4 +57,7 @@ pkg_postinst() {
einfo "An example configuration file has been installed as"
einfo "/usr/share/doc/${PF}/radvd.conf.example.gz"
einfo
+ einfo "grsec users should allow a specific group to read /proc"
+ einfo "and add the radvd user to that group, otherwise radvd may"
+ einfo "segfault on startup"
}