summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-28 14:22:48 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-28 14:22:48 +0000
commit9ee000eaaa2f62bd87e7d4f6f973f27d15ba6033 (patch)
tree56d1dcbdf7856438488da17538346a1a52736fd7 /net-misc/putty
parentMarked ~hppa too. (diff)
downloadgentoo-2-9ee000eaaa2f62bd87e7d4f6f973f27d15ba6033.tar.gz
gentoo-2-9ee000eaaa2f62bd87e7d4f6f973f27d15ba6033.tar.bz2
gentoo-2-9ee000eaaa2f62bd87e7d4f6f973f27d15ba6033.zip
Install icons in different sizes by Pacho Ramos (bug #473022).
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/putty-0.62.20120823-r1.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 0591c8a4d7b2..1e1aa9104492 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.71 2013/06/10 20:57:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.72 2013/06/28 14:22:47 jer Exp $
+
+*putty-0.62.20120823-r1 (28 Jun 2013)
+
+ 28 Jun 2013; Jeroen Roovers <jer@gentoo.org> +putty-0.62.20120823-r1.ebuild:
+ Install icons in different sizes by Pacho Ramos (bug #473022).
10 Jun 2013; Jeroen Roovers <jer@gentoo.org> putty-0.62.20120823.ebuild:
Fix sed script.
diff --git a/net-misc/putty/putty-0.62.20120823-r1.ebuild b/net-misc/putty/putty-0.62.20120823-r1.ebuild
new file mode 100644
index 000000000000..50e770bbcc51
--- /dev/null
+++ b/net-misc/putty/putty-0.62.20120823-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.62.20120823-r1.ebuild,v 1.1 2013/06/28 14:22:48 jer Exp $
+
+EAPI="4"
+
+inherit autotools eutils gnome2-utils toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)-2012-08-23"
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://tartarus.org/~simon/${PN}-snapshots/${PN}-${MY_PV}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos"
+
+RDEPEND="
+ !net-misc/pssh
+ dev-libs/glib
+ kerberos? ( virtual/krb5 )
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ cd "${S}"/unix || die
+ sed \
+ -i configure.ac \
+ -e '/AM_PATH_GTK(/d' \
+ -e 's|-Wall -Werror||g' || die
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die
+ econf $(use_with kerberos gssapi)
+}
+
+src_compile() {
+ cd "${S}"/unix || die
+ emake $(usex ipv6 '' COMPAT=-DNO_IPV6)
+
+ cd "${S}"/icons || die
+ for i in 16 22 24 32 48 64 128 256; do
+ ./mkicon.py putty_icon ${i} putty-${i}.png || die
+ done
+}
+
+src_install() {
+ if use doc; then
+ dodoc doc/puttydoc.txt
+ dohtml doc/*.html
+ fi
+
+ cd "${S}"/unix || die
+ default
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ cd "${S}"/icons || die
+ for i in 16 22 24 32 48 64 128 256; do
+ newicon -s ${i} putty-${i}.png putty.png
+ done
+
+ make_desktop_entry putty PuTTY putty Network
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}