summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-08-04 16:19:31 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-08-04 16:19:31 +0000
commit9ea1ef711517d16a4b55293d1ddbca06a8ee972d (patch)
treec65c14ac1ef2281c444b0a473cb2382d5e83ff19 /net-misc/putty
parentversion bump, bug #48114 (Manifest recommit) (diff)
downloadgentoo-2-9ea1ef711517d16a4b55293d1ddbca06a8ee972d.tar.gz
gentoo-2-9ea1ef711517d16a4b55293d1ddbca06a8ee972d.tar.bz2
gentoo-2-9ea1ef711517d16a4b55293d1ddbca06a8ee972d.zip
fixing #59383
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/Manifest6
-rw-r--r--net-misc/putty/files/digest-putty-0.551
-rw-r--r--net-misc/putty/putty-0.55.ebuild66
4 files changed, 75 insertions, 5 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 9fc8515937b7..bedcb07afc9a 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.17 2004/06/25 00:06:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.18 2004/08/04 16:19:31 taviso Exp $
+
+*putty-0.55 (04 Aug 2004)
+
+ 04 Aug 2004; Tavis Ormandy <taviso@gentoo.org> +putty-0.55.ebuild:
+ 0.55 bumped to stable for security #59383, old ebuilds removed.
01 Jun 2004; Tavis Ormandy <taviso@gentoo.org> putty-0.54.ebuild:
include puttygen binary
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index bfa997755719..4feb421471d2 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,8 +1,6 @@
-MD5 f4c82e7ad0d5b9a78efc7df63e57bec6 putty-0.54_pre1.ebuild 1657
-MD5 3ddee545c72b79b0b0f92069edfcedf5 putty-0.54.ebuild 1492
+MD5 0a9f0c74abfe7f6b4d5760a8e54edffb putty-0.55.ebuild 1490
MD5 067ee148f35ca26c25a14e63387e00da ChangeLog 2610
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
-MD5 a2ad14ee6d36a140e2cc1cee21288bd9 files/digest-putty-0.54 62
+MD5 834622a19cd41509df5e75f8a7bbcafd files/digest-putty-0.55 63
MD5 4f674a5fd23877ac6d76c6d9baa33041 files/putty-ut_time.patch 824
MD5 85355228c88a7a925e751df0f058f0ea files/putty.desktop 207
-MD5 d3c6f158244af5bb6cdd7bbda46e8dc6 files/digest-putty-0.54_pre1 71
diff --git a/net-misc/putty/files/digest-putty-0.55 b/net-misc/putty/files/digest-putty-0.55
new file mode 100644
index 000000000000..e73831650dd6
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-0.55
@@ -0,0 +1 @@
+MD5 b827836bec1109a2c0af9af0f9ae0bae putty-0.55.tar.gz 1280000
diff --git a/net-misc/putty/putty-0.55.ebuild b/net-misc/putty/putty-0.55.ebuild
new file mode 100644
index 000000000000..22f6c7a15a59
--- /dev/null
+++ b/net-misc/putty/putty-0.55.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.55.ebuild,v 1.1 2004/08/04 16:19:31 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://the.earth.li/~sgtatham/putty/latest/${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="x86 alpha ~ppc ~sparc ~amd64"
+IUSE="doc"
+
+RDEPEND="=x11-libs/gtk+-1.2* virtual/x11"
+
+DEPEND="${RDEPEND} dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+
+ ebegin "Generating Makefiles"
+ cd ${S}; perl ${S}/mkfiles.pl || die
+ eend $?
+
+ ebegin "Setting CFLAGS"
+ sed -i "s!-O2!${CFLAGS}!g" ${S}/unix/Makefile.gtk
+ eend $?
+
+ # apply ut_time patch for amd64
+ use amd64 && epatch ${FILESDIR}/putty-ut_time.patch
+}
+
+src_compile() {
+ cd ${S}/unix; emake -f Makefile.gtk || die "make failed"
+}
+
+src_install() {
+ cd ${S}/doc
+
+ doman plink.1 pterm.1 putty.1 puttytel.1 puttygen.1
+
+ cd ${S}/unix
+
+ dobin plink pterm putty puttytel psftp pscp puttygen
+
+ cd ${S}
+
+ dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER website.url MODULE
+ use doc && dodoc doc/*
+
+ prepallman
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/putty.desktop
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires kernel UNIX98 PTY support to operate."
+ ewarn
+ fi
+}