summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-23 12:32:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-23 12:32:49 +0000
commit017fe958c8d0a82fdbb6ebf1e5db3eb99f9fc26c (patch)
tree69e51321c7e9de9fabb4601a4000856b92347fc5 /net-misc/pen
parentRefactor nx logic. Thanks to Dan Weeks <dan@danweeks.net>. Bug #372257 (diff)
downloadgentoo-2-017fe958c8d0a82fdbb6ebf1e5db3eb99f9fc26c.tar.gz
gentoo-2-017fe958c8d0a82fdbb6ebf1e5db3eb99f9fc26c.tar.bz2
gentoo-2-017fe958c8d0a82fdbb6ebf1e5db3eb99f9fc26c.zip
EAPI4fy and ssl use flag. Bug #372505. Thanks to T-Dawg <tgates81@gmail.com> for the patch
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/pen')
-rw-r--r--net-misc/pen/ChangeLog11
-rw-r--r--net-misc/pen/pen-0.18.0-r1.ebuild23
-rw-r--r--net-misc/pen/pen-0.18.0.ebuild17
3 files changed, 32 insertions, 19 deletions
diff --git a/net-misc/pen/ChangeLog b/net-misc/pen/ChangeLog
index e8d6107374ba..5745e82a1046 100644
--- a/net-misc/pen/ChangeLog
+++ b/net-misc/pen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/pen
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pen/ChangeLog,v 1.11 2009/09/12 09:40:02 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pen/ChangeLog,v 1.12 2011/06/23 12:32:49 hwoarang Exp $
+
+*pen-0.18.0-r1 (23 Jun 2011)
+
+ 23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -pen-0.18.0.ebuild,
+ +pen-0.18.0-r1.ebuild:
+ EAPI4fy and ssl use flag. Bug #372505. Thanks to T-Dawg <tgates81@gmail.com>
+ for the patch
*pen-0.18.0 (12 Sep 2009)
diff --git a/net-misc/pen/pen-0.18.0-r1.ebuild b/net-misc/pen/pen-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..7736daacc13e
--- /dev/null
+++ b/net-misc/pen/pen-0.18.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pen/pen-0.18.0-r1.ebuild,v 1.1 2011/06/23 12:32:49 hwoarang Exp $
+
+EAPI="4"
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://siag.nu/pen/"
+SRC_URI="http://siag.nu/pub/pen/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+src_configure() {
+ econf $(use_with ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+}
diff --git a/net-misc/pen/pen-0.18.0.ebuild b/net-misc/pen/pen-0.18.0.ebuild
deleted file mode 100644
index d2c8d57cb605..000000000000
--- a/net-misc/pen/pen-0.18.0.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pen/pen-0.18.0.ebuild,v 1.1 2009/09/12 09:40:02 patrick Exp $
-
-DESCRIPTION="TCP Load Balancing Port Forwarder"
-HOMEPAGE="http://siag.nu/pen/"
-SRC_URI="http://siag.nu/pub/pen/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND="dev-libs/openssl"
-
-src_install() {
- make DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die
-}