summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-10-11 12:15:49 +0000
committerRoy Marples <uberlord@gentoo.org>2006-10-11 12:15:49 +0000
commit6a19dbfbfd83c00b183936165a5ec2aaf45ba7b3 (patch)
tree4fea1b146d5b899f8e2c2bbcf1452ec38bb57e86 /net-misc/openvpn
parentAdd missing dev-util/pkgconfig to DEPEND, stable on x86. See bug #150821. (diff)
downloadgentoo-2-6a19dbfbfd83c00b183936165a5ec2aaf45ba7b3.tar.gz
gentoo-2-6a19dbfbfd83c00b183936165a5ec2aaf45ba7b3.tar.bz2
gentoo-2-6a19dbfbfd83c00b183936165a5ec2aaf45ba7b3.zip
Add a patch so we work with both LinuxPAM and OpenPAM correctly.
(Portage version: 2.1.2_pre2-r7)
Diffstat (limited to 'net-misc/openvpn')
-rw-r--r--net-misc/openvpn/ChangeLog7
-rw-r--r--net-misc/openvpn/files/openvpn-2.0.7-pam.patch34
-rw-r--r--net-misc/openvpn/openvpn-2.0.7.ebuild7
-rw-r--r--net-misc/openvpn/openvpn-2.1_beta15.ebuild7
4 files changed, 50 insertions, 5 deletions
diff --git a/net-misc/openvpn/ChangeLog b/net-misc/openvpn/ChangeLog
index a694da6a8a83..7c4630e1d772 100644
--- a/net-misc/openvpn/ChangeLog
+++ b/net-misc/openvpn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openvpn
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.95 2006/10/05 20:56:23 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.96 2006/10/11 12:15:49 uberlord Exp $
+
+ 11 Oct 2006; Roy Marples <uberlord@gentoo.org>
+ +files/openvpn-2.0.7-pam.patch, openvpn-2.0.7.ebuild,
+ openvpn-2.1_beta15.ebuild:
+ Add a patch so we work with both LinuxPAM and OpenPAM correctly.
05 Oct 2006; Markus Rothe <corsair@gentoo.org> openvpn-2.1_beta15.ebuild:
Added ~ppc64
diff --git a/net-misc/openvpn/files/openvpn-2.0.7-pam.patch b/net-misc/openvpn/files/openvpn-2.0.7-pam.patch
new file mode 100644
index 000000000000..34fa3aeb0108
--- /dev/null
+++ b/net-misc/openvpn/files/openvpn-2.0.7-pam.patch
@@ -0,0 +1,34 @@
+We should use pam property - this works on both LinuxPAM and OpenPAM
+
+diff -ur openvpn-2.0.7.orig/plugin/auth-pam/Makefile openvpn-2.0.7/plugin/auth-pam/Makefile
+--- openvpn-2.0.7.orig/plugin/auth-pam/Makefile 2005-11-02 18:02:49 +0000
++++ openvpn-2.0.7/plugin/auth-pam/Makefile 2006-10-11 12:05:55 +0100
+@@ -4,7 +4,7 @@
+
+ # If PAM modules are not linked against libpam.so, set DLOPEN_PAM to 1. This
+ # must be done on SUSE 9.1, at least.
+-DLOPEN_PAM=1
++DLOPEN_PAM=0
+
+ ifeq ($(DLOPEN_PAM),1)
+ LIBPAM=-ldl
+diff -ur openvpn-2.0.7.orig/plugin/auth-pam/pamdl.c openvpn-2.0.7/plugin/auth-pam/pamdl.c
+--- openvpn-2.0.7.orig/plugin/auth-pam/pamdl.c 2005-11-02 18:02:49 +0000
++++ openvpn-2.0.7/plugin/auth-pam/pamdl.c 2006-10-11 12:04:48 +0100
+@@ -10,7 +10,6 @@
+ #include <stdio.h>
+ #include <dlfcn.h>
+ #include <security/pam_appl.h>
+-#include <security/_pam_macros.h>
+
+ #include "pamdl.h"
+
+@@ -74,7 +73,7 @@
+ return real_pam_set_item(pamh, item_type, item);
+ }
+
+-int pam_get_item(const pam_handle_t *pamh, int item_type, const void **item)
++int pam_get_item(pam_handle_t *pamh, int item_type, const void **item)
+ {
+ int (*real_pam_get_item)(const pam_handle_t *, int, const void **);
+ RESOLVE_PAM_FUNCTION(pam_get_item, int,
diff --git a/net-misc/openvpn/openvpn-2.0.7.ebuild b/net-misc/openvpn/openvpn-2.0.7.ebuild
index 9cbc8f7354cd..3548822d1192 100644
--- a/net-misc/openvpn/openvpn-2.0.7.ebuild
+++ b/net-misc/openvpn/openvpn-2.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.7.ebuild,v 1.1 2006/06/29 09:34:46 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.7.ebuild,v 1.2 2006/10/11 12:15:49 uberlord Exp $
inherit eutils gnuconfig multilib
@@ -25,9 +25,12 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack "${A}"
- gnuconfig_update
cd "${S}"
+
epatch "${FILESDIR}/${PN}"-2.0.4-darwin.patch
+ epatch "${FILESDIR}/${P}-pam.patch"
+
+ gnuconfig_update
}
src_compile() {
diff --git a/net-misc/openvpn/openvpn-2.1_beta15.ebuild b/net-misc/openvpn/openvpn-2.1_beta15.ebuild
index 74345b72610b..197501e24e43 100644
--- a/net-misc/openvpn/openvpn-2.1_beta15.ebuild
+++ b/net-misc/openvpn/openvpn-2.1_beta15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_beta15.ebuild,v 1.3 2006/10/05 20:56:23 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_beta15.ebuild,v 1.4 2006/10/11 12:15:49 uberlord Exp $
inherit eutils gnuconfig multilib
@@ -23,9 +23,12 @@ DEPEND=">=dev-libs/lzo-1.07
src_unpack() {
unpack ${A}
- gnuconfig_update
cd "${S}"
+
epatch "${FILESDIR}/${PN}"-2.0.4-darwin.patch
+ epatch "${FILESDIR}/${PN}"-2.0.7-pam.patch
+
+ gnuconfig_update
}
src_compile() {