summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-04-07 02:44:16 +0000
committerMike Gilbert <floppym@gentoo.org>2012-04-07 02:44:16 +0000
commitf6309135f3bb028dde3b557e3f0bffe01eccb3d4 (patch)
treecf48c52ced35d160fe8ea7901a4e3c401c9362c0 /net-misc/openswan
parentAdd missing depend on doxygen if USE=doc (diff)
downloadgentoo-2-f6309135f3bb028dde3b557e3f0bffe01eccb3d4.tar.gz
gentoo-2-f6309135f3bb028dde3b557e3f0bffe01eccb3d4.tar.bz2
gentoo-2-f6309135f3bb028dde3b557e3f0bffe01eccb3d4.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/openswan')
-rw-r--r--net-misc/openswan/ChangeLog8
-rw-r--r--net-misc/openswan/files/openswan-2.6.38-gentoo.patch296
-rw-r--r--net-misc/openswan/openswan-2.6.38.ebuild177
3 files changed, 480 insertions, 1 deletions
diff --git a/net-misc/openswan/ChangeLog b/net-misc/openswan/ChangeLog
index 387a110daeab..74a2ed6a63a2 100644
--- a/net-misc/openswan/ChangeLog
+++ b/net-misc/openswan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/openswan
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/ChangeLog,v 1.82 2012/04/06 22:37:40 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/ChangeLog,v 1.83 2012/04/07 02:44:16 floppym Exp $
+
+*openswan-2.6.38 (07 Apr 2012)
+
+ 07 Apr 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/openswan-2.6.38-gentoo.patch, +openswan-2.6.38.ebuild:
+ Version bump.
06 Apr 2012; Mike Gilbert <floppym@gentoo.org> metadata.xml:
Change maintainer.
diff --git a/net-misc/openswan/files/openswan-2.6.38-gentoo.patch b/net-misc/openswan/files/openswan-2.6.38-gentoo.patch
new file mode 100644
index 000000000000..6149e6dd2558
--- /dev/null
+++ b/net-misc/openswan/files/openswan-2.6.38-gentoo.patch
@@ -0,0 +1,296 @@
+From 40f1f558b5b0ccd9d60e34178fbebf376ed48b5f Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Fri, 6 Apr 2012 21:20:23 -0400
+Subject: [PATCH] Gentoo changes
+
+---
+ Makefile.inc | 2 +-
+ lib/libcrypto/libmd5/Makefile | 2 +-
+ lib/libcrypto/libsha1/Makefile | 2 +-
+ lib/libcrypto/libsha2/Makefile | 2 +-
+ lib/libdns/Makefile | 2 +-
+ lib/libipsecconf/Makefile | 2 +-
+ lib/libisc/Makefile | 2 +-
+ lib/liblwres/Makefile | 2 +-
+ lib/libopenswan/Makefile | 2 +-
+ packaging/makefiles/module.make | 1 -
+ programs/Makefile.program | 8 +-------
+ programs/pluto/Makefile.options | 5 +++--
+ programs/rsasigkey/Makefile | 3 ++-
+ programs/setup/Makefile | 10 ++--------
+ programs/showhostkey/Makefile | 2 +-
+ testing/utils/make-uml.sh | 2 +-
+ 16 files changed, 19 insertions(+), 30 deletions(-)
+
+diff --git a/Makefile.inc b/Makefile.inc
+index c827328..f63e660 100644
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -55,7 +55,7 @@ export SHELL
+ DESTDIR?=
+
+ # "local" part of tree, used in building other pathnames
+-INC_USRLOCAL=/usr/local
++INC_USRLOCAL?=/usr
+
+ # PUBDIR is where the "ipsec" command goes; beware, many things define PATH
+ # settings which are assumed to include it (or at least, to include *some*
+diff --git a/lib/libcrypto/libmd5/Makefile b/lib/libcrypto/libmd5/Makefile
+index 2d6c566..948ba38 100644
+--- a/lib/libcrypto/libmd5/Makefile
++++ b/lib/libcrypto/libmd5/Makefile
+@@ -12,7 +12,7 @@ LIB=libmd5.a
+
+ ifeq ($(USE_LIBNSS),true)
+ CFLAGS+=-DHAVE_LIBNSS
+-CFLAGS+=-I/usr/include/nspr4 -I/usr/include/nss3
++CFLAGS+=-I/usr/include/nspr -I/usr/include/nss
+ endif
+
+ include ${srcdir}../../Makefile.library
+diff --git a/lib/libcrypto/libsha1/Makefile b/lib/libcrypto/libsha1/Makefile
+index a2c006c..1f7bc3e 100644
+--- a/lib/libcrypto/libsha1/Makefile
++++ b/lib/libcrypto/libsha1/Makefile
+@@ -12,7 +12,7 @@ LIB=libsha1.a
+
+ ifeq ($(USE_LIBNSS),true)
+ CFLAGS+=-DHAVE_LIBNSS
+-CFLAGS+=-I/usr/include/nspr4 -I/usr/include/nss3
++CFLAGS+=-I/usr/include/nspr -I/usr/include/nss
+ endif
+
+
+diff --git a/lib/libcrypto/libsha2/Makefile b/lib/libcrypto/libsha2/Makefile
+index 7db2862..7f1517f 100644
+--- a/lib/libcrypto/libsha2/Makefile
++++ b/lib/libcrypto/libsha2/Makefile
+@@ -15,5 +15,5 @@ include ${srcdir}../../Makefile.library
+
+ ifeq ($(USE_LIBNSS),true)
+ CFLAGS+=-DHAVE_LIBNSS
+-INCLUDES+=-I/usr/include/nspr4 -I/usr/include/nss3
++INCLUDES+=-I/usr/include/nspr -I/usr/include/nss
+ endif
+diff --git a/lib/libdns/Makefile b/lib/libdns/Makefile
+index 9b1993f..be3f896 100644
+--- a/lib/libdns/Makefile
++++ b/lib/libdns/Makefile
+@@ -31,7 +31,7 @@ CINCLUDES = -I${srcdir}${ISCARCH}/include \
+ -I. -I./include -I${srcdir}include \
+ -I${srcdir}../libisc/include
+ CDEFINES = ${USERCOMPILE} ${PORTINCLUDE}
+-CWARNINGS = -Werror
++CWARNINGS =
+
+ CFLAGS+=${CINCLUDES} ${CDEFINES} ${CWARNINGS}
+
+diff --git a/lib/libipsecconf/Makefile b/lib/libipsecconf/Makefile
+index 02422fb..b4ccc10 100644
+--- a/lib/libipsecconf/Makefile
++++ b/lib/libipsecconf/Makefile
+@@ -33,7 +33,7 @@ SRCS+=interfaces.c
+ #CFLAGS+=-DFIPS_CHECK
+ ifeq ($(USE_LIBNSS),true)
+ CFLAGS+=-DHAVE_LIBNSS
+-CFLAGS+=-I/usr/include/nspr4 -I/usr/include/nss3
++CFLAGS+=-I/usr/include/nspr -I/usr/include/nss
+ endif
+
+ ifeq ($(USE_NM),true)
+diff --git a/lib/libisc/Makefile b/lib/libisc/Makefile
+index 777b4b2..dcb082a 100644
+--- a/lib/libisc/Makefile
++++ b/lib/libisc/Makefile
+@@ -23,7 +23,7 @@ CINCLUDES = -I${srcdir}${ISCARCH}/include \
+ -I. -I./include -I${srcdir}include \
+ $(PORTINCLUDE) -I${OPENSWANSRCDIR}/include
+ CDEFINES = -DHAVE_STRERROR ${USERCOMPILE} ${PORTINCLUDE}
+-# CWARNINGS = -Werror
++CWARNINGS =
+
+ CFLAGS+=${CINCLUDES} ${CDEFINES} ${CWARNINGS}
+
+diff --git a/lib/liblwres/Makefile b/lib/liblwres/Makefile
+index 4b045cc..c6d18a4 100644
+--- a/lib/liblwres/Makefile
++++ b/lib/liblwres/Makefile
+@@ -23,7 +23,7 @@ CINCLUDES = -I${srcdir}${ISCARCH}/include \
+ -I${srcdir}../libisc/include \
+ -I. -I./include -I${srcdir}include
+ CDEFINES =
+-CWARNINGS = -Werror
++CWARNINGS =
+
+ CFLAGS+=${USERCOMPILE} ${PORTINCLUDE} ${CINCLUDES} ${CDEFINES} ${CWARNINGS}
+
+diff --git a/lib/libopenswan/Makefile b/lib/libopenswan/Makefile
+index 1661522..033ef86 100644
+--- a/lib/libopenswan/Makefile
++++ b/lib/libopenswan/Makefile
+@@ -103,7 +103,7 @@ endif
+
+ ifeq ($(USE_LIBNSS),true)
+ CFLAGS+=-DHAVE_LIBNSS
+-CFLAGS+=-I/usr/include/nspr4 -I/usr/include/nss3
++CFLAGS+=-I/usr/include/nspr -I/usr/include/nss
+ endif
+
+ ifeq ($(USE_MODP_RFC5114),true)
+diff --git a/packaging/makefiles/module.make b/packaging/makefiles/module.make
+index 74a9f09..6f21471 100644
+--- a/packaging/makefiles/module.make
++++ b/packaging/makefiles/module.make
+@@ -25,7 +25,6 @@ EXTRA_CFLAGS += -DDISABLE_UDP_CHECKSUM
+
+ EXTRA_CFLAGS += $(KLIPSCOMPILE)
+ EXTRA_CFLAGS += -Wall -DIPCOMP_PREFIX
+-#EXTRA_CFLAGS += -Werror
+ #EXTRA_CFLAGS += -Wconversion
+ #EXTRA_CFLAGS += -Wmissing-prototypes
+ # 'override CFLAGS' should really be 'EXTRA_CFLAGS'
+diff --git a/programs/Makefile.program b/programs/Makefile.program
+index 342f6c4..276777f 100644
+--- a/programs/Makefile.program
++++ b/programs/Makefile.program
+@@ -48,12 +48,7 @@ CFLAGS+=-DFINALCONFDDIR=\"${FINALCONFDDIR}\"
+ CFLAGS+=-DFINALCONFFILE=\"${FINALCONFFILE}\"
+ CFLAGS+=-DFINALVARDIR=\"${FINALVARDIR}\"
+
+-# die if there are any warnings
+-ifndef WERROR
+-WERROR:= -Werror
+-endif
+
+-CFLAGS+= ${WERROR}
+
+ ifneq ($(LD_LIBRARY_PATH),)
+ LDFLAGS=-L$(LD_LIBRARY_PATH)
+@@ -104,8 +99,6 @@ endif
+ ifneq ($(NOINSTALL),true)
+
+ doinstall:: $(PROGRAM) $(CONFFILES) $(EXTRA8MAN) $(EXTRA5MAN) $(EXTRA5PROC) $(LIBFILES) $(CONFDFILES)
+- # remove any old vendor file installed previously
+- @rm -f $(FINALLIBEXECDIR)/vendor
+ @mkdir -p $(PROGRAMDIR) $(MANDIR8) $(MANDIR5) $(LIBDIR) $(CONFDIR) $(CONFDDIR) $(CONFDDIR)/$(CONFDSUBDIR) $(EXAMPLECONFDIR)
+ @if [ -n "$(PROGRAM)" ]; then $(INSTALL) $(INSTBINFLAGS) $(PROGRAM) $(PROGRAMDIR); fi
+ @$(foreach f, $(addsuffix .8, $(PROGRAM)), \
+@@ -180,6 +173,7 @@ ifeq ($(USE_LIBNSS),false)
+ LDLIBS=${LIBS} ${USERLINK} ${LIBS} ${EXTRALIBS} -lgmp
+ else
+ LDLIBS=${LIBS} ${USERLINK} ${LIBS} ${EXTRALIBS} -lgmp -lnspr4 -lnss3
++LDFLAGS+=-L/usr/lib/nspr -L/usr/lib/nss
+ endif
+
+
+diff --git a/programs/pluto/Makefile.options b/programs/pluto/Makefile.options
+index bf09b32..a7bcd12 100644
+--- a/programs/pluto/Makefile.options
++++ b/programs/pluto/Makefile.options
+@@ -44,7 +44,7 @@ endif
+
+ # -O on Linux makes gcc coredump when compiling sha1.c
+ # -Wundef is nice but RHL5.2 compiler doesn't support it
+-CFLAGS +=-g -Wall -W -Wmissing-prototypes -Wpointer-arith -Wbad-function-cast \
++CFLAGS +=-Wall -W -Wmissing-prototypes -Wpointer-arith -Wbad-function-cast \
+ -Wcast-qual -Wmissing-declarations -Wwrite-strings \
+ -Wstrict-prototypes # -Wundef
+
+@@ -58,7 +58,7 @@ HDRDIRS = -I${OPENSWANSRCDIR}/programs/pluto/linux26 -I${OPENSWANSRCDIR}/include
+
+ # Use LIBNSS
+ ifeq ($(USE_LIBNSS),true)
+-HDRDIRS+= -I/usr/include/nspr4 -I/usr/include/nss3
++HDRDIRS+= -I/usr/include/nspr -I/usr/include/nss
+ endif
+
+ # BYTE_ORDER = -DBIG_ENDIAN=4321 -DLITTLE_ENDIAN=1234 -DBYTE_ORDER=BIG_ENDIAN
+@@ -318,6 +318,7 @@ HAVE_LIBNSS=1
+ DEFINES+=-DHAVE_LIBNSS
+ LIBSPLUTO+= -lnspr4
+ LIBSPLUTO+= -lnss3
++LDFLAGS+=-L/usr/lib/nspr -L/usr/lib/nss
+ # For avoiding implicit DSO linking
+ LIBSPLUTO+= -lpthread
+ ifeq ($(USE_FIPSCHECK),true)
+diff --git a/programs/rsasigkey/Makefile b/programs/rsasigkey/Makefile
+index 6c87280..ac117d5 100644
+--- a/programs/rsasigkey/Makefile
++++ b/programs/rsasigkey/Makefile
+@@ -21,13 +21,14 @@ ifeq ($(USE_FIPSCHECK),true)
+ FIPS_CHECK=1
+ CFLAGS+=-DFIPS_CHECK
+ endif
+-INCLUDES+=-I/usr/include/nspr4 -I/usr/include/nss3
++INCLUDES+=-I/usr/include/nspr -I/usr/include/nss
+ endif
+
+ PROGRAM=rsasigkey
+ LIBS=${OPENSWANLIB} -lgmp
+ ifeq ($(USE_LIBNSS),true)
+ LIBS+= -lnspr4 -lnss3 -lplc4
++LDFLAGS+=-L/usr/lib/nspr -L/usr/lib/nss
+ ifeq ($(USE_FIPSCHECK),true)
+ LIBS+= -lfipscheck
+ endif
+diff --git a/programs/setup/Makefile b/programs/setup/Makefile
+index 7ac3dbe..ce0ba07 100644
+--- a/programs/setup/Makefile
++++ b/programs/setup/Makefile
+@@ -14,11 +14,7 @@
+ OPENSWANSRCDIR?=$(shell cd ../..; pwd)
+ include ${OPENSWANSRCDIR}/Makefile.inc
+
+-# this dance is because setup has to get installed as /etc/rc.d/init.d/ipsec
+-# not as /etc/rc.d/init.d/setup.
+-PROGRAMDIR=$(RCDIR)
+ PROGRAM=setup
+-NOINSTALL=true
+ EXTRA8MAN=setup.8
+
+ include ${srcdir}../Makefile.program
+@@ -32,13 +28,11 @@ doinstall:: $(PROGRAM) $(CONFFILES) $(EXTRA8MAN) $(EXTRA5MAN) $(EXTRA5PROC) $(LI
+ # remove any old vendor file installed previously
+ @rm -f $(BINDIR)/setup
+ # check the directories we need exist (ie., make install DESTDIR=/tmp/IPsec)
+- @mkdir -p $(RCDIR) $(BINDIR)
++ @mkdir -p $(BINDIR)
+ # install and link everything
+- @$(INSTALL) $(INSTBINFLAGS) setup $(RCDIR)/ipsec
+- @ln -s $(FINALRCDIR)/ipsec $(BINDIR)/setup
++ @$(INSTALL) $(INSTBINFLAGS) setup $(BINDIR)/setup
+
+ install_file_list::
+- @echo $(RCDIR)/ipsec
+ @echo $(BINDIR)/setup
+
+ cleanall::
+diff --git a/programs/showhostkey/Makefile b/programs/showhostkey/Makefile
+index 3a127fc..decaf1c 100644
+--- a/programs/showhostkey/Makefile
++++ b/programs/showhostkey/Makefile
+@@ -16,7 +16,7 @@ OPENSWANSRCDIR?=$(shell cd ../..; pwd)
+ include ${OPENSWANSRCDIR}/Makefile.inc
+ ifeq ($(USE_LIBNSS),true)
+ CFLAGS+=-DHAVE_LIBNSS
+-INCLUDES+=-I/usr/include/nspr4 -I/usr/include/nss3
++INCLUDES+=-I/usr/include/nspr -I/usr/include/nss
+ endif
+
+ PROGRAM=showhostkey
+diff --git a/testing/utils/make-uml.sh b/testing/utils/make-uml.sh
+index b8ee039..cb8a232 100755
+--- a/testing/utils/make-uml.sh
++++ b/testing/utils/make-uml.sh
+@@ -264,7 +264,7 @@ fi
+
+ cd $OPENSWANSRCDIR || exit 1
+
+-make ${WERROR:-WERROR=-Werror} USE_OBJDIR=true USE_IPSECPOLICY=true programs
++make ${WERROR:-WERROR=} USE_OBJDIR=true USE_IPSECPOLICY=true programs
+
+ # now, execute the Makefile that we have created!
+ cd $POOLSPACE && make $OPENSWANHOSTS
+--
+1.7.9.4
+
diff --git a/net-misc/openswan/openswan-2.6.38.ebuild b/net-misc/openswan/openswan-2.6.38.ebuild
new file mode 100644
index 000000000000..0ff1ce71ed4c
--- /dev/null
+++ b/net-misc/openswan/openswan-2.6.38.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/openswan-2.6.38.ebuild,v 1.1 2012/04/07 02:44:16 floppym Exp $
+
+EAPI="4"
+
+inherit eutils linux-info toolchain-funcs flag-o-matic
+
+DESCRIPTION="Open Source implementation of IPsec for the Linux operating system (was SuperFreeS/WAN)."
+HOMEPAGE="http://www.openswan.org/"
+SRC_URI="http://download.openswan.org/openswan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="caps curl ldap pam ssl extra-algorithms weak-algorithms nocrypto-algorithms ms-bad-proposal nss"
+
+RESTRICT="test" # requires user mode linux setup
+
+COMMON_DEPEND="!net-misc/strongswan
+ dev-libs/gmp
+ dev-lang/perl
+ caps? ( sys-libs/libcap-ng )
+ curl? ( net-misc/curl )
+ ldap? ( net-nds/openldap )
+ nss? ( dev-libs/nss )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${COMMON_DEPEND}
+ virtual/linux-sources
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2" # see bug 237132
+RDEPEND="${COMMON_DEPEND}
+ || ( sys-apps/net-tools[old-output] <sys-apps/net-tools-1.60_p201111202031570500 )
+ virtual/logger
+ sys-apps/iproute2"
+
+pkg_setup() {
+ if use nocrypto-algorithms && ! use weak-algorithms; then
+ ewarn "Enabling nocrypto-algorithms USE flag has no effect when"
+ ewarn "weak-algorithms USE flag is disabled"
+ fi
+
+ linux-info_pkg_setup
+
+ if kernel_is -ge 2 6; then
+ einfo "This ebuild will set ${P} to use kernel native IPsec (KAME)."
+ MYMAKE="programs"
+
+ elif kernel_is 2 4; then
+ if ! [[ -d "${KERNEL_DIR}/net/ipsec" ]]; then
+ eerror "You need to have an IPsec enabled 2.4.x kernel."
+ eerror "Ensure you have one running and make a symlink to it in /usr/src/linux"
+ die
+ fi
+
+ einfo "Using patched-in IPsec code for kernel 2.4"
+ einfo "Your kernel only supports KLIPS for kernel level IPsec."
+ MYMAKE="confcheck programs"
+
+ else
+ die "Unsupported kernel version"
+ fi
+
+ # most code is OK, but programs/pluto code breaks strict aliasing
+ append-cflags -fno-strict-aliasing
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ use ms-bad-proposal && epatch "${FILESDIR}"/${PN}-${PV%.*}-allow-ms-bad-proposal.patch
+
+ find . -type f -regex '.*[.]\([1-8]\|html\|xml\)' -exec sed -i \
+ -e s:/usr/local:/usr:g '{}' \; ||
+ die "failed to replace text in docs"
+}
+
+usetf() { usex $1 true false ; }
+get_make_options() {
+ make_options=(
+ KERNELSRC="${KERNEL_DIR}"
+ FINALEXAMPLECONFDIR=/usr/share/doc/${PF}
+ INC_RCDEFAULT=/etc/init.d
+ INC_USRLOCAL=/usr
+ INC_MANDIR=share/man
+ FINALDOCDIR=/usr/share/doc/${PF}/html
+ FINALLIBDIR=/usr/$(get_libdir)/ipsec
+ DESTDIR="${D}"
+ USERCOMPILE="${CFLAGS}"
+ USERLINK="-Wl,-z,relro ${LDFLAGS}"
+ CC="$(tc-getCC)"
+ USE_LIBCAP_NG=$(usetf caps)
+ USE_LIBCURL=$(usetf curl)
+ USE_LDAP=$(usetf ldap)
+ USE_XAUTH=true
+ USE_XAUTHPAM=$(usetf pam)
+ USE_LIBNSS=$(usetf nss)
+ HAVE_OPENSSL=$(usetf ssl)
+ USE_EXTRACRYPTO=$(usetf extra-algorithms)
+ USE_WEAKSTUFF=$(usetf weak-algorithms)
+ )
+
+ if use weak-algorithms && use nocrypto-algorithms ; then
+ make_options+=( USE_NOCRYPTO=true )
+ fi
+
+ make_options+=( USE_LWRES=false ) # needs bind9 with lwres support
+ if use curl || use ldap || use pam; then
+ make_options+=( HAVE_THREADS=true )
+ else
+ make_options+=( HAVE_THREADS=false )
+ fi
+}
+
+src_compile() {
+ local make_options; get_make_options
+ emake "${make_options[@]}" ${MYMAKE}
+}
+
+src_install() {
+ local make_options; get_make_options
+ emake "${make_options[@]}" install
+
+ dodoc CHANGES README
+ dodoc docs/{KNOWN_BUGS*,RELEASE-NOTES*,PATENTS*,debugging*}
+ docinto quickstarts
+ dodoc docs/quickstarts/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+
+ newinitd "${FILESDIR}"/ipsec-initd ipsec
+
+ keepdir /var/run/pluto
+}
+
+pkg_preinst() {
+ if has_version "<net-misc/openswan-2.6.14" && pushd "${ROOT}etc/ipsec"; then
+ ewarn "Following files and directories were moved from '${ROOT}etc/ipsec' to '${ROOT}etc':"
+ local i err=0
+ if [ -h "../ipsec.d" ]; then
+ rm "../ipsec.d" || die "failed to remove ../ipsec.d symlink"
+ fi
+ for i in *; do
+ if [ -e "../$i" ]; then
+ eerror " $i NOT MOVED, ../$i already exists!"
+ err=1
+ elif [ -d "$i" ]; then
+ mv "$i" .. || die "failed to move $i directory"
+ ewarn " directory $i"
+ elif [ -f "$i" ]; then
+ sed -i -e 's:/etc/ipsec/:/etc/:g' "$i" && \
+ mv "$i" .. && ewarn " file $i" || \
+ die "failed to move $i file"
+ else
+ eerror " $i NOT MOVED, it is not a file nor a directory!"
+ err=1
+ fi
+ done
+ popd
+ if [ $err -eq 0 ]; then
+ rmdir "${ROOT}etc/ipsec" || eerror "Failed to remove ${ROOT}etc/ipsec"
+ else
+ ewarn "${ROOT}etc/ipsec is not empty, you will have to remove it yourself"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if kernel_is -ge 2 6; then
+ CONFIG_CHECK="~NET_KEY ~INET_XFRM_MODE_TRANSPORT ~INET_XFRM_MODE_TUNNEL ~INET_AH ~INET_ESP ~INET_IPCOMP"
+ WARNING_INET_AH="CONFIG_INET_AH:\tmissing IPsec AH support (needed if you want only authentication)"
+ WARNING_INET_ESP="CONFIG_INET_ESP:\tmissing IPsec ESP support (needed if you want authentication and encryption)"
+ WARNING_INET_IPCOMP="CONFIG_INET_IPCOMP:\tmissing IPsec Payload Compression (required for compress=yes)"
+ check_extra_config
+ fi
+}