summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-13 10:32:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-13 10:32:51 +0000
commit46d8420e3f0d0f4f554764599309b2913f323b16 (patch)
tree6b27ac1c7271879a2e1178069f6222682e39d6b5 /net-misc/openssh
parentRevision bump; updated list of files ignored in /etc/cron.d (diff)
downloadgentoo-2-46d8420e3f0d0f4f554764599309b2913f323b16.tar.gz
gentoo-2-46d8420e3f0d0f4f554764599309b2913f323b16.tar.bz2
gentoo-2-46d8420e3f0d0f4f554764599309b2913f323b16.zip
Fix USE=-opensc logic with patch by Stian Skjelstad #78730.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog6
-rw-r--r--net-misc/openssh/files/openssh-3.9_p1-configure-openct.patch34
-rw-r--r--net-misc/openssh/openssh-3.9_p1-r1.ebuild32
3 files changed, 53 insertions, 19 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index bae44288c1ae..fb83b113ea3c 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openssh
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.113 2005/02/20 01:33:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.114 2005/03/13 10:32:51 vapier Exp $
+
+ 13 Mar 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/openssh-3.9_p1-configure-openct.patch, openssh-3.9_p1-r1.ebuild:
+ Fix USE=-opensc logic with patch by Stian Skjelstad #78730.
19 Feb 2005; Mike Frysinger <vapier@gentoo.org>
files/openssh-3.9_p1-largekey.patch.bz2:
diff --git a/net-misc/openssh/files/openssh-3.9_p1-configure-openct.patch b/net-misc/openssh/files/openssh-3.9_p1-configure-openct.patch
new file mode 100644
index 000000000000..f6a3bab23cc1
--- /dev/null
+++ b/net-misc/openssh/files/openssh-3.9_p1-configure-openct.patch
@@ -0,0 +1,34 @@
+The --without-opensc logic is broken, so let's fix it.
+
+patch by Stian Skjelstad.
+
+http://bugs.gentoo.org/show_bug.cgi?id=78730
+
+--- openssh-3.9p1/configure.ac
++++ openssh-3.9p1/configure.ac
+@@ -2171,9 +2171,9 @@
+ AC_ARG_WITH(opensc,
+ AC_HELP_STRING([--with-opensc=PFX],
+ [Enable smartcard support using OpenSC]),
+- opensc_config_prefix="$withval", opensc_config_prefix="")
+-if test x$opensc_config_prefix != x ; then
+- OPENSC_CONFIG=$opensc_config_prefix/bin/opensc-config
++ [
++if test "x$withval" != xno ; then
++ OPENSC_CONFIG="$withval/bin/opensc-config"
+ AC_PATH_PROG(OPENSC_CONFIG, opensc-config, no)
+ if test "$OPENSC_CONFIG" != "no"; then
+ LIBOPENSC_CFLAGS=`$OPENSC_CONFIG --cflags`
+@@ -2183,8 +2183,12 @@
+ AC_DEFINE(SMARTCARD)
+ AC_DEFINE(USE_OPENSC)
+ SCARD_MSG="yes, using OpenSC"
++ else
++ AC_MSG_ERROR([opensc-config not found])
+ fi
+ fi
++ ]
++)
+
+ # Check libraries needed by DNS fingerprint support
+ AC_SEARCH_LIBS(getrrsetbyname, resolv,
diff --git a/net-misc/openssh/openssh-3.9_p1-r1.ebuild b/net-misc/openssh/openssh-3.9_p1-r1.ebuild
index ec46378a9eab..9832157529a6 100644
--- a/net-misc/openssh/openssh-3.9_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-3.9_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.9_p1-r1.ebuild,v 1.12 2005/03/13 10:18:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.9_p1-r1.ebuild,v 1.13 2005/03/13 10:32:51 vapier Exp $
inherit eutils flag-o-matic ccc gnuconfig
@@ -24,9 +24,9 @@ KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE="ipv6 static pam tcpd kerberos skey selinux chroot X509 ldap smartcard nocxx sftplogging"
RDEPEND="pam? ( >=sys-libs/pam-0.73 >=sys-apps/shadow-4.0.2-r2 )
- !mips? ( kerberos? ( virtual/krb5 ) )
+ kerberos? ( virtual/krb5 )
selinux? ( sys-libs/libselinux )
- !ppc64? ( skey? ( >=app-admin/skey-1.1.5-r1 ) )
+ skey? ( >=app-admin/skey-1.1.5-r1 )
>=dev-libs/openssl-0.9.6d
>=sys-libs/zlib-1.1.4
smartcard? ( dev-libs/opensc )
@@ -46,6 +46,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-fix_suid.patch.bz2
epatch ${FILESDIR}/${P}-infoleak.patch #59361
epatch ${FILESDIR}/${P}-terminal_restore.patch.bz2
+ epatch ${FILESDIR}/${P}-configure-openct.patch #78730
use sftplogging && epatch ${FILESDIR}/${P}-sftplogging-1.2-gentoo.patch.bz2
use alpha && epatch ${FILESDIR}/${PN}-3.5_p1-gentoo-sshd-gcc3.patch.bz2
@@ -69,17 +70,12 @@ src_compile() {
use ldap && filter-flags -funroll-loops
use selinux && append-flags "-DWITH_SELINUX"
- if use static; then
+ if use static ; then
append-ldflags -static
- export LDFLAGS
- if use pam; then
- ewarn "Disabling pam support becuse of static flag."
- myconf="${myconf} --without-pam"
- else
- myconf="${myconf} --without-pam"
- fi
+ use pam && ewarn "Disabling pam support becuse of static flag"
+ myconf="${myconf} --without-pam"
else
- myconf="${myconf} `use_with pam`"
+ myconf="${myconf} $(use_with pam)"
fi
use ipv6 || myconf="${myconf} --with-ipv4-default"
@@ -103,11 +99,11 @@ src_compile() {
}
src_install() {
- make install-files DESTDIR=${D} || die
- chmod 600 ${D}/etc/ssh/sshd_config
+ make install-files DESTDIR="${D}" || die
+ fperms 600 /etc/ssh/sshd_config
dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
- use pam && ( insinto /etc/pam.d ; newins ${FILESDIR}/sshd.pam sshd )
- exeinto /etc/init.d ; newexe ${FILESDIR}/sshd.rc6 sshd
+ newpamd "${FILESDIR}"/sshd.pam sshd
+ newinitd "${FILESDIR}"/sshd.rc6 sshd
keepdir /var/empty
dosed "/^#Protocol /s:.*:Protocol 2:" /etc/ssh/sshd_config
use pam \
@@ -130,9 +126,9 @@ pkg_postinst() {
einfo "new one with UID 22. If you have any scripts or programs that"
einfo "that referenced the old UID directly, you will need to update them."
einfo
- use pam >/dev/null 2>&1 && {
+ if use pam ; then
einfo "Please be aware users need a valid shell in /etc/passwd"
einfo "in order to be allowed to login."
einfo
- }
+ fi
}