summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-06 01:42:41 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-06 01:42:41 +0000
commit2ae43718d52468749584860851b2cd7f0f904407 (patch)
treee670af0fe65c54acc61d20ab656a8ff94a3d90d8 /net-misc/openssh
parentsync some fixes from upstream sftplogging (diff)
downloadgentoo-2-2ae43718d52468749584860851b2cd7f0f904407.tar.gz
gentoo-2-2ae43718d52468749584860851b2cd7f0f904407.tar.bz2
gentoo-2-2ae43718d52468749584860851b2cd7f0f904407.zip
Version bump #104948 by Saurabh Singhvi.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog10
-rw-r--r--net-misc/openssh/files/digest-openssh-4.2_p15
-rw-r--r--net-misc/openssh/files/openssh-4.2_p1-kerberos-detection.patch18
-rw-r--r--net-misc/openssh/files/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2bin0 -> 5673 bytes
-rw-r--r--net-misc/openssh/openssh-4.2_p1.ebuild162
5 files changed, 194 insertions, 1 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 88902255767c..23ce4a9a6b76 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.128 2005/09/05 22:09:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.129 2005/09/06 01:42:41 vapier Exp $
+
+*openssh-4.2_p1 (06 Sep 2005)
+
+ 06 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/openssh-4.2_p1-kerberos-detection.patch,
+ +files/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2,
+ +openssh-4.2_p1.ebuild:
+ Version bump #104948 by Saurabh Singhvi.
05 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+files/openssh-3.9_p1-fix_suid.patch,
diff --git a/net-misc/openssh/files/digest-openssh-4.2_p1 b/net-misc/openssh/files/digest-openssh-4.2_p1
new file mode 100644
index 000000000000..9681b0530497
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-4.2_p1
@@ -0,0 +1,5 @@
+MD5 df899194a340c933944b193477c628fa openssh-4.2p1.tar.gz 914165
+MD5 b779906d657d63794144cabe2bf978b8 openssh-lpk-4.1p1-0.3.6.patch 60312
+MD5 cda9a91dc66ff20be49ba379be9089fd openssh-4.2p1+x509-5.2.diff.gz 123592
+MD5 7a9abefaf7078da86ac2e70bf154127f openssh-4.1p1-hpn11.diff 14223
+MD5 7c5798757b7efc79a897f92de5f80539 openssh-4.1p1+SecurID_v1.3.1.patch 612445
diff --git a/net-misc/openssh/files/openssh-4.2_p1-kerberos-detection.patch b/net-misc/openssh/files/openssh-4.2_p1-kerberos-detection.patch
new file mode 100644
index 000000000000..fdfd5113dff7
--- /dev/null
+++ b/net-misc/openssh/files/openssh-4.2_p1-kerberos-detection.patch
@@ -0,0 +1,18 @@
+--- configure.ac
++++ configure.ac
+@@ -2757,7 +2757,6 @@
+ if test ! -z "$blibpath" ; then
+ blibpath="$blibpath:${KRB5ROOT}/lib"
+ fi
+- fi
+
+ AC_CHECK_HEADERS(gssapi.h gssapi/gssapi.h)
+ AC_CHECK_HEADERS(gssapi_krb5.h gssapi/gssapi_krb5.h)
+@@ -2765,6 +2764,7 @@
+
+ LIBS="$LIBS $K5LIBS"
+ AC_SEARCH_LIBS(k_hasafs, kafs, AC_DEFINE(USE_AFS))
++ fi
+ ]
+ )
+
diff --git a/net-misc/openssh/files/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2 b/net-misc/openssh/files/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2
new file mode 100644
index 000000000000..bd24d0b19c5b
--- /dev/null
+++ b/net-misc/openssh/files/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2
Binary files differ
diff --git a/net-misc/openssh/openssh-4.2_p1.ebuild b/net-misc/openssh/openssh-4.2_p1.ebuild
new file mode 100644
index 000000000000..555302319776
--- /dev/null
+++ b/net-misc/openssh/openssh-4.2_p1.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.2_p1.ebuild,v 1.1 2005/09/06 01:42:41 vapier Exp $
+
+inherit eutils flag-o-matic ccc pam
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+
+SFTPLOG_PATCH_VER="1.2"
+X509_PATCH="${PARCH}+x509-5.2.diff.gz"
+SELINUX_PATCH="openssh-3.9_p1-selinux.diff"
+SECURID_PATCH="" #${PARCH}+SecurID_v1.3.1.patch"
+LDAP_PATCH="${PARCH/-4.2/-lpk-4.1}-0.3.6.patch"
+HPN_PATCH="" #${PARCH/4.2/4.1}-hpn11.diff"
+
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="http://www.openssh.com/"
+SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
+ ldap? ( http://www.opendarwin.org/en/projects/openssh-lpk/files/${LDAP_PATCH} )
+ X509? ( http://roumenpetrov.info/openssh/x509-5.2/${X509_PATCH} )"
+# hpn? ( http://www.psc.edu/networking/projects/hpn-ssh/${HPN_PATCH} )"
+# smartcard? ( http://www.omniti.com/~jesus/projects/${SECURID_PATCH} )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 static pam tcpd kerberos skey selinux chroot X509 ldap smartcard sftplogging hpn libedit"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( sys-libs/libselinux )
+ skey? ( >=app-admin/skey-1.1.5-r1 )
+ ldap? ( net-nds/openldap )
+ libedit? ( dev-libs/libedit )
+ >=dev-libs/openssl-0.9.6d
+ >=sys-libs/zlib-1.1.4
+ smartcard? ( dev-libs/opensc )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ sys-devel/autoconf"
+PROVIDE="virtual/ssh"
+
+S=${WORKDIR}/${PARCH}
+
+src_unpack() {
+ unpack ${PARCH}.tar.gz
+ cd "${S}"
+
+ #epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
+ epatch "${FILESDIR}"/openssh-4.2_p1-kerberos-detection.patch #80811
+
+ use X509 && epatch ${DISTDIR}/${X509_PATCH}
+ use sftplogging && epatch ${FILESDIR}/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2
+ use skey && epatch ${FILESDIR}/openssh-3.9_p1-skey.patch.bz2
+ use chroot && epatch ${FILESDIR}/openssh-3.9_p1-chroot.patch
+ use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
+ use smartcard && epatch ${FILESDIR}/openssh-3.9_p1-opensc.patch.bz2
+ if ! use X509 ; then
+ if [[ -n ${SECURID_PATCH} ]] && use smartcard ; then
+ epatch ${DISTDIR}/${SECURID_PATCH} ${FILESDIR}/openssh-securid-1.3.1-updates.patch
+ use ldap && epatch ${FILESDIR}/openssh-4.0_p1-smartcard-ldap-happy.patch
+ fi
+ if use sftplogging ; then
+ ewarn "Sorry, sftplogging and ldap don't get along"
+ else
+ use ldap && epatch ${DISTDIR}/${LDAP_PATCH}
+ fi
+ elif [[ -n ${SECURID_PATCH} ]] && use smartcard || use ldap ; then
+ ewarn "Sorry, x509 and smartcard/ldap don't get along"
+ fi
+ [[ -n ${HPN_PATCH} ]] && use hpn && epatch ${DISTDIR}/${HPN_PATCH}
+
+ sed -i '/LD.*ssh-keysign/s:$: -Wl,-z,now:' Makefile.in || die "setuid"
+
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ addwrite /dev/ptmx
+
+ # make sure .sbss is large enough
+ use skey && use alpha && append-ldflags -mlarge-data
+ if use ldap ; then
+ filter-flags -funroll-loops
+ myconf="${myconf} --with-ldap"
+ fi
+ use selinux && append-flags "-DWITH_SELINUX"
+
+ if use static ; then
+ append-ldflags -static
+ use pam && ewarn "Disabling pam support becuse of static flag"
+ myconf="${myconf} --without-pam"
+ else
+ myconf="${myconf} $(use_with pam)"
+ fi
+
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ econf \
+ --with-ldflags="${LDFLAGS}" \
+ --disable-strip \
+ --sysconfdir=/etc/ssh \
+ --libexecdir=/usr/$(get_libdir)/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ $(use_with libedit) \
+ $(use_with kerberos kerberos5 /usr) \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_with skey) \
+ $(use_with smartcard opensc) \
+ ${myconf} \
+ || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install-nokeys DESTDIR="${D}" || die
+ fperms 600 /etc/ssh/sshd_config
+ dobin contrib/ssh-copy-id
+ newinitd "${FILESDIR}"/sshd.rc6 sshd
+ keepdir /var/empty
+
+ newpamd "${FILESDIR}"/sshd.pam_include sshd
+ dosed "/^#Protocol /s:.*:Protocol 2:" /etc/ssh/sshd_config
+ use pam \
+ && dosed "/^#UsePAM /s:.*:UsePAM yes:" /etc/ssh/sshd_config \
+ && dosed "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" /etc/ssh/sshd_config
+
+ doman contrib/ssh-copy-id.1
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+}
+
+pkg_postinst() {
+ enewgroup sshd 22
+ enewuser sshd 22 -1 /var/empty sshd
+
+ ewarn "Remember to merge your config files in /etc/ssh/ and then"
+ ewarn "restart sshd: '/etc/init.d/sshd restart'."
+ ewarn
+ einfo "As of version 3.4 the default is to enable the UsePrivelegeSeparation"
+ einfo "functionality, but please ensure that you do not explicitly disable"
+ einfo "this in your configuration as disabling it opens security holes"
+ einfo
+ einfo "This revision has removed your sshd user id and replaced it with a"
+ einfo "new one with UID 22. If you have any scripts or programs that"
+ einfo "that referenced the old UID directly, you will need to update them."
+ einfo
+ if use pam ; then
+ einfo "Please be aware users need a valid shell in /etc/passwd"
+ einfo "in order to be allowed to login."
+ einfo
+ fi
+}