summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-05 22:14:25 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-05 22:14:25 +0000
commitbe0cc8b56c9f8c5fdff95fd7c8fa4c78b833cb09 (patch)
treef46bd676d8d43d8728080708653bd05179bed82d /net-misc/openntpd
parentfix incompatibility introduced in file 5.05 (diff)
downloadgentoo-2-be0cc8b56c9f8c5fdff95fd7c8fa4c78b833cb09.tar.gz
gentoo-2-be0cc8b56c9f8c5fdff95fd7c8fa4c78b833cb09.tar.bz2
gentoo-2-be0cc8b56c9f8c5fdff95fd7c8fa4c78b833cb09.zip
Add Debian patchset which includes a bunch of patches (fixes #296612 and #297360). Tweak init.d script to make startup more solid #336995.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/openntpd')
-rw-r--r--net-misc/openntpd/ChangeLog11
-rw-r--r--net-misc/openntpd/files/openntpd.rc-3.9_p1-r28
-rw-r--r--net-misc/openntpd/openntpd-3.9_p1-r3.ebuild59
3 files changed, 73 insertions, 5 deletions
diff --git a/net-misc/openntpd/ChangeLog b/net-misc/openntpd/ChangeLog
index ed6b19983bdf..8e7558ee9c4a 100644
--- a/net-misc/openntpd/ChangeLog
+++ b/net-misc/openntpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openntpd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/ChangeLog,v 1.44 2010/01/11 00:21:22 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/ChangeLog,v 1.45 2011/03/05 22:14:25 vapier Exp $
+
+*openntpd-3.9_p1-r3 (05 Mar 2011)
+
+ 05 Mar 2011; Mike Frysinger <vapier@gentoo.org>
+ files/openntpd.rc-3.9_p1-r2, +openntpd-3.9_p1-r3.ebuild:
+ Add Debian patchset which includes a bunch of patches (fixes #296612 and
+ #297360). Tweak init.d script to make startup more solid #336995.
11 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
openntpd-3.9_p1-r2.ebuild:
diff --git a/net-misc/openntpd/files/openntpd.rc-3.9_p1-r2 b/net-misc/openntpd/files/openntpd.rc-3.9_p1-r2
index 992944aabce5..7d97d3e67200 100644
--- a/net-misc/openntpd/files/openntpd.rc-3.9_p1-r2
+++ b/net-misc/openntpd/files/openntpd.rc-3.9_p1-r2
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/files/openntpd.rc-3.9_p1-r2,v 1.2 2009/10/14 13:39:15 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/files/openntpd.rc-3.9_p1-r2,v 1.3 2011/03/05 22:14:25 vapier Exp $
depend() {
need net
@@ -23,13 +23,15 @@ checkconfig() {
fi
fi
+ checkpath -d -o 0:0 /var/lib/openntpd/chroot
+
return 0
}
start() {
checkconfig || return $?
- #prepare chroot
+ # prepare chroot
mkdir -p "${NTPD_HOME}/etc"
cp /etc/localtime "${NTPD_HOME}/etc"
diff --git a/net-misc/openntpd/openntpd-3.9_p1-r3.ebuild b/net-misc/openntpd/openntpd-3.9_p1-r3.ebuild
new file mode 100644
index 000000000000..152e74bcab55
--- /dev/null
+++ b/net-misc/openntpd/openntpd-3.9_p1-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/openntpd-3.9_p1-r3.ebuild,v 1.1 2011/03/05 22:14:25 vapier Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+MY_P=${P/_/}
+DEB_VER="8"
+DESCRIPTION="Lightweight NTP server ported from OpenBSD"
+HOMEPAGE="http://www.openntpd.org/"
+SRC_URI="mirror://openbsd/OpenNTPD/${MY_P}.tar.gz
+ mirror://debian/pool/main/o/openntpd/${MY_P/-/_}+debian-${DEB_VER}.debian.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl selinux"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ selinux? ( sec-policy/selinux-ntp )
+ !<=net-misc/ntp-4.2.0-r2
+ !net-misc/ntp[-openntpd]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup ntp 123
+ enewuser ntp 123 -1 /var/lib/openntpd/chroot ntp
+
+ # make sure user has correct HOME when flipping between
+ # the standard ntp pkg and this one
+ usermod -d /var/lib/openntpd/chroot ntp
+}
+
+src_prepare() {
+ sed -i '/NTPD_USER/s:_ntp:ntp:' ntpd.h || die
+
+ epatch "${WORKDIR}"/debian/patches/*.patch
+ sed -i 's:debian:gentoo:g' ntpd.conf || die
+ eautoreconf # deb patchset touches .ac files and such
+}
+
+src_configure() {
+ econf \
+ --disable-strip \
+ --with-adjtimex \
+ $(use_with !ssl builtin-arc4random)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog CREDITS README
+
+ newinitd "${FILESDIR}"/openntpd.rc-3.9_p1-r2 ntpd
+ newconfd "${FILESDIR}"/openntpd.conf.d-3.9_p1-r2 ntpd
+}