summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-12-15 20:24:48 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-12-15 20:24:48 +0000
commit6985448a91f5e5686a65b0e9383503ea69474f16 (patch)
tree812e58bd1381915b85cd5e5c4b996308bd89b11f /net-misc/nxnode
parentVersion bump. Fixes bug #296867 (diff)
downloadgentoo-2-6985448a91f5e5686a65b0e9383503ea69474f16.tar.gz
gentoo-2-6985448a91f5e5686a65b0e9383503ea69474f16.tar.bz2
gentoo-2-6985448a91f5e5686a65b0e9383503ea69474f16.zip
Change Gnome start command, bug #292480
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/nxnode')
-rw-r--r--net-misc/nxnode/ChangeLog8
-rw-r--r--net-misc/nxnode/files/nxnode-3.4.0-setup.patch61
-rw-r--r--net-misc/nxnode/nxnode-3.4.0.6-r1.ebuild101
3 files changed, 169 insertions, 1 deletions
diff --git a/net-misc/nxnode/ChangeLog b/net-misc/nxnode/ChangeLog
index d9159e3a03cc..bde4e54a95a0 100644
--- a/net-misc/nxnode/ChangeLog
+++ b/net-misc/nxnode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nxnode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/ChangeLog,v 1.52 2009/12/15 17:35:06 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/ChangeLog,v 1.53 2009/12/15 20:24:48 voyageur Exp $
+
+*nxnode-3.4.0.6-r1 (15 Dec 2009)
+
+ 15 Dec 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +nxnode-3.4.0.6-r1.ebuild, +files/nxnode-3.4.0-setup.patch:
+ Change Gnome start command, bug #292480
15 Dec 2009; Bernard Cafarelli <voyageur@gentoo.org>
-nxnode-3.3.0.3.ebuild, -nxnode-3.3.0.12.ebuild, -nxnode-3.3.0.22.ebuild:
diff --git a/net-misc/nxnode/files/nxnode-3.4.0-setup.patch b/net-misc/nxnode/files/nxnode-3.4.0-setup.patch
new file mode 100644
index 000000000000..f4a70f670178
--- /dev/null
+++ b/net-misc/nxnode/files/nxnode-3.4.0-setup.patch
@@ -0,0 +1,61 @@
+--- scripts/setup/nxnode.orig 2009-09-24 18:12:36.000000000 +0200
++++ scripts/setup/nxnode 2009-12-15 21:22:27.000000000 +0100
+@@ -481,7 +481,7 @@
+ echo "#
+ # Specify path and name of the command to start the GNOME session.
+ #
+-CommandStartGnome=\"$DBUS_PATH --exit-with-session gnome-session\"
++CommandStartGnome=\"/etc/X11/Sessions/Gnome\"
+ " >> $CONFIG_FILE;
+ fi
+
+@@ -525,7 +525,7 @@
+ cmdGnome="/etc/X11/Xsession gnome-session"
+ elif [ $DBUS = "1" ] && [ "x$DBUS_PATH" != "x" ];
+ then
+- cmdGnome="$DBUS_PATH --exit-with-session gnome-session"
++ cmdGnome="/etc/X11/Sessions/Gnome"
+ else
+ cmdGnome="gnome-session"
+ fi
+@@ -1421,6 +1421,10 @@
+ runCommand "$RMCOMMAND -f /etc/rc0.d/K01nxsensor" "Unable to remove '/etc/rc0.d/K01nxsensor'" "warn"
+ fi
+
++ elif [ "$system" = "gentoo" ]; then
++ # do nothing; this is handled by Gentoo ebuild
++ echo > /dev/null
++
+ else
+ if [ -h /etc/rc.d/rc3.d/S99nxsensor ];
+ then
+@@ -1465,6 +1469,10 @@
+
+ addNXinit () {
+
++ if [ "$system" = "gentoo" ] ; then
++ return;
++ fi
++
+ runCommand "cat $NODE_ROOT/scripts/init/nxsensor > /etc/init.d/nxsensor" "Unable to create: '/etc/init.d/nxsensor'" "warn"
+ runCommand "chmod +x /etc/init.d/nxsensor" "Cannot set permissions of '/etc/init.d/nxsensor' file" "warn"
+
+@@ -2489,6 +2497,10 @@
+ system=fedora
+ fi
+
++if [ -d /usr/portage ]; then
++ system=gentoo
++fi
++
+ if [ "x$system" = "x" -a -f /etc/release ];
+ then
+ system=solaris
+@@ -2523,6 +2535,7 @@
+ "fedora" ) ;;
+ "debian" ) ;;
+ "solaris" ) ;;
++ "gentoo" );;
+ "" ) ARGS=-1 && errMsg="$PREFIX $ERROR ERROR: Unable to autodetect the operating system type, please specify it" ;;
+ * ) ARGS=-1 && errMsg="$PREFIX $ERROR ERROR: Unsupported operating system '$system'" ;;
+ esac
diff --git a/net-misc/nxnode/nxnode-3.4.0.6-r1.ebuild b/net-misc/nxnode/nxnode-3.4.0.6-r1.ebuild
new file mode 100644
index 000000000000..73bb56209d07
--- /dev/null
+++ b/net-misc/nxnode/nxnode-3.4.0.6-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.4.0.6-r1.ebuild,v 1.1 2009/12/15 20:24:48 voyageur Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MAJOR_PV="$(get_version_component_range 1-3)"
+FULL_PV="${MAJOR_PV}-$(get_version_component_range 4)"
+DESCRIPTION="shared components between the different editions of NoMachine's NX Servers"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="amd64? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxnode-${FULL_PV}.x86_64.tar.gz )
+ x86? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxnode-${FULL_PV}.i386.tar.gz )"
+
+LICENSE="nomachine"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="rdesktop vnc"
+RESTRICT="strip"
+
+DEPEND="!<net-misc/nxserver-freeedition-3.0.0"
+RDEPEND="=net-misc/nxclient-${MAJOR_PV}*
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-apps/xrdb
+ rdesktop? ( net-misc/rdesktop )
+ vnc? ( x11-misc/x11vnc
+ || ( net-misc/tightvnc net-misc/vnc ) )"
+
+S=${WORKDIR}/NX
+
+pkg_preinst()
+{
+ enewuser nx -1 -1 /usr/NX/home/nx
+}
+
+src_prepare()
+{
+ epatch "${FILESDIR}"/nxnode-3.4.0-setup.patch
+}
+
+src_install()
+{
+ # we install nxnode into /usr/NX, to make sure it doesn't clash
+ # with libraries installed for FreeNX
+
+ into /usr/NX
+ for x in nxagent nxnode nxsensor nxspool nxuexec ; do
+ dobin bin/$x
+ done
+
+ dodir /usr/NX/etc
+ cp etc/node-debian.cfg.sample "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
+ sed -e 's|COMMAND_FUSER = .*|COMMAND_FUSER = "/usr/bin/fuser"|;' -i "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
+ cp etc/node.lic.sample "${D}"/usr/NX/etc/node.lic.sample || die
+
+ dodir /usr/NX/lib
+ cp -R lib "${D}"/usr/NX || die
+
+ dodir /usr/NX/scripts
+ cp -R scripts "${D}"/usr/NX || die
+
+ dodir /usr/NX/share
+ cp -R share "${D}"/usr/NX || die
+
+ dodir /usr/NX/var
+ cp -R var "${D}"/usr/NX || die
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/nxnode-3.0.0-init nxsensor
+}
+
+pkg_postinst()
+{
+ # Only install license file if none is found
+ if [ ! -f /usr/NX/etc/node.lic ]; then
+ cp "${ROOT}"/usr/NX/etc/node.lic.sample "${ROOT}"/usr/NX/etc/node.lic || die
+ chmod 0400 "${ROOT}"/usr/NX/etc/node.lic
+ chown nx:0 "${ROOT}"/usr/NX/etc/node.lic
+ fi
+
+ # only run install on the first time
+ if [ -f /usr/NX/etc/node.cfg ]; then
+ einfo "Running NoMachine's update script"
+ "${ROOT}"/usr/NX/scripts/setup/nxnode --update
+ else
+ einfo "Running NoMachine's setup script"
+ "${ROOT}"/usr/NX/scripts/setup/nxnode --install
+ fi
+
+ elog "If you want server statistics, please add nxsensor to your default runlevel"
+ elog
+ elog " rc-update add nxsensor default"
+ elog
+ elog "You will also need to change EnableSensor to 1 in /usr/NX/etc/node.cfg"
+}