summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-06-21 20:15:48 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-06-21 20:15:48 +0000
commit0b6c48b5de8e5b86eb9b4539835e10fe51638a4e (patch)
tree664a0385983528a8d77dff8c726628244ba406b7 /net-misc/nxclient
parentStable on amd64 wrt bug 180645 (diff)
downloadgentoo-2-0b6c48b5de8e5b86eb9b4539835e10fe51638a4e.tar.gz
gentoo-2-0b6c48b5de8e5b86eb9b4539835e10fe51638a4e.tar.bz2
gentoo-2-0b6c48b5de8e5b86eb9b4539835e10fe51638a4e.zip
Version bump
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'net-misc/nxclient')
-rw-r--r--net-misc/nxclient/ChangeLog8
-rw-r--r--net-misc/nxclient/files/digest-nxclient-3.0.06
-rw-r--r--net-misc/nxclient/nxclient-3.0.0.ebuild60
3 files changed, 73 insertions, 1 deletions
diff --git a/net-misc/nxclient/ChangeLog b/net-misc/nxclient/ChangeLog
index abdd5329b645..e6931f1f8273 100644
--- a/net-misc/nxclient/ChangeLog
+++ b/net-misc/nxclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nxclient
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/ChangeLog,v 1.41 2007/06/13 08:21:47 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/ChangeLog,v 1.42 2007/06/21 20:15:48 voyageur Exp $
+
+*nxclient-3.0.0 (21 Jun 2007)
+
+ 21 Jun 2007; Bernard Cafarelli <voyageur@gentoo.org>
+ +nxclient-3.0.0.ebuild:
+ Version bump
13 Jun 2007; Bernard Cafarelli <voyageur@gentoo.org>
nxclient-1.5.0-r5.ebuild:
diff --git a/net-misc/nxclient/files/digest-nxclient-3.0.0 b/net-misc/nxclient/files/digest-nxclient-3.0.0
new file mode 100644
index 000000000000..872e6c79c130
--- /dev/null
+++ b/net-misc/nxclient/files/digest-nxclient-3.0.0
@@ -0,0 +1,6 @@
+MD5 de0f114fcfb568082cc4ba99bf18cb31 nxclient-3.0.0-65.i386.tar.gz 3863317
+RMD160 55f9de751e46c7703ed0266af2cbf87c7cf8ccf5 nxclient-3.0.0-65.i386.tar.gz 3863317
+SHA256 af2d02d87aba42af2920fdd6c122a12e1384a267f9363e9821c62b7991dfd02e nxclient-3.0.0-65.i386.tar.gz 3863317
+MD5 903ba1825c533b74ae6e31beeee30810 nxclient-3.0.0-65.x86_64.tar.gz 4050883
+RMD160 ebe2516c0b2047ae82885795ac7d0606b7fdc27b nxclient-3.0.0-65.x86_64.tar.gz 4050883
+SHA256 8cb182bc0df415f8b6105354c47066062a739c136b94e6c73f44311693ac6dc2 nxclient-3.0.0-65.x86_64.tar.gz 4050883
diff --git a/net-misc/nxclient/nxclient-3.0.0.ebuild b/net-misc/nxclient/nxclient-3.0.0.ebuild
new file mode 100644
index 000000000000..ea3965ebb862
--- /dev/null
+++ b/net-misc/nxclient/nxclient-3.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/nxclient-3.0.0.ebuild,v 1.1 2007/06/21 20:15:48 voyageur Exp $
+
+inherit eutils
+
+DESCRIPTION="NXClient is a X11/VNC/NXServer client especially tuned for using remote desktops over low-bandwidth links such as the Internet"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="amd64? ( http://64.34.161.181/download/${PV}/Linux/nxclient-${PV}-65.x86_64.tar.gz )
+ x86? ( http://64.34.161.181/download/${PV}/Linux/nxclient-${PV}-65.i386.tar.gz )"
+LICENSE="nomachine"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="nostrip"
+
+DEPEND=""
+RDEPEND="dev-libs/expat
+ dev-libs/openssl
+ media-libs/audiofile
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/freetype
+ media-libs/fontconfig
+ net-print/cups
+ x11-libs/libXft
+ x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXext
+ sys-libs/zlib
+ !net-misc/nxclient-2xterminalserver"
+
+S=${WORKDIR}/NX
+
+src_install()
+{
+ # we install nxclient into /usr/NX, to make sure it doesn't clash
+ # with libraries installed for FreeNX
+
+ for x in nxclient nxesd nxkill nxprint nxservice nxssh ; do
+ into /usr/NX
+ dobin bin/$x
+ into /usr
+ make_wrapper $x ./$x /usr/NX/bin /usr/NX/lib || die
+ done
+
+ dodir /usr/NX/lib
+ cp -P lib/libXcompsh.so* lib/libXcomp.so* ${D}/usr/NX/lib
+
+ dodir /usr/NX/share
+ cp -R share ${D}/usr/NX
+
+ # Add icons/desktop entries (missing in the tarball)
+ doicon share/icons/*.png
+ make_desktop_entry "nxclient" "NX Client" nx-desktop.png
+ make_desktop_entry "nxclient -admin" "NX Session Administrator" nxclient-admin.png
+ make_desktop_entry "nxclient -wizard" "NX Connection Wizard" nxclient-wizard.png
+}