summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-01-09 14:54:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-01-09 14:54:45 +0000
commit60eed084e93aeb0fca324e7d51f1f12cd48ee580 (patch)
tree6e3c60289ddb5af1de05b6256782f1fdf9ea979b /net-misc/nx
parentr1 for getting rid of install scripts for icons and desktop files (diff)
downloadgentoo-2-60eed084e93aeb0fca324e7d51f1f12cd48ee580.tar.gz
gentoo-2-60eed084e93aeb0fca324e7d51f1f12cd48ee580.tar.bz2
gentoo-2-60eed084e93aeb0fca324e7d51f1f12cd48ee580.zip
Finally found how to respect AR/RANLIB, fix some missing CC/CXX, bug #445794
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/nx')
-rw-r--r--net-misc/nx/ChangeLog8
-rw-r--r--net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch100
-rw-r--r--net-misc/nx/nx-3.5.0.17-r1.ebuild98
3 files changed, 205 insertions, 1 deletions
diff --git a/net-misc/nx/ChangeLog b/net-misc/nx/ChangeLog
index 7a58a6939c38..d49f7d2e3c63 100644
--- a/net-misc/nx/ChangeLog
+++ b/net-misc/nx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nx/ChangeLog,v 1.75 2013/01/08 10:47:02 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nx/ChangeLog,v 1.76 2013/01/09 14:54:45 voyageur Exp $
+
+*nx-3.5.0.17-r1 (09 Jan 2013)
+
+ 09 Jan 2013; Bernard Cafarelli <voyageur@gentoo.org> +nx-3.5.0.17-r1.ebuild,
+ +files/nx-3.5.0.17-cflags_ar_ranlib.patch:
+ Finally found how to respect AR/RANLIB, fix some missing CC/CXX, bug #445794
*nx-3.5.0.17 (08 Jan 2013)
diff --git a/net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch b/net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch
new file mode 100644
index 000000000000..668a6bf4c310
--- /dev/null
+++ b/net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch
@@ -0,0 +1,100 @@
+diff -Naur nx-libs-3.5.0.17.orig/nxcomp/Makefile.in nx-libs-3.5.0.17/nxcomp/Makefile.in
+--- nx-libs-3.5.0.17.orig/nxcomp/Makefile.in 2013-01-09 15:03:33.152952758 +0100
++++ nx-libs-3.5.0.17/nxcomp/Makefile.in 2013-01-09 15:05:39.771898159 +0100
+@@ -243,8 +243,8 @@
+
+ $(LIBARCHIVE): $(CXXOBJ) $(COBJ)
+ rm -f $(LIBARCHIVE)
+- ar clq $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
+- ranlib $(LIBARCHIVE)
++ $(AR) $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
++ $(RANLIB) $(LIBARCHIVE)
+
+ $(LIBCYGSHARED): $(LIBARCHIVE)
+ $(CC) -shared -o $(LIBCYGSHARED) \
+diff -Naur nx-libs-3.5.0.17.orig/nxcomp/configure.in nx-libs-3.5.0.17/nxcomp/configure.in
+--- nx-libs-3.5.0.17.orig/nxcomp/configure.in 2013-01-09 15:03:33.151952758 +0100
++++ nx-libs-3.5.0.17/nxcomp/configure.in 2013-01-09 15:04:03.312940892 +0100
+@@ -7,8 +7,7 @@
+
+ dnl Set our default compilation flags.
+
+-CXXFLAGS="$CXXFLAGS -O3 -fno-rtti -fno-exceptions"
+-CFLAGS="$CFLAGS -O3"
++CXXFLAGS="$CXXFLAGS -fno-rtti -fno-exceptions"
+
+ dnl Reset default linking directives.
+
+diff -Naur nx-libs-3.5.0.17.orig/nxcompext/Makefile.in nx-libs-3.5.0.17/nxcompext/Makefile.in
+--- nx-libs-3.5.0.17.orig/nxcompext/Makefile.in 2013-01-09 15:03:33.164952753 +0100
++++ nx-libs-3.5.0.17/nxcompext/Makefile.in 2013-01-09 15:06:08.747879052 +0100
+@@ -125,8 +125,8 @@
+
+ $(LIBARCHIVE): $(CXXOBJ) $(COBJ)
+ rm -f $(LIBARCHIVE)
+- ar clq $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
+- ranlib $(LIBARCHIVE)
++ $(AR) $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
++ $(RANLIB) $(LIBARCHIVE)
+
+ $(LIBCYGSHARED): $(LIBARCHIVE)
+ $(CC) -shared -o $(LIBCYGSHARED) \
+diff -Naur nx-libs-3.5.0.17.orig/nxcompext/configure.in nx-libs-3.5.0.17/nxcompext/configure.in
+--- nx-libs-3.5.0.17.orig/nxcompext/configure.in 2013-01-09 15:03:33.164952753 +0100
++++ nx-libs-3.5.0.17/nxcompext/configure.in 2013-01-09 15:04:16.247935801 +0100
+@@ -5,11 +5,6 @@
+ AC_INIT(NXlib.h)
+ AC_PREREQ(2.13)
+
+-dnl Reset default compilation flags.
+-
+-CXXFLAGS="$CXXFLAGS -O3"
+-CFLAGS="$CFLAGS -O3"
+-
+ dnl Reset default linking directives.
+
+ LIBSTATIC=""
+diff -Naur nx-libs-3.5.0.17.orig/nxcompshad/Makefile.in nx-libs-3.5.0.17/nxcompshad/Makefile.in
+--- nx-libs-3.5.0.17.orig/nxcompshad/Makefile.in 2013-01-09 15:03:33.163952754 +0100
++++ nx-libs-3.5.0.17/nxcompshad/Makefile.in 2013-01-09 15:06:16.933873660 +0100
+@@ -158,8 +158,8 @@
+
+ $(LIBARCHIVE): $(CXXOBJ) $(COBJ)
+ rm -f $(LIBARCHIVE)
+- ar clq $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
+- ranlib $(LIBARCHIVE)
++ $(AR) $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
++ $(RANLIB) $(LIBARCHIVE)
+
+ $(LIBDLL): $(LIBARCHIVE)
+ $(CC) -o $@ \
+diff -Naur nx-libs-3.5.0.17.orig/nxcompshad/configure.in nx-libs-3.5.0.17/nxcompshad/configure.in
+--- nx-libs-3.5.0.17.orig/nxcompshad/configure.in 2013-01-09 15:03:33.163952754 +0100
++++ nx-libs-3.5.0.17/nxcompshad/configure.in 2013-01-09 15:04:20.073934295 +0100
+@@ -5,11 +5,6 @@
+ AC_INIT(Shadow.h)
+ AC_PREREQ(2.13)
+
+-dnl Reset default compilation flags.
+-
+-CXXFLAGS="$CXXFLAGS -O3"
+-CPPFLAGS="$CPPFLAGS -O3"
+-
+ dnl Reset default linking directives.
+
+ LIBSTATIC=""
+diff -Naur nx-libs-3.5.0.17.orig/nxproxy/configure.in nx-libs-3.5.0.17/nxproxy/configure.in
+--- nx-libs-3.5.0.17.orig/nxproxy/configure.in 2013-01-09 15:03:33.163952754 +0100
++++ nx-libs-3.5.0.17/nxproxy/configure.in 2013-01-09 15:04:24.842932418 +0100
+@@ -5,11 +5,6 @@
+ AC_INIT(Main.c)
+ AC_PREREQ(2.13)
+
+-dnl Reset default compilation flags.
+-
+-CXXFLAGS="$CXXFLAGS -O3"
+-CPPFLAGS="$CPPFLAGS -O3"
+-
+ dnl Prefer headers and libraries from nx-X11 if present.
+
+ if test -d "../nx-X11/exports/include" ; then
diff --git a/net-misc/nx/nx-3.5.0.17-r1.ebuild b/net-misc/nx/nx-3.5.0.17-r1.ebuild
new file mode 100644
index 000000000000..0a062311e127
--- /dev/null
+++ b/net-misc/nx/nx-3.5.0.17-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nx/nx-3.5.0.17-r1.ebuild,v 1.1 2013/01/09 14:54:45 voyageur Exp $
+
+EAPI=4
+inherit autotools eutils multilib
+
+DESCRIPTION="NX compression technology core libraries"
+HOMEPAGE="http://www.nomachine.com/developers.php
+ http://www.x2go.org/doku.php/wiki:libs:nx-libs"
+
+SRC_URI="http://code.x2go.org/releases/source/nx-libs/nx-libs-${PV}-full.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="elibc_glibc"
+
+RDEPEND="elibc_glibc? ( || ( net-libs/libtirpc <sys-libs/glibc-2.14 ) )
+ >=media-libs/libpng-1.2.8
+ >=sys-libs/zlib-1.2.3
+ virtual/jpeg"
+
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/inputproto"
+
+S=${WORKDIR}/nx-libs-${PV}
+
+src_prepare() {
+ # For nxcl/qtnx
+ cd "${S}"/nxproxy
+ epatch "${FILESDIR}"/${PN}-3.2.0-nxproxy_read_from_stdin.patch
+
+ cd "${S}"
+ # Fix sandbox violation
+ epatch "${FILESDIR}"/1.5.0/nx-x11-1.5.0-tmp-exec.patch
+ # -fPIC
+ epatch "${FILESDIR}"/1.5.0/nxcomp-1.5.0-pic.patch
+ # Drop force -O3, set AR/RANLIB and
+ # run autoreconf in all neeed folders
+ epatch "${FILESDIR}"/${P}-cflags_ar_ranlib.patch
+ for i in nxcomp nxcompext nxcompshad nxproxy; do
+ cd "${S}"/${i}
+ eautoreconf ${i}
+ cd "${S}"
+ done
+
+ # From xorg-x11-6.9.0-r3.ebuild
+ cd "${S}/nx-X11"
+ HOSTCONF="config/cf/host.def"
+ echo "#define CcCmd $(tc-getCC)" >> ${HOSTCONF}
+ echo "#define OptimizedCDebugFlags ${CFLAGS} GccAliasingArgs" >> ${HOSTCONF}
+ echo "#define OptimizedCplusplusDebugFlags ${CXXFLAGS} GccAliasingArgs" >> ${HOSTCONF}
+ # Respect LDFLAGS
+ echo "#define ExtraLoadFlags ${LDFLAGS}" >> ${HOSTCONF}
+ echo "#define SharedLibraryLoadFlags -shared ${LDFLAGS}" >> ${HOSTCONF}
+}
+
+src_configure() {
+ cd "${S}"/nxproxy
+ econf
+}
+
+src_compile() {
+ cd "${S}/nx-X11"
+ FAST=1 emake World WORLDOPTS="" MAKE="make" \
+ AR="$(tc-getAR) clq" RANLIB="$(tc-getRANLIB)" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+
+ cd "${S}"/nxproxy
+ emake
+}
+
+src_install() {
+ NX_ROOT=/usr/$(get_libdir)/NX
+
+ for x in nxagent nxauth nxproxy; do
+ make_wrapper $x ./$x ${NX_ROOT}/bin ${NX_ROOT}/$(get_libdir) ||
+ die " $x wrapper creation failed"
+ done
+
+ into ${NX_ROOT}
+ dobin "${S}"/nx-X11/programs/Xserver/nxagent
+ dobin "${S}"/nx-X11/programs/nxauth/nxauth
+ dobin "${S}"/nxproxy/nxproxy
+
+ for lib in X11 Xau Xcomposite Xdamage Xdmcp Xext Xfixes Xinerama Xpm Xrandr Xrender Xtst;
+ do
+ dolib.so "${S}"/nx-X11/lib/${lib}/libNX_${lib}.so*
+ done
+ dolib.so "${S}"/nx-X11/lib/freetype2/libNX_freetype.so*
+
+ dolib.so "${S}"/nxcomp/libXcomp.so*
+ dolib.so "${S}"/nxcompext/libXcompext.so*
+ dolib.so "${S}"/nxcompshad/libXcompshad.so*
+}