summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-17 07:42:34 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-17 07:42:34 +0000
commite1ac8e76c96f1156ae0d4c29821ecd3b7be34f11 (patch)
tree1d5d45c5750446a2d7817e7b93b50de92509176c /net-misc/ntp
parentStable on amd64 (diff)
downloadgentoo-2-e1ac8e76c96f1156ae0d4c29821ecd3b7be34f11.tar.gz
gentoo-2-e1ac8e76c96f1156ae0d4c29821ecd3b7be34f11.tar.bz2
gentoo-2-e1ac8e76c96f1156ae0d4c29821ecd3b7be34f11.zip
Version bump.
(Portage version: 2.1)
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/ChangeLog7
-rw-r--r--net-misc/ntp/files/digest-ntp-4.2.26
-rw-r--r--net-misc/ntp/ntp-4.2.2.ebuild139
3 files changed, 151 insertions, 1 deletions
diff --git a/net-misc/ntp/ChangeLog b/net-misc/ntp/ChangeLog
index c0e1bfba9d64..d4a6f5c0b80f 100644
--- a/net-misc/ntp/ChangeLog
+++ b/net-misc/ntp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ntp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.73 2006/05/25 22:33:48 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.74 2006/06/17 07:42:33 vapier Exp $
+
+*ntp-4.2.2 (17 Jun 2006)
+
+ 17 Jun 2006; Mike Frysinger <vapier@gentoo.org> +ntp-4.2.2.ebuild:
+ Version bump.
25 May 2006; Emanuele Giaquinta <exg@gentoo.org> ntp-4.2.0-r2.ebuild,
ntp-4.2.0.20040617-r3.ebuild, ntp-4.2.0.20050303-r1.ebuild,
diff --git a/net-misc/ntp/files/digest-ntp-4.2.2 b/net-misc/ntp/files/digest-ntp-4.2.2
new file mode 100644
index 000000000000..fa66f4cb72ee
--- /dev/null
+++ b/net-misc/ntp/files/digest-ntp-4.2.2
@@ -0,0 +1,6 @@
+MD5 6f51d450cfaef5b898f5ee6fff5499a5 ntp-4.2.2-manpages.tar.bz2 25213
+RMD160 ac90f9b371fe6cd6bfdf931fd53432e054e7ce8a ntp-4.2.2-manpages.tar.bz2 25213
+SHA256 290e5a2ccb61960c7c35b07ac5255c8efa0721858fd85594792b62daa2852bc0 ntp-4.2.2-manpages.tar.bz2 25213
+MD5 111d879acdcc955e60f527575ab0a71a ntp-4.2.2.tar.gz 2546027
+RMD160 2cf9540cf2e6c5fc3e3d8922676ea3b2efb9215e ntp-4.2.2.tar.gz 2546027
+SHA256 fb392fa5f1a753043981e661b09c6d0249050ff903078ed215a568952d76befc ntp-4.2.2.tar.gz 2546027
diff --git a/net-misc/ntp/ntp-4.2.2.ebuild b/net-misc/ntp/ntp-4.2.2.ebuild
new file mode 100644
index 000000000000..ddec5dc9f5f8
--- /dev/null
+++ b/net-misc/ntp/ntp-4.2.2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.2.ebuild,v 1.1 2006/06/17 07:42:34 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Network Time Protocol suite/programs"
+HOMEPAGE="http://www.ntp.org/"
+SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV:0:3}/${P}.tar.gz
+ mirror://gentoo/${P}-manpages.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="logrotate parse-clocks caps selinux ssl ipv6 openntpd debug"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ kernel_linux? ( caps? ( sys-libs/libcap ) )
+ !openntpd? ( !net-misc/openntpd )
+ ssl? ( dev-libs/openssl )
+ selinux? ( sec-policy/selinux-ntp )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+PDEPEND="openntpd? ( net-misc/openntpd )"
+
+hax_bitkeeper() {
+ # the makefiles have support for bk ...
+ # basically we have to do this or bk will try to write
+ # to files in /opt/bitkeeper causing sandbox violations ;(
+ mkdir "${T}"/fakebin
+ echo "#!/bin/sh"$'\n'"exit 1" > "${T}"/fakebin/bk
+ chmod a+x "${T}"/fakebin/bk
+ export PATH="${T}/fakebin:${PATH}"
+}
+
+pkg_setup() {
+ enewgroup ntp 123
+ enewuser ntp 123 -1 /dev/null ntp
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+# epatch "${FILESDIR}"/4.2.0.20040617-hostname.patch
+
+ sed -i \
+ -e 's:md5\.h:touch_not_my_md5:g' \
+ -e 's:-lelf:-la_doe_a_deer_a_female_deer:g' \
+ -e 's:-lmd5:-li_dont_want_no_stinkin_md5:g' \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ hax_bitkeeper
+ econf \
+ $(use_enable caps linuxcaps) \
+ $(use_enable parse-clocks) \
+ $(use_enable ipv6) \
+ $(use_enable debug debugging) \
+ $(use_with ssl crypto) \
+ || die
+ emake || die
+}
+
+src_install() {
+ hax_bitkeeper
+ make install DESTDIR="${D}" || die "install failed"
+ # move ntpd/ntpdate to sbin #66671
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/{ntpd,ntpdate} "${D}"/usr/sbin/ || die "move to sbin"
+
+ dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
+ doman "${WORKDIR}"/man/*.1
+ dohtml -r html/*
+
+ insinto /usr/share/ntp
+ doins "${FILESDIR}"/ntp.conf
+ cp -r scripts/* "${D}"/usr/share/ntp/
+ chmod -R go-w "${D}"/usr/share/ntp
+ find "${D}"/usr/share/ntp \
+ '(' \
+ -name '*.in' -o \
+ -name 'Makefile*' -o \
+ -name 'rc[12]' -o \
+ -name support \
+ ')' \
+ -exec rm -r {} \;
+
+ insinto /etc
+ doins "${FILESDIR}"/ntp.conf
+ newinitd "${FILESDIR}"/ntpd.rc ntpd
+ newconfd "${FILESDIR}"/ntpd.confd ntpd
+ newinitd "${FILESDIR}"/ntp-client.rc ntp-client
+ newconfd "${FILESDIR}"/ntp-client.confd ntp-client
+ use caps || dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
+ dosed "s:-Q::" /etc/conf.d/ntp-client # no longer needed
+ dosed "s:/usr/bin:/usr/sbin:" /etc/init.d/ntpd
+
+ keepdir /var/lib/ntp
+ fowners ntp:ntp /var/lib/ntp
+
+ if use logrotate ; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/ntp.logrotate ntp
+ fi
+
+ if use openntpd ; then
+ cd "${D}"
+ rm usr/sbin/ntpd
+ rm -r var/lib
+ rm etc/{conf,init}.d/ntpd
+ fi
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/ntp.conf ]] ; then
+ rm -f "${D}"/etc/ntp.conf
+ fi
+}
+
+pkg_postinst() {
+ ewarn "You can find an example /etc/ntp.conf in /usr/share/ntp/"
+ ewarn "Review /etc/ntp.conf to setup server info."
+ ewarn "Review /etc/conf.d/ntpd to setup init.d info."
+ echo
+ einfo "The way ntp sets and maintains your system time has changed."
+ einfo "Now you can use /etc/init.d/ntp-client to set your time at"
+ einfo "boot while you can use /etc/init.d/ntpd to maintain your time"
+ einfo "while your machine runs"
+ if [[ -n $(egrep '^[^#].*notrust' "${ROOT}"/etc/ntp.conf) ]] ; then
+ echo
+ eerror "The notrust option was found in your /etc/ntp.conf!"
+ ewarn "If your ntpd starts sending out weird responses,"
+ ewarn "then make sure you have keys properly setup and see"
+ ewarn "http://bugs.gentoo.org/41827"
+ fi
+}