summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-05-25 22:33:48 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-05-25 22:33:48 +0000
commitac9caf370cae4752140aed0ecc82a59cb0c71062 (patch)
tree329687ae6a866518e91eb98d511a7812d609eeb5 /net-misc/ntp
parentAdded to ~hppa, ~ppc64, ~sparc. See bug #134270. (diff)
downloadgentoo-2-ac9caf370cae4752140aed0ecc82a59cb0c71062.tar.gz
gentoo-2-ac9caf370cae4752140aed0ecc82a59cb0c71062.tar.bz2
gentoo-2-ac9caf370cae4752140aed0ecc82a59cb0c71062.zip
Use caps instead of !nodroproot to enable libcap support.
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/ChangeLog7
-rw-r--r--net-misc/ntp/ntp-4.2.0-r2.ebuild12
-rw-r--r--net-misc/ntp/ntp-4.2.0.20040617-r3.ebuild10
-rw-r--r--net-misc/ntp/ntp-4.2.0.20050303-r1.ebuild10
-rw-r--r--net-misc/ntp/ntp-4.2.0.20060224.ebuild10
5 files changed, 27 insertions, 22 deletions
diff --git a/net-misc/ntp/ChangeLog b/net-misc/ntp/ChangeLog
index 93fd22054c4b..c0e1bfba9d64 100644
--- a/net-misc/ntp/ChangeLog
+++ b/net-misc/ntp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ntp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.72 2006/05/04 01:10:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.73 2006/05/25 22:33:48 exg Exp $
+
+ 25 May 2006; Emanuele Giaquinta <exg@gentoo.org> ntp-4.2.0-r2.ebuild,
+ ntp-4.2.0.20040617-r3.ebuild, ntp-4.2.0.20050303-r1.ebuild,
+ ntp-4.2.0.20060224.ebuild:
+ Use caps instead of !nodroproot to enable libcap support.
*ntp-4.2.0.20060224 (04 May 2006)
diff --git a/net-misc/ntp/ntp-4.2.0-r2.ebuild b/net-misc/ntp/ntp-4.2.0-r2.ebuild
index b637edc5fd7b..9bf0ce117cdf 100644
--- a/net-misc/ntp/ntp-4.2.0-r2.ebuild
+++ b/net-misc/ntp/ntp-4.2.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0-r2.ebuild,v 1.25 2005/08/25 22:10:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0-r2.ebuild,v 1.26 2006/05/25 22:33:48 exg Exp $
inherit eutils flag-o-matic gnuconfig
@@ -12,11 +12,11 @@ SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${P}.tar.gz
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa mips ppc ppc64 sparc x86 ia64"
-IUSE="parse-clocks nodroproot selinux ssl"
+IUSE="parse-clocks caps selinux ssl"
RDEPEND=">=sys-libs/ncurses-5.2
>=sys-libs/readline-4.1
- !nodroproot? ( sys-libs/libcap )
+ caps? ( sys-libs/libcap )
ssl? ( dev-libs/openssl )
selinux? ( sec-policy/selinux-ntp )"
DEPEND="${RDEPEND}
@@ -67,7 +67,7 @@ src_compile() {
&& mysslconf="--with-openssl-libdir=yes" \
|| mysslconf="--with-openssl-libdir=no"
econf \
- `use_enable !nodroproot linuxcaps` \
+ `use_enable caps linuxcaps` \
`use_enable parse-clocks` \
${mysslconf} \
|| die
@@ -107,7 +107,7 @@ src_install() {
insinto /etc/conf.d
newins "${FILESDIR}"/ntpd.confd ntpd
newins "${FILESDIR}"/ntp-client.confd ntp-client
- use nodroproot && dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
+ use caps || dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
dodir /var/lib/ntp
fowners ntp:ntp /var/lib/ntp
diff --git a/net-misc/ntp/ntp-4.2.0.20040617-r3.ebuild b/net-misc/ntp/ntp-4.2.0.20040617-r3.ebuild
index 4c3da0cb6fc2..3cc6a8a5d2b8 100644
--- a/net-misc/ntp/ntp-4.2.0.20040617-r3.ebuild
+++ b/net-misc/ntp/ntp-4.2.0.20040617-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0.20040617-r3.ebuild,v 1.4 2006/01/20 00:56:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0.20040617-r3.ebuild,v 1.5 2006/05/25 22:33:48 exg Exp $
inherit eutils
@@ -13,11 +13,11 @@ SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/snapshots/ntp-stable/${PV
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
-IUSE="logrotate parse-clocks nodroproot selinux ssl ipv6 openntpd debug"
+IUSE="logrotate parse-clocks caps selinux ssl ipv6 openntpd debug"
RDEPEND=">=sys-libs/ncurses-5.2
>=sys-libs/readline-4.1
- kernel_linux? ( !nodroproot? ( sys-libs/libcap ) )
+ kernel_linux? ( caps? ( sys-libs/libcap ) )
!openntpd? ( !net-misc/openntpd )
ssl? ( dev-libs/openssl )
selinux? ( sec-policy/selinux-ntp )"
@@ -67,7 +67,7 @@ src_unpack() {
src_compile() {
hax_bitkeeper
econf \
- $(use_enable !nodroproot linuxcaps) \
+ $(use_enable caps linuxcaps) \
$(use_enable parse-clocks) \
$(use_enable ipv6) \
$(use_enable debug debugging) \
@@ -106,7 +106,7 @@ src_install() {
newconfd "${FILESDIR}"/ntpd.confd ntpd
newinitd "${FILESDIR}"/ntp-client.rc ntp-client
newconfd "${FILESDIR}"/ntp-client.confd ntp-client
- use nodroproot && dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
+ use caps || dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
dosed "s:-Q::" /etc/conf.d/ntp-client # no longer needed
dosed "s:/usr/bin:/usr/sbin:" /etc/init.d/ntpd
diff --git a/net-misc/ntp/ntp-4.2.0.20050303-r1.ebuild b/net-misc/ntp/ntp-4.2.0.20050303-r1.ebuild
index b45137d5f779..df4d3acb9f9f 100644
--- a/net-misc/ntp/ntp-4.2.0.20050303-r1.ebuild
+++ b/net-misc/ntp/ntp-4.2.0.20050303-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0.20050303-r1.ebuild,v 1.5 2006/03/31 00:37:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0.20050303-r1.ebuild,v 1.6 2006/05/25 22:33:48 exg Exp $
inherit eutils
@@ -13,11 +13,11 @@ SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/snapshots/ntp-stable/${PV
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="logrotate parse-clocks nodroproot selinux ssl ipv6 openntpd debug"
+IUSE="logrotate parse-clocks caps selinux ssl ipv6 openntpd debug"
RDEPEND=">=sys-libs/ncurses-5.2
>=sys-libs/readline-4.1
- kernel_linux? ( !nodroproot? ( sys-libs/libcap ) )
+ kernel_linux? ( caps? ( sys-libs/libcap ) )
!openntpd? ( !net-misc/openntpd )
ssl? ( dev-libs/openssl )
selinux? ( sec-policy/selinux-ntp )"
@@ -66,7 +66,7 @@ src_unpack() {
src_compile() {
hax_bitkeeper
econf \
- $(use_enable !nodroproot linuxcaps) \
+ $(use_enable caps linuxcaps) \
$(use_enable parse-clocks) \
$(use_enable ipv6) \
$(use_enable debug debugging) \
@@ -105,7 +105,7 @@ src_install() {
newconfd "${FILESDIR}"/ntpd.confd ntpd
newinitd "${FILESDIR}"/ntp-client.rc ntp-client
newconfd "${FILESDIR}"/ntp-client.confd ntp-client
- use nodroproot && dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
+ use caps || dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
dosed "s:-Q::" /etc/conf.d/ntp-client # no longer needed
dosed "s:/usr/bin:/usr/sbin:" /etc/init.d/ntpd
diff --git a/net-misc/ntp/ntp-4.2.0.20060224.ebuild b/net-misc/ntp/ntp-4.2.0.20060224.ebuild
index 043f64007db5..766896e3fd7b 100644
--- a/net-misc/ntp/ntp-4.2.0.20060224.ebuild
+++ b/net-misc/ntp/ntp-4.2.0.20060224.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0.20060224.ebuild,v 1.1 2006/05/04 01:10:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.0.20060224.ebuild,v 1.2 2006/05/25 22:33:48 exg Exp $
inherit eutils toolchain-funcs
@@ -13,11 +13,11 @@ SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/snapshots/ntp-stable/${PV
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="logrotate parse-clocks nodroproot selinux ssl ipv6 openntpd debug"
+IUSE="logrotate parse-clocks caps selinux ssl ipv6 openntpd debug"
RDEPEND=">=sys-libs/ncurses-5.2
>=sys-libs/readline-4.1
- kernel_linux? ( !nodroproot? ( sys-libs/libcap ) )
+ kernel_linux? ( caps? ( sys-libs/libcap ) )
!openntpd? ( !net-misc/openntpd )
ssl? ( dev-libs/openssl )
selinux? ( sec-policy/selinux-ntp )"
@@ -63,7 +63,7 @@ src_unpack() {
src_compile() {
hax_bitkeeper
econf \
- $(use_enable !nodroproot linuxcaps) \
+ $(use_enable caps linuxcaps) \
$(use_enable parse-clocks) \
$(use_enable ipv6) \
$(use_enable debug debugging) \
@@ -102,7 +102,7 @@ src_install() {
newconfd "${FILESDIR}"/ntpd.confd ntpd
newinitd "${FILESDIR}"/ntp-client.rc ntp-client
newconfd "${FILESDIR}"/ntp-client.confd ntp-client
- use nodroproot && dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
+ use caps || dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
dosed "s:-Q::" /etc/conf.d/ntp-client # no longer needed
dosed "s:/usr/bin:/usr/sbin:" /etc/init.d/ntpd