summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-19 15:33:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-19 15:33:33 +0000
commit32e2473ec19d65f0ad87c08403aad5d1afa3bd17 (patch)
tree8b88ffef773056e9ada0c1e75a13ec6454bbe4e4 /net-misc/ntp
parentMarked ppc-macos stable for progressive users (diff)
downloadgentoo-2-32e2473ec19d65f0ad87c08403aad5d1afa3bd17.tar.gz
gentoo-2-32e2473ec19d65f0ad87c08403aad5d1afa3bd17.tar.bz2
gentoo-2-32e2473ec19d65f0ad87c08403aad5d1afa3bd17.zip
Version bump #144107 by Conrad Kostecki.
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/ChangeLog7
-rw-r--r--net-misc/ntp/files/digest-ntp-4.2.2_p36
-rw-r--r--net-misc/ntp/ntp-4.2.2_p3.ebuild143
3 files changed, 155 insertions, 1 deletions
diff --git a/net-misc/ntp/ChangeLog b/net-misc/ntp/ChangeLog
index b9600e031119..dd98b652c29f 100644
--- a/net-misc/ntp/ChangeLog
+++ b/net-misc/ntp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ntp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.75 2006/07/16 07:03:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.76 2006/08/19 15:33:33 vapier Exp $
+
+*ntp-4.2.2_p3 (19 Aug 2006)
+
+ 19 Aug 2006; Mike Frysinger <vapier@gentoo.org> +ntp-4.2.2_p3.ebuild:
+ Version bump #144107 by Conrad Kostecki.
*ntp-4.2.2_p2 (16 Jul 2006)
diff --git a/net-misc/ntp/files/digest-ntp-4.2.2_p3 b/net-misc/ntp/files/digest-ntp-4.2.2_p3
new file mode 100644
index 000000000000..148eba1b81de
--- /dev/null
+++ b/net-misc/ntp/files/digest-ntp-4.2.2_p3
@@ -0,0 +1,6 @@
+MD5 d64a462838e8048da857975ebf13d2d4 ntp-4.2.2p3-manpages.tar.bz2 48839
+RMD160 ef4a57738db9978ba55d287795d866dad305bc38 ntp-4.2.2p3-manpages.tar.bz2 48839
+SHA256 c079192a64923de60d46a06f6e9c13aa6bd16f332deb287899e5f4286239ab90 ntp-4.2.2p3-manpages.tar.bz2 48839
+MD5 45cee6d1ebf8fe46e412fd818b8e7b74 ntp-4.2.2p3.tar.gz 2563397
+RMD160 fb377b5e7a561bca172e9ba71288a691c5f40f5e ntp-4.2.2p3.tar.gz 2563397
+SHA256 385a606007eb14f5847f033ac6fa8ea48366597ad1f93aa99864e1f82e23ac88 ntp-4.2.2p3.tar.gz 2563397
diff --git a/net-misc/ntp/ntp-4.2.2_p3.ebuild b/net-misc/ntp/ntp-4.2.2_p3.ebuild
new file mode 100644
index 000000000000..e0013f8d3cac
--- /dev/null
+++ b/net-misc/ntp/ntp-4.2.2_p3.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.2_p3.ebuild,v 1.1 2006/08/19 15:33:33 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_p/p}
+DESCRIPTION="Network Time Protocol suite/programs"
+HOMEPAGE="http://www.ntp.org/"
+SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV:0:3}/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}-manpages.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="logrotate parse-clocks caps selinux ssl ipv6 openntpd debug"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ kernel_linux? ( caps? ( sys-libs/libcap ) )
+ !openntpd? ( !net-misc/openntpd )
+ ssl? ( dev-libs/openssl )
+ selinux? ( sec-policy/selinux-ntp )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+PDEPEND="openntpd? ( net-misc/openntpd )"
+
+S=${WORKDIR}/${MY_P}
+
+hax_bitkeeper() {
+ # the makefiles have support for bk ...
+ # basically we have to do this or bk will try to write
+ # to files in /opt/bitkeeper causing sandbox violations ;(
+ mkdir "${T}"/fakebin
+ echo "#!/bin/sh"$'\n'"exit 1" > "${T}"/fakebin/bk
+ chmod a+x "${T}"/fakebin/bk
+ export PATH="${T}/fakebin:${PATH}"
+}
+
+pkg_setup() {
+ enewgroup ntp 123
+ enewuser ntp 123 -1 /dev/null ntp
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Needs to be ported ...
+ #epatch "${FILESDIR}"/4.2.0.20040617-hostname.patch
+
+ sed -i \
+ -e 's:md5\.h:touch_not_my_md5:g' \
+ -e 's:-lelf:-la_doe_a_deer_a_female_deer:g' \
+ -e 's:-lmd5:-li_dont_want_no_stinkin_md5:g' \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ hax_bitkeeper
+ econf \
+ $(use_enable caps linuxcaps) \
+ $(use_enable parse-clocks) \
+ $(use_enable ipv6) \
+ $(use_enable debug debugging) \
+ $(use_with ssl crypto) \
+ || die
+ emake || die
+}
+
+src_install() {
+ hax_bitkeeper
+ make install DESTDIR="${D}" || die "install failed"
+ # move ntpd/ntpdate to sbin #66671
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/{ntpd,ntpdate} "${D}"/usr/sbin/ || die "move to sbin"
+
+ dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
+ doman "${WORKDIR}"/man/*.[58]
+ dohtml -r html/*
+
+ insinto /usr/share/ntp
+ doins "${FILESDIR}"/ntp.conf
+ cp -r scripts/* "${D}"/usr/share/ntp/
+ chmod -R go-w "${D}"/usr/share/ntp
+ find "${D}"/usr/share/ntp \
+ '(' \
+ -name '*.in' -o \
+ -name 'Makefile*' -o \
+ -name 'rc[12]' -o \
+ -name support \
+ ')' \
+ -exec rm -r {} \;
+
+ insinto /etc
+ doins "${FILESDIR}"/ntp.conf
+ newinitd "${FILESDIR}"/ntpd.rc ntpd
+ newconfd "${FILESDIR}"/ntpd.confd ntpd
+ newinitd "${FILESDIR}"/ntp-client.rc ntp-client
+ newconfd "${FILESDIR}"/ntp-client.confd ntp-client
+ use caps || dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
+ dosed "s:-Q::" /etc/conf.d/ntp-client # no longer needed
+ dosed "s:/usr/bin:/usr/sbin:" /etc/init.d/ntpd
+
+ keepdir /var/lib/ntp
+ fowners ntp:ntp /var/lib/ntp
+
+ if use logrotate ; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/ntp.logrotate ntp
+ fi
+
+ if use openntpd ; then
+ cd "${D}"
+ rm usr/sbin/ntpd
+ rm -r var/lib
+ rm etc/{conf,init}.d/ntpd
+ fi
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/ntp.conf ]] ; then
+ rm -f "${D}"/etc/ntp.conf
+ fi
+}
+
+pkg_postinst() {
+ ewarn "You can find an example /etc/ntp.conf in /usr/share/ntp/"
+ ewarn "Review /etc/ntp.conf to setup server info."
+ ewarn "Review /etc/conf.d/ntpd to setup init.d info."
+ echo
+ einfo "The way ntp sets and maintains your system time has changed."
+ einfo "Now you can use /etc/init.d/ntp-client to set your time at"
+ einfo "boot while you can use /etc/init.d/ntpd to maintain your time"
+ einfo "while your machine runs"
+ if [[ -n $(egrep '^[^#].*notrust' "${ROOT}"/etc/ntp.conf) ]] ; then
+ echo
+ eerror "The notrust option was found in your /etc/ntp.conf!"
+ ewarn "If your ntpd starts sending out weird responses,"
+ ewarn "then make sure you have keys properly setup and see"
+ ewarn "http://bugs.gentoo.org/41827"
+ fi
+}