summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-09-29 15:23:54 +0000
committerAron Griffis <agriffis@gentoo.org>2001-09-29 15:23:54 +0000
commitbb7e0448a3c2d23e72d0aa45af7d5643958105f9 (patch)
tree55fcc99bf20e252769b55ec83a05a382141fff3f /net-misc/netkit-rsh
parentUpdated dump that builds with linux-headers-2.4.10 (diff)
downloadgentoo-2-bb7e0448a3c2d23e72d0aa45af7d5643958105f9.tar.gz
gentoo-2-bb7e0448a3c2d23e72d0aa45af7d5643958105f9.tar.bz2
gentoo-2-bb7e0448a3c2d23e72d0aa45af7d5643958105f9.zip
Made rsh, rlogin, rcp suid-root so they use a privileged source port.
These programs don't work otherwise, and this is how they are packaged in other distributions.
Diffstat (limited to 'net-misc/netkit-rsh')
-rw-r--r--net-misc/netkit-rsh/files/digest-netkit-rsh-0.17-r21
-rw-r--r--net-misc/netkit-rsh/netkit-rsh-0.17-r2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/netkit-rsh/files/digest-netkit-rsh-0.17-r2 b/net-misc/netkit-rsh/files/digest-netkit-rsh-0.17-r2
new file mode 100644
index 000000000000..e9b559a0d711
--- /dev/null
+++ b/net-misc/netkit-rsh/files/digest-netkit-rsh-0.17-r2
@@ -0,0 +1 @@
+MD5 65f5f28e2fe22d9ad8b17bb9a10df096 netkit-rsh-0.17.tar.gz
diff --git a/net-misc/netkit-rsh/netkit-rsh-0.17-r2.ebuild b/net-misc/netkit-rsh/netkit-rsh-0.17-r2.ebuild
new file mode 100644
index 000000000000..bb93b19bf9aa
--- /dev/null
+++ b/net-misc/netkit-rsh/netkit-rsh-0.17-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/netkit-rsh-0.17-r2.ebuild,v 1.1 2001/09/29 15:23:54 agriffis Exp $
+
+P=netkit-rsh-0.17
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Netkit - rshd"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${A}"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.72"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${O}/files/rlogind-auth.diff || die
+}
+
+src_compile() {
+ ./configure || die
+ cp MCONFIG MCONFIG.orig
+ sed -e "s/-pipe -O2/${CFLAGS}/" -e "s:-Wpointer-arith::" MCONFIG.orig > MCONFIG
+ make || die
+}
+
+src_install() {
+ into /usr
+ dobin rcp/rcp
+ fperms 1755 /usr/bin/rcp
+ doman rcp/rcp.1
+ dobin rexec/rexec
+ doman rexec/rexec.1
+ dosbin rexecd/rexecd
+ dosym rexecd /usr/sbin/in.rexecd
+ doman rexecd/rexecd.8
+ dosym rexecd.8.gz /usr/share/man/man8/in.rexecd.8.gz
+ dobin rlogin/rlogin
+ fperms 1755 /usr/bin/rlogin
+ doman rlogin/rlogin.1
+ dosbin rlogind/rlogind
+ dosym rlogind /usr/sbin/in.rlogind
+ doman rlogind/rlogind.8
+ dosym rlogind.8.gz /usr/share/man/man8/in.rlogind.8.gz
+ dobin rsh/rsh
+ fperms 1755 /usr/bin/rsh
+ doman rsh/rsh.1
+ dosbin rshd/rshd
+ dosym rshd /usr/sbin/in.rshd
+ doman rshd/rshd.8
+ dosym rshd.8.gz /usr/share/man/man8/in.rshd.8.gz
+ dodoc README ChangeLog BUGS
+ newdoc rexec/README README.rexec
+}