summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-02 13:47:59 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-02 13:47:59 +0000
commitb96c7be919fa0c176e5000825396075ea9406864 (patch)
tree542da3c8f1b8c1c1bda5bac8623236e74fc9af22 /net-misc/netkit-rsh
parentFixing compatibility of wrapper so it REALLY works with /bin/sh (Bug #203987) (diff)
downloadgentoo-2-b96c7be919fa0c176e5000825396075ea9406864.tar.gz
gentoo-2-b96c7be919fa0c176e5000825396075ea9406864.tar.bz2
gentoo-2-b96c7be919fa0c176e5000825396075ea9406864.zip
Respect env LDFLAGS. Respect CC for everyone, not just cross-compilers #203911 by Davide Cendron.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-misc/netkit-rsh')
-rw-r--r--net-misc/netkit-rsh/ChangeLog8
-rw-r--r--net-misc/netkit-rsh/netkit-rsh-0.17-r8.ebuild16
2 files changed, 15 insertions, 9 deletions
diff --git a/net-misc/netkit-rsh/ChangeLog b/net-misc/netkit-rsh/ChangeLog
index 2cabf5275ee7..4f052340bf69 100644
--- a/net-misc/netkit-rsh/ChangeLog
+++ b/net-misc/netkit-rsh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/netkit-rsh
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/ChangeLog,v 1.46 2007/07/23 05:31:28 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/ChangeLog,v 1.47 2008/01/02 13:47:59 vapier Exp $
+
+ 02 Jan 2008; Mike Frysinger <vapier@gentoo.org> netkit-rsh-0.17-r8.ebuild:
+ Respect env LDFLAGS. Respect CC for everyone, not just cross-compilers
+ #203911 by Davide Cendron.
23 Jul 2007; Mike Frysinger <vapier@gentoo.org> netkit-rsh-0.17-r8.ebuild:
Punt bindnow-flags usage.
diff --git a/net-misc/netkit-rsh/netkit-rsh-0.17-r8.ebuild b/net-misc/netkit-rsh/netkit-rsh-0.17-r8.ebuild
index fc22b9faaa65..d4c84cbe9100 100644
--- a/net-misc/netkit-rsh/netkit-rsh-0.17-r8.ebuild
+++ b/net-misc/netkit-rsh/netkit-rsh-0.17-r8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/netkit-rsh-0.17-r8.ebuild,v 1.10 2007/07/23 05:31:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/netkit-rsh-0.17-r8.ebuild,v 1.11 2008/01/02 13:47:59 vapier Exp $
inherit eutils pam toolchain-funcs
@@ -30,20 +30,22 @@ src_unpack() {
EPATCH_SUFFIX="patch"
epatch "${WORKDIR}"/patch
fi
+
+ if tc-is-cross-compiler ; then
+ # Can't do runtime tests when cross-compiling
+ sed -i -e "s|./__conftest|: ./__conftest|" configure
+ fi
}
src_compile() {
local myconf
use pam || myconf="--without-pam"
- if tc-is-cross-compiler; then
- tc-export CC
- # Can't do runtime tests when cross-compiling
- sed -i -e "s|./__conftest|: ./__conftest|" configure
- fi
+ tc-export CC
./configure ${myconf} || die
sed -i \
-e "s:-pipe -O2:${CFLAGS}:" \
+ -e "/^LDFLAGS=$/d" \
-e "s:-Wpointer-arith::" \
MCONFIG || die "could not sed MCONFIG"
emake || die