summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2006-06-28 17:28:03 +0000
committerJoel Martin <kanaka@gentoo.org>2006-06-28 17:28:03 +0000
commit90ff52b1545c567b9113cf033895f18db1e70f3e (patch)
tree054849e5365ea56e6ec0e0d0f20097625a0b8d74 /net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild
parentBug 138332, the Makefile being distributed was causing sandbox problems. Also... (diff)
downloadgentoo-2-90ff52b1545c567b9113cf033895f18db1e70f3e.tar.gz
gentoo-2-90ff52b1545c567b9113cf033895f18db1e70f3e.tar.bz2
gentoo-2-90ff52b1545c567b9113cf033895f18db1e70f3e.zip
Allow cross-compiling by sed-removing runtime tests from lame non-autoconf configure script.
(Portage version: 2.1-r1)
Diffstat (limited to 'net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild')
-rw-r--r--net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild b/net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild
index b4aa008f1920..3d37eedfc158 100644
--- a/net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild
+++ b/net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild,v 1.10 2005/08/22 22:15:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/netkit-rsh-0.17-r6.ebuild,v 1.11 2006/06/28 17:28:03 kanaka Exp $
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Netkit's Remote Shell Suite: rexec{,d} rlogin{,d} rsh{,d}"
HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
@@ -33,12 +33,17 @@ src_unpack() {
src_compile() {
local myconf
use pam || myconf="--without-pam"
+ if tc-is-cross-compiler; then
+ tc-export CC
+ # Can't do runtime tests when cross-compiling
+ sed -i -e "s|./__conftest|: ./__conftest|" configure
+ fi
./configure ${myconf} || die
sed -i \
-e "s:-pipe -O2:${CFLAGS}:" \
-e "s:-Wpointer-arith::" \
- MCONFIG
+ MCONFIG || die "could not sed MCONFIG"
make || die
}