summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-02 16:26:09 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-02 16:26:09 +0000
commiteb466cf55dfcd8c881118bbec56c6bf937da0f93 (patch)
tree9ccf0769a55075a52abd8e5d1e0260e7ed5cb29a /net-misc/netctl
parentUpdate dependency on virtual/jpeg. (diff)
downloadgentoo-2-eb466cf55dfcd8c881118bbec56c6bf937da0f93.tar.gz
gentoo-2-eb466cf55dfcd8c881118bbec56c6bf937da0f93.tar.bz2
gentoo-2-eb466cf55dfcd8c881118bbec56c6bf937da0f93.zip
Version bump.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog8
-rw-r--r--net-misc/netctl/netctl-1.1-r1.ebuild6
-rw-r--r--net-misc/netctl/netctl-1.2.ebuild79
-rw-r--r--net-misc/netctl/netctl-9999.ebuild9
4 files changed, 95 insertions, 7 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index b54bd43c9110..0e349627a3eb 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/netctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.11 2013/06/14 00:00:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.12 2013/08/02 16:26:09 floppym Exp $
+
+*netctl-1.2 (02 Aug 2013)
+
+ 02 Aug 2013; Mike Gilbert <floppym@gentoo.org> +netctl-1.2.ebuild,
+ netctl-1.1-r1.ebuild, netctl-9999.ebuild:
+ Version bump.
14 Jun 2013; Mike Gilbert <floppym@gentoo.org> -netctl-0.8.ebuild,
-netctl-1.0.ebuild, -netctl-1.1.ebuild, netctl-1.1-r1.ebuild,
diff --git a/net-misc/netctl/netctl-1.1-r1.ebuild b/net-misc/netctl/netctl-1.1-r1.ebuild
index 2519714899f8..a7e9a9f0318a 100644
--- a/net-misc/netctl/netctl-1.1-r1.ebuild
+++ b/net-misc/netctl/netctl-1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.1-r1.ebuild,v 1.5 2013/06/14 00:00:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.1-r1.ebuild,v 1.6 2013/08/02 16:26:09 floppym Exp $
EAPI=5
@@ -16,7 +16,9 @@ else
fi
DESCRIPTION="Profile based network connection tool from Arch Linux"
-HOMEPAGE="https://www.archlinux.org/netctl/"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
LICENSE="BSD"
SLOT="0"
IUSE=""
diff --git a/net-misc/netctl/netctl-1.2.ebuild b/net-misc/netctl/netctl-1.2.ebuild
new file mode 100644
index 000000000000..1cab12543055
--- /dev/null
+++ b/net-misc/netctl/netctl-1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.2.ebuild,v 1.1 2013/08/02 16:26:09 floppym Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+ DEPEND="app-text/asciidoc"
+else
+ SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ virtual/pkgconfig
+ sys-apps/systemd
+"
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+ !<net-misc/dhcpcd-5.6.7
+"
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
+
+optfeature() {
+ local desc=$1
+ shift
+ while (( $# )); do
+ if has_version "$1"; then
+ elog " [I] $1 for ${desc}"
+ else
+ elog " [ ] $1 for ${desc}"
+ fi
+ shift
+ done
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To get additional features, a number of optional runtime dependencies may be"
+ elog "installed."
+ optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
+ optfeature "WPA support" net-wireless/wpa_supplicant
+ optfeature "interactive assistant" dev-util/dialog
+ optfeature "automatic connection" sys-apps/ifplugd
+ optfeature "bonding support" net-misc/ifenslave
+ optfeature "dialup support" net-dialup/ppp
+ fi
+}
diff --git a/net-misc/netctl/netctl-9999.ebuild b/net-misc/netctl/netctl-9999.ebuild
index 642982932a74..35aefb29ecbc 100644
--- a/net-misc/netctl/netctl-9999.ebuild
+++ b/net-misc/netctl/netctl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.9 2013/06/14 00:00:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.10 2013/08/02 16:26:09 floppym Exp $
EAPI=5
@@ -16,7 +16,9 @@ else
fi
DESCRIPTION="Profile based network connection tool from Arch Linux"
-HOMEPAGE="https://www.archlinux.org/netctl/"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -65,14 +67,13 @@ optfeature() {
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To get additional features, a number of option runtime dependencies may be"
+ elog "To get additional features, a number of optional runtime dependencies may be"
elog "installed."
optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
optfeature "WPA support" net-wireless/wpa_supplicant
optfeature "interactive assistant" dev-util/dialog
optfeature "automatic connection" sys-apps/ifplugd
optfeature "bonding support" net-misc/ifenslave
- optfeature "bridge support" net-misc/bridge-utils
optfeature "dialup support" net-dialup/ppp
fi
}