summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-08-07 19:44:11 +0000
committerMike Gilbert <floppym@gentoo.org>2014-08-07 19:44:11 +0000
commit25187a8989e485392c5cbe04ae70c6273595d054 (patch)
tree20c900b8845374f6ec7de98b74e02f90152f9029 /net-misc/netctl
parentStable for HPPA (bug #512012). (diff)
downloadgentoo-2-25187a8989e485392c5cbe04ae70c6273595d054.tar.gz
gentoo-2-25187a8989e485392c5cbe04ae70c6273595d054.tar.bz2
gentoo-2-25187a8989e485392c5cbe04ae70c6273595d054.zip
Version bump.
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog7
-rw-r--r--net-misc/netctl/netctl-1.9.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index 657de338ed94..77fa5a339b51 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/netctl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.22 2014/06/21 17:55:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.23 2014/08/07 19:44:11 floppym Exp $
+
+*netctl-1.9 (07 Aug 2014)
+
+ 07 Aug 2014; Mike Gilbert <floppym@gentoo.org> +netctl-1.9.ebuild:
+ Version bump.
*netctl-1.8 (21 Jun 2014)
diff --git a/net-misc/netctl/netctl-1.9.ebuild b/net-misc/netctl/netctl-1.9.ebuild
new file mode 100644
index 000000000000..ec715d7a24c1
--- /dev/null
+++ b/net-misc/netctl/netctl-1.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.9.ebuild,v 1.1 2014/08/07 19:44:11 floppym Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+ DEPEND="app-text/asciidoc"
+else
+ SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ virtual/pkgconfig
+ sys-apps/systemd
+"
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+ !<net-misc/dhcpcd-6.4.0
+"
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
+
+optfeature() {
+ local desc=$1
+ shift
+ while (( $# )); do
+ if has_version "$1"; then
+ elog " [I] $1 for ${desc}"
+ else
+ elog " [ ] $1 for ${desc}"
+ fi
+ shift
+ done
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To get additional features, a number of optional runtime dependencies may be"
+ elog "installed."
+ optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
+ optfeature "WPA support" net-wireless/wpa_supplicant
+ optfeature "interactive assistant" dev-util/dialog
+ optfeature "automatic connection" sys-apps/ifplugd
+ optfeature "bonding support" net-misc/ifenslave
+ optfeature "dialup support" net-dialup/ppp
+ fi
+}