summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-20 13:08:24 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-20 13:08:24 +0000
commitaa22b6dd9f03b266c1b631dedcae8ac102aa388d (patch)
tree9281c00b90dc5dc6634e52455eb33f3638458e69 /net-misc/mosh
parentstable the stable series (diff)
downloadgentoo-2-aa22b6dd9f03b266c1b631dedcae8ac102aa388d.tar.gz
gentoo-2-aa22b6dd9f03b266c1b631dedcae8ac102aa388d.tar.bz2
gentoo-2-aa22b6dd9f03b266c1b631dedcae8ac102aa388d.zip
respect bashcompdir (bug 477384)
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-misc/mosh')
-rw-r--r--net-misc/mosh/ChangeLog6
-rw-r--r--net-misc/mosh/mosh-1.2.4.ebuild15
-rw-r--r--net-misc/mosh/mosh-9999.ebuild19
3 files changed, 19 insertions, 21 deletions
diff --git a/net-misc/mosh/ChangeLog b/net-misc/mosh/ChangeLog
index 5a7bc554de23..38dd9ad4feb6 100644
--- a/net-misc/mosh/ChangeLog
+++ b/net-misc/mosh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/mosh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.43 2013/06/11 09:40:21 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.44 2013/07/20 13:08:24 xmw Exp $
+
+ 20 Jul 2013; Michael Weber <xmw@gentoo.org> mosh-1.2.4.ebuild,
+ mosh-9999.ebuild:
+ respect bashcompdir (bug 477384)
11 Jun 2013; Michael Weber <xmw@gentoo.org> -mosh-1.2.2.ebuild,
-mosh-1.2.3.95_rc1.ebuild, -mosh-1.2.3.ebuild:
diff --git a/net-misc/mosh/mosh-1.2.4.ebuild b/net-misc/mosh/mosh-1.2.4.ebuild
index 12bcb26513ca..a3c756e07c59 100644
--- a/net-misc/mosh/mosh-1.2.4.ebuild
+++ b/net-misc/mosh/mosh-1.2.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-1.2.4.ebuild,v 1.4 2013/05/20 12:42:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-1.2.4.ebuild,v 1.5 2013/07/20 13:08:23 xmw Exp $
EAPI=4
-inherit autotools vcs-snapshot
+inherit autotools bash-completion-r1 vcs-snapshot
DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
HOMEPAGE="http://mosh.mit.edu"
@@ -13,7 +13,7 @@ SRC_URI="http://mosh.mit.edu/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~mips ppc x86 ~arm-linux ~x86-linux"
-IUSE="bash-completion +client examples +mosh-hardening +server ufw +utempter"
+IUSE="+client examples +mosh-hardening +server ufw +utempter"
REQUIRED_USE="|| ( client server )
examples? ( client )"
@@ -32,7 +32,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable bash-completion completion) \
+ --disable-completion \
$(use_enable client) \
$(use_enable server) \
$(use_enable examples) \
@@ -53,9 +53,6 @@ src_install() {
elog "${myprog} installed as ${PN}-$(basename ${myprog})"
done
- if use bash-completion ; then
- insinto /usr/share/bash-completion
- doins "${ED}"/etc/bash_completion.d/mosh
- rm -rf "${ED}"/etc/bash_completion.d
- fi
+ # bug 477384
+ dobashcomp conf/bash_completion.d/mosh
}
diff --git a/net-misc/mosh/mosh-9999.ebuild b/net-misc/mosh/mosh-9999.ebuild
index e5fb6220dc9c..ae06a7a3292b 100644
--- a/net-misc/mosh/mosh-9999.ebuild
+++ b/net-misc/mosh/mosh-9999.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.13 2013/03/13 19:19:51 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.14 2013/07/20 13:08:23 xmw Exp $
-EAPI=4
-EGIT_REPO_URI="https://github.com/keithw/mosh.git"
+EAPI=5
-inherit autotools git-2
+inherit autotools bash-completion-r1 git-2
DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
HOMEPAGE="http://mosh.mit.edu"
+EGIT_REPO_URI="https://github.com/keithw/mosh.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="bash-completion +client examples +mosh-hardening +server ufw +utempter"
+IUSE="+client examples +mosh-hardening +server ufw +utempter"
REQUIRED_USE="|| ( client server )
examples? ( client )"
@@ -33,7 +33,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable bash-completion completion) \
+ --disable-completion \
$(use_enable client) \
$(use_enable server) \
$(use_enable examples) \
@@ -54,9 +54,6 @@ src_install() {
elog "${myprog} installed as ${PN}-$(basename ${myprog})"
done
- if use bash-completion ; then
- insinto /usr/share/bash-completion
- doins "${ED}"/etc/bash_completion.d/mosh
- rm -rf "${ED}"/etc/bash_completion.d
- fi
+ # bug 477384
+ dobashcomp conf/bash_completion.d/mosh
}