summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-11-16 20:16:04 +0000
committerJohannes Huber <johu@gentoo.org>2012-11-16 20:16:04 +0000
commit2e3b08d33540440671f1992bf292ddc18297ac95 (patch)
tree06e270703a1815fcf66c2b78541c5a87091bc931 /net-misc/mirall
parentworkaround for bug 399061 (diff)
downloadgentoo-2-2e3b08d33540440671f1992bf292ddc18297ac95.tar.gz
gentoo-2-2e3b08d33540440671f1992bf292ddc18297ac95.tar.bz2
gentoo-2-2e3b08d33540440671f1992bf292ddc18297ac95.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-misc/mirall')
-rw-r--r--net-misc/mirall/ChangeLog7
-rw-r--r--net-misc/mirall/mirall-1.1.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/net-misc/mirall/ChangeLog b/net-misc/mirall/ChangeLog
index b1b44105fb78..7c70964a7070 100644
--- a/net-misc/mirall/ChangeLog
+++ b/net-misc/mirall/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/mirall
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mirall/ChangeLog,v 1.7 2012/10/15 08:19:54 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mirall/ChangeLog,v 1.8 2012/11/16 20:16:04 johu Exp $
+
+*mirall-1.1.1 (16 Nov 2012)
+
+ 16 Nov 2012; Johannes Huber <johu@gentoo.org> +mirall-1.1.1.ebuild:
+ Version bump.
15 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> mirall-1.1.0.ebuild:
Fix finding csync when we are not using the internal one. Resolves bug#438290.
diff --git a/net-misc/mirall/mirall-1.1.1.ebuild b/net-misc/mirall/mirall-1.1.1.ebuild
new file mode 100644
index 000000000000..6a0a1e001be0
--- /dev/null
+++ b/net-misc/mirall/mirall-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mirall/mirall-1.1.1.ebuild,v 1.1 2012/11/16 20:16:04 johu Exp $
+
+EAPI=4
+
+LANG_DIR="translations"
+PLOCALES="af ar ar_SA bg_BG ca cs_CZ da de el en eo es es_AR et_EE eu eu_ES fa fi fi_FI fr gl he hi hr hu_HU hy ia id id_ID it ja_JP ko lb lt_LT lv mk nb_NO nl nn_NO oc pl pl_PL pt_BR pt_PT ro ru ru_RU sk_SK sl sr sr@latin sv tr uk vi zh_CN zh_TW"
+inherit cmake-utils l10n
+
+DESCRIPTION="Synchronization of your folders with another computers"
+HOMEPAGE="http://owncloud.org/"
+SRC_URI="http://download.owncloud.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-misc/csync-0.60.0[sftp,samba,webdav]
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Yay for fcked detection.
+ export CSYNC_DIR="${EPREFIX}/usr/include/ocsync/"
+
+ local lang
+ for lang in ${PLOCALES} ; do
+ if ! use linguas_${lang} ; then
+ rm ${LANG_DIR}/${PN}_${lang}.ts
+ fi
+ done
+}